X
Tap here to go to the mobile version of the site.

Support Forum

Can't save images - not responding

Posted

With the latest Firefox on Windows 8.1, if I right click to save an image, it doesn't work. The Save screen comes up, but the buttons along the bottom are missing. The blue circle is spinning. Then it will say "not responding: and there is no way to get out, except to close the program. I've tried turning off other programs and starting in safe mode, with no add-ons, but I have the same problem.

With the latest Firefox on Windows 8.1, if I right click to save an image, it doesn't work. The Save screen comes up, but the buttons along the bottom are missing. The blue circle is spinning. Then it will say "not responding: and there is no way to get out, except to close the program. I've tried turning off other programs and starting in safe mode, with no add-ons, but I have the same problem.

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Google Update
  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • VLC media player Web Plugin 2.0.6
  • GEPlugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • iTunes Detector Plug-in
  • WinZip Courier Plugin for Mozilla Firefox
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Cutyfox URL Shortener (bit.ly, is.gd, goo.gl) 1.4.1 (cutyfox@apps.metzweb.net)
  • Easy YouTube Video Downloader 7.0 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • VideoDownloadConverter 5.33.2.8238 (4zffxtbr@VideoDownloadConverter_4z.com)
  • WinZip Courier 3.5 ({74c841e3-b59f-479e-8d7a-e26a942a87c8})
  • AVG SafeGuard toolbar 17.0.1.12 (avg@toolbar) (Inactive)
  • SmartPrintButton 1.0 (quickprint@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 5450
  • adapterDescription2:
  • adapterDeviceID: 0x68f9
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 9-10-2013
  • driverDate2:
  • driverVersion: 13.152.1.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5450 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: about:blank
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: w3i&type=W3i_DS,136,0_0,Search,20130832,19890,0,68,0
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.google.com/advanced_search
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • font.minimum-size.x-western: 14
  • font.name.monospace.x-western: Lucida Console
  • font.size.fixed.x-western: 16
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.tb.ask.com/search/GGmain.jhtml?st=kwd&ptb=C8AD8DBB-6A78-486D-A072-7D5C6130DCE1&n=77fd2d50&ind=2013080912&p2=^HJ^xdm003^YYA^us&si=CKj035nq8LgCFcJj7AodyGUA2A&searchfor=
  • network.cookie.cookieBehavior: 1
  • network.cookie.prefsMigrated: True
  • network.http.max-connections-per-server: 8
  • network.protocol-handler.warn-external.dnupdate: False
  • places.database.lastMaintenance: 1382368851
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npsitesafety: 2
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.mixed_content.block_active_content: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1381943477

Misc

  • User JS: Yes
  • Accessibility: No
SHASHANK ROY 14 solutions 119 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Question owner

That fixed it, thank you!

That fixed it, thank you!

Question owner

Well, the problem came back, after turning off hardware acceleration. I just upgraded to the new version 25.0 and I still have the problem. I updated 2 addons. I restarted in safe mode without addons, and I still have the problem. Sometimes File/Save page as has the same problem.

Well, the problem came back, after turning off hardware acceleration. I just upgraded to the new version 25.0 and I still have the problem. I updated 2 addons. I restarted in safe mode without addons, and I still have the problem. Sometimes File/Save page as has the same problem.
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers
Does it help if you boot the computer in Safe mode? *http://windows.microsoft.com/en-US/windows-8/windows-startup-settings-including-safe-mode

Question owner

I can't figure out how to boot in safe mode in Windows 8.1. I tried to follow the instructions, but after "PC settings" there is no "general".

One thing - with Firefox 24, it would not even show the buttons on the Save as screen. With 25 it does show the buttons, but it locks up if you try to save.

I can't figure out how to boot in safe mode in Windows 8.1. I tried to follow the instructions, but after "PC settings" there is no "general". One thing - with Firefox 24, it would not even show the buttons on the Save as screen. With 25 it does show the buttons, but it locks up if you try to save.

Question owner

Well, now it is working, with add-ons.

Well, now it is working, with add-ons.
rherber1 0 solutions 4 answers

I am using Firefox 26.0 with WinXP Pro SP3 (oldie but a goodie) and my problem with Save Image As is slightly different.

On this website http://recordsearch.naa.gov.au/scripts/Imagine.asp?B=31735088 there are 33 separate image pages in .JPG format in the file. To save images in high resolution first click on the Enlarge option at top left. Now right-click on the image and select Save Image As and you should get the save folder & file name screen as expected. In a normal situation the folder to save the file in and the filename can be modified to whatever is desired as long as the extension remains unaltered. It will be noted here that the default filename has a .asp extension. It becomes necessary to change the extension from .asp to .jpg for each of the 33 image pages in the file otherwise the image viewer program can't open them later. I dare say that the pages could all be saved with the .asp extension butit would then be necessary to go back and rename them to .jpg later. Quite inconvenient really....

IE8 doesn't have this problem. It correctly identifies the images as .jpg so saving is a simple task. Firefox has a problem which should be easy to fix. Surely it shouldn't be difficult for it to recognise a filename extension correctly.

I am using Firefox 26.0 with WinXP Pro SP3 (oldie but a goodie) and my problem with Save Image As is slightly different. On this website http://recordsearch.naa.gov.au/scripts/Imagine.asp?B=31735088 there are 33 separate image pages in .JPG format in the file. To save images in high resolution first click on the Enlarge option at top left. Now right-click on the image and select Save Image As and you should get the save folder & file name screen as expected. In a normal situation the folder to save the file in and the filename can be modified to whatever is desired as long as the extension remains unaltered. It will be noted here that the default filename has a .asp extension. It becomes necessary to change the extension from .asp to .jpg for each of the 33 image pages in the file otherwise the image viewer program can't open them later. I dare say that the pages could all be saved with the .asp extension butit would then be necessary to go back and rename them to .jpg later. Quite inconvenient really.... IE8 doesn't have this problem. It correctly identifies the images as .jpg so saving is a simple task. Firefox has a problem which should be easy to fix. Surely it shouldn't be difficult for it to recognise a filename extension correctly.
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Hi rherber1

If I right-click the image and use "Save Image As" then Firefox offers to store the image as "ShowImage.asp.jpeg" for me.
So the file type should be OK and you should only have to add the image number.
If I save the image via "Tools > Page Info > Media" then I get "ShowImage.asp" without the jpeg appended.

I see these HTTP response headers with the Live Http Headers extension.

HTTP/1.1 200 OK
Connection: close
Date: Mon, 06 Jan 2014 23:31:49 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Content-Type: image/jpeg
Expires: Mon, 06 Jan 2014 23:31:49 GMT
Cache-Control: private
Hi rherber1 If I right-click the image and use "Save Image As" then Firefox offers to store the image as "ShowImage.asp.jpeg" for me.<br /> So the file type should be OK and you should only have to add the image number.<br /> If I save the image via "Tools > Page Info > Media" then I get "ShowImage.asp" without the jpeg appended. I see these HTTP response headers with the Live Http Headers extension. * https://addons.mozilla.org/firefox/addon/live-http-headers/ <pre><nowiki>HTTP/1.1 200 OK Connection: close Date: Mon, 06 Jan 2014 23:31:49 GMT Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET Content-Type: image/jpeg Expires: Mon, 06 Jan 2014 23:31:49 GMT Cache-Control: private </nowiki></pre>
rherber1 0 solutions 4 answers

If I right-click the image and use "Save Image As" then Firefox offers to store the image as "ShowImage.asp.jpeg" for me.

In this instance the file type box does suggest that it will be saved as a JPEG Image but it doesn't actually add .jpg after the .asp when saving. The file saved is simply ShowImage.asp

If I save the image via "Tools > Page Info > Media" then I get "ShowImage.asp" without the jpeg appended.

I also tried this method and as you say only the .asp is included as the extension.

'''If I right-click the image and use "Save Image As" then Firefox offers to store the image as "ShowImage.asp.jpeg" for me.''' In this instance the file type box does suggest that it will be saved as a JPEG Image but it doesn't actually add .jpg after the .asp when saving. The file saved is simply ShowImage.asp '''If I save the image via "Tools > Page Info > Media" then I get "ShowImage.asp" without the jpeg appended. ''' I also tried this method and as you say only the .asp is included as the extension.
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Did you check the file type in the Properties of this file because Windows has a tendency to hide some file extensions and it is quite possible that this file has a .jpeg file extension if Firefox shows this when saving the file.

Did you check the file type in the Properties of this file because Windows has a tendency to hide some file extensions and it is quite possible that this file has a .jpeg file extension if Firefox shows this when saving the file.
rherber1 0 solutions 4 answers

I know the image type is .jpg because that is the format which NAA save all their documents. Firefox does NOT show it as a .jpg image in the save dialog box and it does not save it with a .jpg extension no matter whether it suggests that it can do so in the file type box.

It is not a Windows issue. I have the full filename display option in Windows Explorer enabled and even If the .jpg extension were hidden then the image viewer (I use Irfanview) would correctly identify it as such and display it. Any saved images which are viewable by Irfanview will have the Irfanview logo alongside it in the explorer file listing. The image saved by Firefox does not have the Irfanview logo and this image can only be viewed after I edit the file extension from .asp to .jpg.

As I said in my first post IE correctly shows the image type as .jpg in the "Save Image As" dialog box whereas Firefox shows it as .asp. This is purely a Firefox problem.

I know the image type is .jpg because that is the format which NAA save all their documents. Firefox does NOT show it as a .jpg image in the save dialog box and it does not save it with a .jpg extension no matter whether it suggests that it can do so in the file type box. It is not a Windows issue. I have the full filename display option in Windows Explorer enabled and even If the .jpg extension were hidden then the image viewer (I use Irfanview) would correctly identify it as such and display it. Any saved images which are viewable by Irfanview will have the Irfanview logo alongside it in the explorer file listing. The image saved by Firefox does not have the Irfanview logo and this image can only be viewed after I edit the file extension from .asp to .jpg. As I said in my first post IE correctly shows the image type as .jpg in the "Save Image As" dialog box whereas Firefox shows it as .asp. This is purely a Firefox problem.

Modified by rherber1

cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

You can try to increase the value of the browser.download.saveLinkAsFilenameTimeout pref on the about:config page to 8000 or more.
You can open the about:config page via the location bar.

You can try to increase the value of the browser.download.saveLinkAsFilenameTimeout pref on the <b>about:config</b> page to 8000 or more.<br /> You can open the <b>about:config</b> page via the location bar.
rherber1 0 solutions 4 answers

Tried your suggested change to saveLinkAsFilenameTimeout (about:config) and no difference. Still saves image as .asp

To my mind Firefox is simply not able to recognise the image as a .jpg. It seems to default to the ASP.NET function and applies this as an extension to the image type. If IE can get it right then there has to be a problem with Firefox....

Tried your suggested change to '''saveLinkAsFilenameTimeout''' (about:config) and no difference. Still saves image as .asp To my mind Firefox is simply not able to recognise the image as a .jpg. It seems to default to the ASP.NET function and applies this as an extension to the image type. If IE can get it right then there has to be a problem with Firefox....
galileo 0 solutions 1 answers

Help please! Either with the latest Firefox or with Chrome, the same problem occurs: When I copy (right-click or ctrl-C) an image from a webpage and try to paste it elsewhere (in Word, in Wordpress etc.), I can only paste the FIRST image that I copied, again and again. If I try to copy-paste other images from the same page, it will only paste the first image that I copied. How could that be fixed?! Thank you, ÉRIC

Help please! Either with the latest '''Firefox '''or with '''Chrome''', the same problem occurs: When I copy (right-click or ctrl-C) an '''image '''from a '''webpage''' and try to paste it elsewhere (in Word, in Wordpress etc.), I can '''only '''paste the '''FIRST '''image that I copied, again and again. If I try to copy-paste other images from the same page, it will only paste the first image that I copied. How could that be fixed?! Thank you, ÉRIC
UnknownVT 0 solutions 3 answers

I am on Firefox 27.0.1 (latest version, set on auto update) and Windows 8.1 (64-bit) - on a new HP TouchSmart 11 notebook (11-E010nr, AMD A4-1250) Checked and made sure the HP recommended graphics driver is installed for my notebok and OS.

Neither Save Image as nor Save Page As work for me -

click on either of those options and nothing happens - no window opens to offer to save.

Checked download history - nothing.

(I also have a desktop with Windows 7 and latest Firefox (on auto update) - for years, so know how it's supposed to work)

I have disabled Hardware acceleration and restarted Firefox - does not work.

Even tried these: disabling WebGL about:config > webgl.disable set to true

browser.download.saveLinkAsFilenameTimeout set to 8000

None of those worked - still cannot save either page nor image as.

Be grateful for any advice, please.

Thank you.

I am on Firefox 27.0.1 (latest version, set on auto update) and Windows 8.1 (64-bit) - on a new HP TouchSmart 11 notebook (11-E010nr, AMD A4-1250) Checked and made sure the HP recommended graphics driver is installed for my notebok and OS. Neither Save Image as nor Save Page As work for me - click on either of those options and nothing happens - no window opens to offer to save. Checked download history - nothing. (I also have a desktop with Windows 7 and latest Firefox (on auto update) - for years, so know how it's supposed to work) I have disabled Hardware acceleration and restarted Firefox - does not work. Even tried these: disabling WebGL about:config > webgl.disable set to true browser.download.saveLinkAsFilenameTimeout set to 8000 None of those worked - still cannot save either page nor image as. Be grateful for any advice, please. Thank you.