X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I am unable to open pdf files in firefox, and I have tried all the solutions proposed by others. How can I re-enable pdf viewing in firefox?

Posted

I have recently switched to Firefox from Google Chrome, and I am finding that I am unable to open any pdf files from the web in any way in Firefox. I cannot download them and open them in Adobe Reader, and I cannot preview them in Firefox, nor can I use the Adobe plugin. I have tried to use the solutions posed by users on this site, but none of them have worked. Any time I make a change to settings to try to solve this issue, the change never allows me to view the pdf file, and the setting reverts to the previous setting after the browser has been restarted. I don't care how I view the file, but I need to either be able to view it as a preview or I need to be able to download it.

Chosen solution

I'm using an adobe downloading add-on, 3.0.0.2, and I have disabled it. Now I can actually open pdf files in my browser as previews, or download them as I see fit. Thanks!

But clearly there's an error with the add-on.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Version 4.8.0.15566
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.04
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX VOD Helper Plug-in
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.20513.0
  • DivX Plus Web Player version 2.3.1.51
  • iPhoto6
  • Simple plug-in that handles Citrix connection files

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • PDF Download 3.0.0.2 ({37E4D8EA-8BDA-4831-8EA1-89053939A250})
  • Socialite 1.5.1 (socialite@chromakode)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • XFINITY Toolbar 3.5.1.12 ({4b9bcce8-a70b-402a-a7e1-db96831ee26f})
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.reddit.com/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1381715647
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1379518950

Misc

  • User JS: No
  • Accessibility: No
ideato
  • Top 25 Contributor
617 solutions 4264 answers

Hello jofield, try to delete the prefs.js file and any prefs-n.js files where n is a number (e.g. prefs-2.js) and Invalidprefs.js if exist.

see fro more info: Corrupt preferences file

thank you

Question owner

Hello ideato,

I tried this solution, and it did not work. My pdf files still will not open.

ideato
  • Top 25 Contributor
617 solutions 4264 answers

Any luck if you delete the mimeTypes.rdf file in profile folder ?

http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions

thanks again

Question owner

I have just tried this, and it did not work.. The pdf files just open to blank pages, even if I change the preference.

jscher2000
  • Top 10 Contributor
2380 solutions 21069 answers

Some Mac users have reported a flaw in the Adobe Acrobat plugin that leads to blank pages displaying for PDFs. There is a support article on that: PDF files are blank or cause an error message on Mac.

By the way, what is the PDF Download extension? If you disable that temporarily, does it change anything? You can do that here:

Tools menu > Add-ons > in the left column click Extensions

Chosen Solution

I'm using an adobe downloading add-on, 3.0.0.2, and I have disabled it. Now I can actually open pdf files in my browser as previews, or download them as I see fit. Thanks!

But clearly there's an error with the add-on.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97011 answers

Note that if plugin.disable_full_page_plugin_for_types includes application/pdf that only the built-in PDF Viewer can be used to display PDF files. To use a PDF viewer plugin embedded (if that works on Mac) you would have to remove this content type from the plugin.disable_full_page_plugin_for_types pref. The built-in PDF Viewer only supports the application/pdf MIME type.

PuzzledUser 1 solutions 9 answers

Helpful Reply

I don't know if this is any help I have had a problem where the pdf files were not opening correctly which I think was the problem here. I spent hours of head scratching and have now found out what the problem is. Right click on the Adobe Reader Icon on the desktop. Select properties and then the compatibility tab. You will see the uppermost section in this screen is Compatibility mode. I have Windows 7 and mine was set to Windows XP. I changed that to Windows 7 and now the problem is resolved. In short use the above instructions to check you are using the right compatibility mode for the version of Windows you are using and your troubles should be over!!

jscher2000
  • Top 10 Contributor
2380 solutions 21069 answers

Hi PuzzledUser, it's worth checking the poster's system information before replying. This thread lists MacOS X, so Windows 7 vs. XP compatibility isn't relevant...