X
Tap here to go to the mobile version of the site.

Support Forum

Downloaded the new firefox and was told that it won't work with my software, how do I return to my older version

Posted

I have a mac software 10.5.8. I downloaded moxilla firefox 24 and replaced the older version upon download. Then I got a message that firefox 24 won't work with my software. How do I get the older version back?

I have a mac software 10.5.8. I downloaded moxilla firefox 24 and replaced the older version upon download. Then I got a message that firefox 24 won't work with my software. How do I get the older version back?

Chosen solution

hello patcouse, if you'd like to stick with you old OS version, then firefox 16 is the last available version that will run in this environment. for a download link please refer to Firefox no longer works with Mac OS X 10.5 (at the end of the article).

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

More Information

philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23379 answers

Chosen Solution

hello patcouse, if you'd like to stick with you old OS version, then firefox 16 is the last available version that will run in this environment. for a download link please refer to Firefox no longer works with Mac OS X 10.5 (at the end of the article).

hello patcouse, if you'd like to stick with you old OS version, then firefox 16 is the last available version that will run in this environment. for a download link please refer to [[Firefox no longer works with Mac OS X 10.5]] (at the end of the article).
ideato 893 solutions 6250 answers

Hello patcouse, yes Firefox no longer works with Mac OS X 10.5 .

1. Download with your safari from the above link the Firefox 16.0.2 the latest for your 10.5 intel mac

2. Trash the current Firefox application to do a clean install.

3. Install the version that you have downloaded.


Do not select to remove your personal data, your profile data is stored elsewhere in the Firefox Profile Folder, so you won't lose your bookmarks or other personal data.

see also: Installing Firefox on Mac

NOTE that 16.0.2 is unsupported

thank you

EDIT : philipp is faster !

Hello patcouse, yes [https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-x-10-5#os=mac&browser=fx24 Firefox no longer works with Mac OS X 10.5] . 1. Download with your safari from the above link the Firefox 16.0.2 the latest for your 10.5 intel mac 2. '''Trash''' the current Firefox application to do a clean install. 3. Install the version that you have downloaded. Do not select to remove your personal data, your profile data is stored elsewhere in the [http://kb.mozillazine.org/Profile_folder_-_Firefox#Mac Firefox Profile Folder], so you won't lose your bookmarks or other personal data. see also: [https://support.mozilla.org/en-US/kb/install-firefox-mac?redirectlocale=en-US&redirectslug=Installing+Firefox+on+Mac#os=mac&browser=fx24 Installing Firefox on Mac] '''NOTE that 16.0.2 is unsupported''' thank you '''EDIT''' : philipp is faster !

Modified by ideato

LadyDebra24 0 solutions 1 answers

I have Ubuntu Linux and Firefox Browser has nothing but bookmark and Navigation on it. There is no tools bar or preference or any thing. so how can I get an older version??? my browser does not look like this one at all..

I have Ubuntu Linux and Firefox Browser has nothing but bookmark and Navigation on it. There is no tools bar or preference or any thing. so how can I get an older version??? my browser does not look like this one at all..
cor-el
  • Top 10 Contributor
  • Moderator
17423 solutions 157430 answers

Hi LadyDebra24

Could you please start a new thread for your question?

Then you can provide more information like your operating system and installed extensions and installed plugins.


You can try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

Hi LadyDebra24 Could you please start a new thread for your question? Then you can provide more information like your operating system and installed extensions and installed plugins. *[[/questions/new start a new thread]] *[[/kb/Using+the+Troubleshooting+Information+page]] ---- You can try to create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox