Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 3.5.3 works fine, but Update to 24 fails to start.

more options

My Firefox 24 ( installed from Firefox Setup Stub 24.0(2).exe) will not open. I have completely uninstalled and deleted Firefox Setup Stub 24.0(2).exe, re installed Firefox from Firefox Setup 3.5.3 and it works perfectly. (I could use this but I notice that it will not support Fast Video Downloader that I have been using for ages) I have reverted to default settings and only have a Default Profile. As soon as I update to Firefox 24 (downloaded - not my on disc version) Firefox will not start.

All Replies (5)

more options

hello michaelolive, firefox 3.5.3 had been released over 4 years ago, so a smooth update process that jumps that many version numbers cannot be guaranteed or even tested. if you are having issues with starting the new version, please try creating a new profile: Profile Manager - Create, remove or switch Firefox profiles

in case there are issue with the "Setup Stub".exe, try using the full installer that is available for your system at https://www.mozilla.org/firefox/all/

more options

Thanks Philipp. I have started afresh with a new download of Firefox 24 but it still does not start. I have only the default profile installed. Perhaps I should have included that I am using Windows XP with an AMD64 processor in a Foxconn motherboard.

more options

thanks for reporting back - is it possible to launch the profile manager and to create a fresh profile (like described in the article i've linked to above)?

more options

Hello, also, be sure you have sp2 and above, because firefox (from 13.0 version and above) needs xp sp2 or sp3, see:

Firefox 24 System Requirements

Firefox no longer works with some versions of Windows XP


thank you

more options

Hi My Windows XP is sp3 but Firefox still does even start up. I may have a problem somewhere else, but if not and Firefox 24 will not work, how far back in Firefox versions would I need to go? Where can I get earlier versions without going all the way back to 3.5.3? (Everything on my 6 year old PC works well on XP and I don't want to try and run a new Windows and run into compatibility problems) Thanks Michael