X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop this error "Firefox is already running, but is not responding"

Posted

Hello, I got this issue where I’m logged into more then on computer at a time. If I have Firefox running on one computer I’m prevented from running Firefox on anther computer. This because my user account has its home directory mounted across all the computers. It appears that the lock file is preventing from running Firefox on the 2nd computer. What I have been doing is deleting the lock file in my home directory. Then I’m able to start Firefox on the 2nd computer. Is there a better way of doing this? Is there away to disable the use of the lock file? Now I could just exit out of Firefox on the 1st computer but what if I’m running a web app on the 1st computer. What if you are using a shared admin account to such as root or using a RBAC profile. If user1 is using Firefox after become root or assuming a role, then no other user can use Firefox as root or using that role. That makes it very hard to use Firefox then. Anyway this is mostly a UNIX/Linux question.

Hello, I got this issue where I’m logged into more then on computer at a time. If I have Firefox running on one computer I’m prevented from running Firefox on anther computer. This because my user account has its home directory mounted across all the computers. It appears that the lock file is preventing from running Firefox on the 2nd computer. What I have been doing is deleting the lock file in my home directory. Then I’m able to start Firefox on the 2nd computer. Is there a better way of doing this? Is there away to disable the use of the lock file? Now I could just exit out of Firefox on the 1st computer but what if I’m running a web app on the 1st computer. What if you are using a shared admin account to such as root or using a RBAC profile. If user1 is using Firefox after become root or assuming a role, then no other user can use Firefox as root or using that role. That makes it very hard to use Firefox then. Anyway this is mostly a UNIX/Linux question.

Chosen solution

Hello, I thought I should update this post with the answer.

In order to get around the lock file. You can delete it or use profiles. If your running Firefox from a UNIX, BSD or Linux based OS. To get to the profile popup window use the -p option.

firefox -p

Which will look like the image below.

https://support.cdn.mozilla.net/media/uploads/images/2013-10-01-11-25-06-18a1cb.png

To get the popup all the time uncheck the "Don't ask at startup"

If you don't have a GUI running then you can do this.

firefox -CreateProfile profilename

firefox -p profilename

I hope this helps someone out.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET4.0C; .NET4.0E; InfoPath.2; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

More Information

Wesley Branton 184 solutions 2297 answers

Do you have any software designed to preload Firefox for a shorter startup time?

Do you have any software designed to preload Firefox for a shorter startup time?

Question owner

No, why would I want do that?

No, why would I want do that?
Waka_Flocka_Flame 441 solutions 5048 answers

You may also want to see the instructions posted in the "Firefox is already running but is not responding" error message - How to fix it article.

You may also want to see the instructions posted in the [["Firefox is already running but is not responding" error message - How to fix it]] article.

Question owner

Waka_Flocka_Flame, Thanks for the link, but I don't think it will help me. The issue is on a Linux computer. As for the file permissions I have listed them below. ls -l ~/.mozilla/firefox/zs9ok4on.default/lock lrwxrwxrwx 1 bitlord users 19 Sep 19 10:00 zs9ok4on.default/lock -> 204.37.14.24:+23346

Waka_Flocka_Flame, Thanks for the link, but I don't think it will help me. The issue is on a Linux computer. As for the file permissions I have listed them below. ls -l ~/.mozilla/firefox/zs9ok4on.default/lock lrwxrwxrwx 1 bitlord users 19 Sep 19 10:00 zs9ok4on.default/lock -> 204.37.14.24:+23346
Waka_Flocka_Flame 441 solutions 5048 answers
Have you tried a new profile? * [[Use the Profile Manager to create and remove Firefox profiles]]

Question owner

Ok I read your post form the link you gave me and this seems to fix the issue. I will have to do some testing though.


Thank you for your help

Ok I read your post form the link you gave me and this seems to fix the issue. I will have to do some testing though. Thank you for your help

Chosen Solution

Hello, I thought I should update this post with the answer.

In order to get around the lock file. You can delete it or use profiles. If your running Firefox from a UNIX, BSD or Linux based OS. To get to the profile popup window use the -p option.

firefox -p

Which will look like the image below.

https://support.cdn.mozilla.net/media/uploads/images/2013-10-01-11-25-06-18a1cb.png

To get the popup all the time uncheck the "Don't ask at startup"

If you don't have a GUI running then you can do this.

firefox -CreateProfile profilename

firefox -p profilename

I hope this helps someone out.

Hello, I thought I should update this post with the answer. In order to get around the lock file. You can delete it or use profiles. If your running Firefox from a UNIX, BSD or Linux based OS. To get to the profile popup window use the -p option. firefox -p Which will look like the image below. https://support.cdn.mozilla.net/media/uploads/images/2013-10-01-11-25-06-18a1cb.png To get the popup all the time uncheck the "Don't ask at startup" If you don't have a GUI running then you can do this. firefox -CreateProfile ''profilename'' firefox -p ''profilename'' I hope this helps someone out.

Modified by bitlord

cyberpunker 0 solutions 1 answers

OS:win7 x64 FX: v3.6 & v26 each firefox has a profile folder which locating in D: partition , in preventing being lost due to OS crashing .

I set the v26 as the default web browser in my Win7 . But , when I want to open a link form other software , etc a super link from word , or open a link from a IM software , even open a saved web pages in the folder , the firefox jump this dialog :

"Firefox is already running but is not responding"

It is really a harassment , I have delete the lock file , and uncheck the read only option , but It does not work .

OS:win7 x64 FX: v3.6 & v26 each firefox has a profile folder which locating in D: partition , in preventing being lost due to OS crashing . I set the v26 as the default web browser in my Win7 . But , when I want to open a link form other software , etc a super link from word , or open a link from a IM software , even open a saved web pages in the folder , the firefox jump this dialog : "Firefox is already running but is not responding" It is really a harassment , I have delete the lock file , and uncheck the read only option , but It does not work .