X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox: After a search in Google back button does take me back to resultsant search page

Posted

Hi All

I have an interesting problem with google and firefox not playing well. When I complete a search on google I get a results page. But when I use a link of the results page and use the back button look at the results page it flashes up quickly and then is replaced with a blank page.

If I use reload (ctrl + R) the result page it is then displayed. Is this a new feature that is in FF24?

I have FF24.0 on Win 7 and I have: 1. re installed firefox 2. deleted my prefs.js 3. turned http cache off 4. run in safe mode with add ons off..

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96801 answers

Still works fine here.

Is this with a secure https page?

You can open the links in a new tab.

Where results open: Open search results in a new browser window.

Do you have any content blocking extensions?


Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

Question owner

Hi Cor-el

I have tried all of the solutions that are in your reply and none have worked. That is I have changed profile, cleared the cache and deleted all cookies, etc.

It appears that the browser does not want to render that page when it comes from the cache using the back button.

chrisbazzle 0 solutions 2 answers

Helpful Reply

Until Firefox fixes this problem, they will have an inferior product compared to what they used to have. It's that simple. They need to face that fact. I have adopted by hitting the back button twice and then going forward one. But that does not work when I do a new search after that. Then, it goes back to my first search results, and I have to stop and type my new search again. MOZILLA FIREFOX, fix the problem please. I think I am safe in saying this is a fundamental issue for lots of people that use your product every day. Are you going to ignore that? Do you care? I guess I can always go back to IE or start using chrome.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Helpful Reply

(Copied from another thread)

The reason I couldn't re-create this problem is that it doesn't occur on low zoom levels. I can replicate it if I zoom the Google home page to 1.33x the standard size (Ctrl+ three times starting from standard 100% zoom level) before searching. The results page doesn't always behave the same in my testing. Sometimes the page appears blank right away, other times it stay, and sometimes it's there for second or two and then blanks itself. Very strange.

Two known workarounds at this point:

  • Use a lower zoom level. For example, if your Firefox has a standard 100% zoom, try 1.2x zoom (Ctrl+ twice instead of three times). If your Firefox has a 125% zoom based on Windows HiDPI settings, try sticking with that for Google. If this makes Google too small, a workaround would be to use a style rule to modify the page. I'll save that discussion for another post if needed.
  • Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

If you try either workaround, please report back on whether it helps.


This zoom issue was noted late Monday night in Bug #908446 "Google search pages blank with use of back button". It's not yet clear from the bug how it can be fixed, but people are actively looking into it.

More info on that mysterious preference: browser.sessionhistory.max_total_viewers on mozillaZine.

rhpollack 0 solutions 1 answers

The zoom thing worked for me. Thanks!

Another thing that works (I found this out in a different forum) is to turn off the thing that auto-completes queries as you type:

[Options] -> Search Settings -> Search results -> Google Instant predictions -> Never show Instant results

Firefox developers take note. These two workarounds should be giving you a pretty good idea of where the problem is.

wilddogsam 0 solutions 1 answers

Chris Bazzle: "Until Firefox fixes this problem, they will have an inferior product compared to what they used to have. It's that simple... I guess I can always go back to IE or start using chrome."

My sentiments exactly.

I cannot believe this shoddy state of affairs has been going on for this long. At this point the alarm bells should be ringing till they are red hot at Firefox.

I am completely fed up with Firefox. If this major glitch is not fixed within 1 week I am going to switch to either IE or Chrome and I won't be switching back.

Steve T Firefox user since 2006

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi Steve T, this isn't going to change in the next week. Even if the developers write the patch tonight, the next release of Firefox is scheduled for February 4th.

If you decide to keep using Firefox, you can implement one of the workarounds in this thread:

  • turn off instant prediction results in Google settings
  • reduce zoom level
  • change the browser.sessionhistory.max_total_viewers preference to 0
chrisbazzle 0 solutions 2 answers

I don't feel like I should have to turn off the zoom view or the google instant results. However, I must admit browser.sessionhistory.max_total_viewers solution is working for me so far. So, I'm glad I came on here. I got to rant and although it took me several months to get around to trying it, apparently I was given a solution. Thanks, jscher2000.

chad9 0 solutions 2 answers

The fix above works (browser.sessionhistory.max_total_viewers to 0), but disables something very important. Now, when I close my firefox window, it does not remember the tabs! If I have 5 tabs up, normally I can close down and bring them up later. Now, all I get is the home page!

We need a real fix for this asap. Thanks.

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi chad9, that preference should not have any effect on how Firefox starts up or how many windows or tabs it remembers. There are a bunch of other settings for that.


First, when Firefox starts, is "Restore Previous Session" available from the History menu? If so, try that. Also, you may need to update your startup setting in the Options dialog. See: Startup, home page and download settings.

You might also want to check for a user.js file which can override your preferences at startup. This article describes how to track that down if you have one: How to fix preferences that won't save. Recently many users have discovered that an update to Advanced SystemCare is locking or changing their browser settings; this is an increasing issue to look out for in your security suites as they try to protect you from unwanted changes.

Some users have reported that session restore doesn't work well when you exit Firefox using the Windows Task Bar (right-clicking and choosing Close All Windows). It works best when you choose Exit from the File menu or orange Firefox button (compact menu).


It's worth also checking two hidden preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

Make sure you have reasonable values for the following and if you still like to close Firefox from the task bar, increase the second one:

  • browser.sessionstore.max_tabs_undo - number of tabs per window that you can recover on the History > Recently Closed Tabs list (default: 10)
  • browser.sessionstore.max_windows_undo - number of windows you can recover on the History > Recently Closed Windows list (default: 3)
chad9 0 solutions 2 answers

jscher2000, you are right! Somehow the setting changed, and I just changed it back to Show Tabs from Last Time. I don't think that had anything to do with the fix above, which works! Thanks for helping, and for the fix!