X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Stop displaying sites when I open a new tab

Posted

When I open a new tab, Firefox displays, in the new tab, links to a bunch of my previously-visited sites. Please tell me how to make this stop. I moved to Firefox specifically because Chrome did this and I hated it. It is a behavior that might have been imported from Google. I hate it. Please tell me how to make it stop. Please tell me how to make it stop. Please tell me how to make it stop.

Chosen solution

You can change your new tab to a blank screen, or any URL of your choice.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Read this answer in context 40

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • VLC media player Web Plugin 2.0.6
  • Google Update
  • GEPlugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20513.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Chosen Solution

You can change your new tab to a blank screen, or any URL of your choice.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Incidentally, Firefox has a lot of these "about" pages. To discover more of them, you can type or paste about:about in the address bar and press Enter. When you get to a page that doesn't have a Back button, Alt+LeftArrow will return you to the previous page.

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

You can create these Boolean prefs on the about:config page to prevent Firefox from generating thumbnails for the about:newtab page.

  • name: browser.pagethumbnails.capturing_disabled with value: true
  • name: pageThumbs.enabled with value: false

You need to delete the thumbnails folder in the Firefox profile folder to remove already stored web page thumbnails.

Helpful Reply

jscher:

Wow.

It seems to have worked like a charm, and it even makes sense, which very little in Chrome does.

This is wonderful. Thank you.

Modified by 45rpm