X
Tap here to go to the mobile version of the site.

Support Forum

When I go back to Google search results page, it takes me to a blank Google screen

Posted

For example, I click on one link after doing a Google search, then I decide to go back & check one of the other links. When I go back instead of seeing my Google results screen again, I have a blank Google screen. Then I have to put my search terms in all over again. This does not happen using Internet Explorer. Thanks for any help

For example, I click on one link after doing a Google search, then I decide to go back & check one of the other links. When I go back instead of seeing my Google results screen again, I have a blank Google screen. Then I have to put my search terms in all over again. This does not happen using Internet Explorer. Thanks for any help

Chosen solution

I've been having the same problem, and looked for help on the Mozillazine.org site. No help there either, but I have found that when you get the blank screen, clicking on REFRESH, brings back the page you want.

Another solution for this issue is available here: https://support.mozilla.org/questions/970863?page=2#answer-485663

Added 'another solution' as per the request of jscher2000

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
8793 solutions 71929 answers

Is there any pattern as to which Google search script has the problem? Check the URL for /search? or /webhp?

  • The /search page is the older design used when you start your search from the search bar or built-in Firefox home page; it should have some query terms hardcoded into the query before the # mark, and often some query terms after it as well.
  • The /webhp page is the newer design that generally is used when you start from Google's home page (e.g., by going there directly or clicking the Google logo in the top bar); the query terms generally only appear after the # mark.

The reason I mention the # mark is that Google's scripts use the data after it to refresh the page content with instant results. Something (obviously) is going wrong in that process.

Is there any pattern as to which Google search script has the problem? Check the URL for /search? or /webhp? * The /search page is the older design used when you start your search from the search bar or built-in Firefox home page; it should have some query terms hardcoded into the query ''before'' the # mark, and often some query terms after it as well. * The /webhp page is the newer design that generally is used when you start from Google's home page (e.g., by going there directly or clicking the Google logo in the top bar); the query terms generally only appear ''after'' the # mark. The reason I mention the # mark is that Google's scripts use the data after it to refresh the page content with instant results. Something (obviously) is going wrong in that process.
alexxmed 0 solutions 8 answers

I am running Firefox version 24.0 under Ubuntu Linux 12.04 and I have the same problem. It is terribly annoying and all the solutions posted so far involve disabling some useful features in Firefox, or clicking "refresh" as a workaround to what is obviously a bug.

Instead, what should happen is the authors should accept responsibility for the bug and fix it, or offer a real solution that does not inconvenience Firefox's users.

I am running Firefox version 24.0 under Ubuntu Linux 12.04 and I have the same problem. It is terribly annoying and all the solutions posted so far involve disabling some useful features in Firefox, or clicking "refresh" as a workaround to what is obviously a bug. Instead, what should happen is the authors should accept responsibility for the bug and fix it, or offer a real solution that does not inconvenience Firefox's users.

Modified by alexxmed

johnerbes 0 solutions 1 answers

I'm running Firefox 24.0 on three different computers running two different versions of Win 7 and one Win 8. All three computers give me a blank Google screen when I press "Go back one page" to a Google search screen. As with everyone else, pressing "Reload Current Page" will always bring back the search results. Why can't anyone figure out what is causing this?

I'm running Firefox 24.0 on three different computers running two different versions of Win 7 and one Win 8. All three computers give me a blank Google screen when I press "Go back one page" to a Google search screen. As with everyone else, pressing "Reload Current Page" will always bring back the search results. Why can't anyone figure out what is causing this?

Modified by johnerbes

jscher2000
  • Top 10 Contributor
8793 solutions 71929 answers

Hi johnerbes, someone might be working on this who hasn't posted in the forum...

Does it make any difference which search page you use? See: https://support.mozilla.org/en-US/questions/970863?page=2#answer-482343

Another workaround is to turn off instant prediction results in your Google search settings (preferences page). On the plus side, that lets you load more results into a page if you like. On the minus side, you always have to submit each new search.

Hi johnerbes, someone might be working on this who hasn't posted in the forum... Does it make any difference which search page you use? See: https://support.mozilla.org/en-US/questions/970863?page=2#answer-482343 Another workaround is to turn off instant prediction results in your Google search settings ([http://www.google.com/preferences preferences page]). On the plus side, that lets you load more results into a page if you like. On the minus side, you always have to submit each new search.
Mr.Handyman 0 solutions 6 answers

I had posted earlier how I have this problem on 2-different computers running different versions of Windows and also different versions of Firefox. And then, magically, everything went back to working normally. Pressing the Back button back to the starting search page for Google loaded fine. The blank page disappeared. Well, that is, it worked fine for about 4 or 5 days, and then went back to showing this blank page yesterday. It must be something to do with Google. Hoping someone figures it out soon.

I had posted earlier how I have this problem on 2-different computers running different versions of Windows and also different versions of Firefox. And then, magically, everything went back to working normally. Pressing the Back button back to the starting search page for Google loaded fine. The blank page disappeared. Well, that is, it worked fine for about 4 or 5 days, and then went back to showing this blank page yesterday. It must be something to do with Google. Hoping someone figures it out soon.
alexxmed 0 solutions 8 answers

Disabling features of Firefox as an attempt to work around bugs is not an acceptable solution. What would be an acceptable solution would be for Mozilla to fix bugs when they have been reported by multiple users on multiple platforms, as this one is. It is shown to be an issue in Windows 7, WIndows 8 and Linux.

Disabling features of Firefox as an attempt to work around bugs is not an acceptable solution. What would be an acceptable solution would be for Mozilla to fix bugs when they have been reported by multiple users on multiple platforms, as this one is. It is shown to be an issue in Windows 7, WIndows 8 and Linux.
alexxmed 0 solutions 8 answers

It seems to happen on all Google searches. To be clear, a google search produces a list of links. The user clicks on one of the links and then after viewing the resulting page clicks the back arrow on the navigation toolbar to go to the previous page and the page appears blank. Clicking the refresh button reloads the page.

The obvious question is what is different about clicking the refresh button from clicking the back button, besides the fact that one reloads the current page and the other reloads the previous page?

This seems to be a new problem. I did not have it on previous versons of Firefox.

I am running Firefox 24 under Ubuntu Linux 12.04.

It seems to happen on all Google searches. To be clear, a google search produces a list of links. The user clicks on one of the links and then after viewing the resulting page clicks the back arrow on the navigation toolbar to go to the previous page and the page appears blank. Clicking the refresh button reloads the page. The obvious question is what is different about clicking the refresh button from clicking the back button, besides the fact that one reloads the current page and the other reloads the previous page? This seems to be a new problem. I did not have it on previous versons of Firefox. I am running Firefox 24 under Ubuntu Linux 12.04.
Taiko 0 solutions 6 answers

I agree with alexxmed, we should not have to do a work-around when it has always worked without a problem.

I didn't notice it until FF 24. (running OSX 10.8.5 here) Has anyone experienced this issue with an nearlier version?

I agree with alexxmed, we should not have to do a work-around when it has always worked without a problem. I didn't notice it until FF 24. (running OSX 10.8.5 here) Has anyone experienced this issue with an nearlier version?
jscher2000
  • Top 10 Contributor
8793 solutions 71929 answers

Hi alexxmed, I don't think anyone seriously recommended disabling features of Firefox as a solution or workaround.

The obvious question is what is different about clicking the refresh button from clicking the back button, besides the fact that one reloads the current page and the other reloads the previous page?

When you go back, unless the server instructed Firefox NOT to cache the page, you see a cached copy of the page and Firefox does NOT re-request the page from the server.

This works fine with pages that are served "complete" like the results you get from using the Firefox search bar. The problem seems to arise when the page is dynamically changed by the Instant Prediction results feature: scripts clear the old results and replace them with new ones. For some users, these dynamic results are not being cached.

(I am not able to replicate the problem myself, so I don't have specific insight into the details.)

Hi alexxmed, I don't think anyone seriously recommended disabling features of Firefox as a solution or workaround. <blockquote>The obvious question is what is different about clicking the refresh button from clicking the back button, besides the fact that one reloads the current page and the other reloads the previous page?</blockquote> When you go back, unless the server instructed Firefox NOT to cache the page, you see a cached copy of the page and Firefox does NOT re-request the page from the server. This works fine with pages that are served "complete" like the results you get from using the Firefox search bar. The problem seems to arise when the page is dynamically changed by the Instant Prediction results feature: scripts clear the old results and replace them with new ones. For some users, these dynamic results are not being cached. (I am not able to replicate the problem myself, so I don't have specific insight into the details.)
alexxmed 0 solutions 8 answers

In an earlier post it was suggested to disable Instand Prediction Results. Is that not a feature? This feature of Google searches is part of what makes Google the best search engine out there. This not a Google problem. It is a Firefox problem. It doesn't happen in Safari, Google Chrome or earlier versions of Firefox.

In an earlier post it was suggested to disable Instand Prediction Results. Is that not a feature? This feature of Google searches is part of what makes Google the best search engine out there. This not a Google problem. It is a Firefox problem. It doesn't happen in Safari, Google Chrome or earlier versions of Firefox.
alexxmed 0 solutions 8 answers

So it is now identified in Windows 7, Windows 8, Ubuntu Linux 12.04 LTS and Apple OSX 10.8.5. Sounds like a global problem to me.

So it is now identified in Windows 7, Windows 8, Ubuntu Linux 12.04 LTS and Apple OSX 10.8.5. Sounds like a global problem to me.
jscher2000
  • Top 10 Contributor
8793 solutions 71929 answers

Hi alexxmed, you wrote:

In an earlier post it was suggested to disable Instand Prediction Results. Is that not a feature? This feature of Google searches is part of what makes Google the best search engine out there.

Yes, that is a feature of Google and yes, the hypothesis is that for whatever yet-to-be-determined reason, some users' Firefoxes seem not to be retaining the last set of instant results in the cache.

Hi alexxmed, you wrote: <blockquote>In an earlier post it was suggested to disable Instand Prediction Results. Is that not a feature? This feature of Google searches is part of what makes Google the best search engine out there.</blockquote> Yes, that is a feature of ''Google'' and yes, the hypothesis is that for whatever yet-to-be-determined reason, some users' Firefoxes seem not to be retaining the last set of instant results in the cache.
Mr.Handyman 0 solutions 6 answers

So, why did the problem go away for about 2 days, and then come back? ( I thought what ever caused this had been fixed.) Did anyone else experience a couple days of things working properly?

By now, it's obvious it does not matter what version of Windows, nor what version of Firefox is being used. (I personally try to use Older Versions, 12.0). I'm still leaning towards a Google problem. When I get the blank page, I left click on the Back button and select the Search page from the list.

Also, when I begin a search, I usually go 4 or 5 pages, or more, into results before I start using the Back button to get back to Google's Search Results, where I started, and encounter the dreaded BLANK PAGE. I see where others seem to go only one page into results, and then go back to Google Search Results, and the Blank Page.

It seems we are eliminating possible causes, but still no answer.

So, why did the problem go away for about 2 days, and then come back? ( I thought what ever caused this had been fixed.) Did anyone else experience a couple days of things working properly? By now, it's obvious it does not matter what version of Windows, nor what version of Firefox is being used. (I personally try to use Older Versions, 12.0). I'm still leaning towards a Google problem. When I get the blank page, I left click on the Back button and select the Search page from the list. Also, when I begin a search, I usually go 4 or 5 pages, or more, into results before I start using the Back button to get back to Google's Search Results, where I started, and encounter the dreaded BLANK PAGE. I see where others seem to go only one page into results, and then go back to Google Search Results, and the Blank Page. It seems we are eliminating possible causes, but still no answer.
jscher2000
  • Top 10 Contributor
8793 solutions 71929 answers

Helpful Reply

The reason I couldn't re-create this problem is that it doesn't occur on low zoom levels. I can replicate it if I zoom the Google home page to 1.33x the standard size (Ctrl+ three times starting from standard 100% zoom level) before searching. The results page doesn't always behave the same in my testing. Sometimes the page appears blank right away, other times it stay, and sometimes it's there for second or two and then blanks itself. Very strange.

Two known workarounds at this point:

  • Use a lower zoom level. For example, if your Firefox has a standard 100% zoom, try 1.2x zoom (Ctrl+ twice instead of three times). If your Firefox has a 125% zoom based on Windows HiDPI settings, try sticking with that for Google. If this makes Google too small, a workaround would be to use a style rule to modify the page. I'll save that discussion for another post if needed.
  • Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

If you try either workaround, please report back on whether it helps.


This zoom issue was noted late Monday night in Bug #908446 "Google search pages blank with use of back button". It's not yet clear from the bug how it can be fixed, but people are actively looking into it.

More info on that mysterious preference: browser.sessionhistory.max_total_viewers on mozillaZine.

The reason I couldn't re-create this problem is that it doesn't occur on low zoom levels. I can replicate it if I zoom the Google home page to 1.33x the standard size (Ctrl+ three times starting from standard 100% zoom level) before searching. The results page doesn't always behave the same in my testing. Sometimes the page appears blank right away, other times it stay, and sometimes it's there for second or two and then blanks itself. Very strange. Two known workarounds at this point: * Use a lower zoom level. For example, if your Firefox has a standard 100% zoom, try 1.2x zoom (Ctrl+ twice instead of three times). If your Firefox has a 125% zoom based on Windows HiDPI settings, try sticking with that for Google. ''If this makes Google too small, a workaround would be to use a style rule to modify the page. I'll save that discussion for another post if needed.'' * Force Firefox to re-parse the page by changing a setting (note: this is not Google-specific and may slow down "Back" on all sites by some milliseconds). Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) Double-click the '''browser.sessionhistory.max_total_viewers''' preference and change it to 0 (that's a zero). '''If you try either workaround, please report back on whether it helps.''' ---- This zoom issue was noted late Monday night in Bug #908446 "Google search pages blank with use of back button". It's not yet clear from the bug how it can be fixed, but people are actively looking into it. More info on that mysterious preference: [http://kb.mozillazine.org/Browser.sessionhistory.max_total_viewers browser.sessionhistory.max_total_viewers on mozillaZine].
alexxmed 0 solutions 8 answers

hi jscher2000 --

The second solution, changing the value of browser.sessionhistory.max_total_viewers to 0 has solved the problem. I do not detect a noticable slowness as a result and the fact that the back button no longer results in a blank screen is worth any undetectable affect on speed this may have had.

Hopefully, this information will provide the needed information to fix the bug so that whatever having a value other than 0 causes (mine was -1), doesn't result in this issue.

Thank you for your assistance.

hi jscher2000 -- The second solution, changing the value of '''browser.sessionhistory.max_total_viewers''' to '''0''' has '''solved the problem'''. I do not detect a noticable slowness as a result and the fact that the back button no longer results in a blank screen is worth any undetectable affect on speed this may have had. Hopefully, this information will provide the needed information to fix the bug so that whatever having a value other than 0 causes (mine was -1), doesn't result in this issue. Thank you for your assistance.

Modified by alexxmed

mackerelsky 0 solutions 2 answers

Yes the second solution has worked for me too, thanks for that, it was driving me crazy. Have only tested it a couple of times so far but fingers crossed it seems to work. thanks

Yes the second solution has worked for me too, thanks for that, it was driving me crazy. Have only tested it a couple of times so far but fingers crossed it seems to work. thanks
nikipatton 0 solutions 3 answers

The blank search page upon hitting the back button started happening to me about 3 weeks ago when I updated Firefox to 24.0. Simultaneously Firefox started asking me if I wanted to save passwords again -- I disabled that function years ago and have never been asked again. Disabling 'instant results' did the trick to refresh the search page going back -- but with both of these things coming up at the same time I think it might be a version glitch.

The blank search page upon hitting the back button started happening to me about 3 weeks ago when I updated Firefox to 24.0. Simultaneously Firefox started asking me if I wanted to save passwords again -- I disabled that function years ago and have never been asked again. Disabling 'instant results' did the trick to refresh the search page going back -- but with both of these things coming up at the same time I think it might be a version glitch.
Taiko 0 solutions 6 answers

The workaround which changes the settings in config does work, but I believe it also causes issues with Google Instant. I will have to keep testing it to see if one thing has anything to do with the other.

The workaround which changes the settings in config does work, but I believe it also causes issues with Google Instant. I will have to keep testing it to see if one thing has anything to do with the other.
Joela 0 solutions 12 answers

The about:config solution works.

The about:config solution works.
Jeff 1 solutions 2 answers

browser.sessionhistory.max_total_viewers = 0 works for me too. That was sure an annoying problem!

browser.sessionhistory.max_total_viewers = 0 works for me too. That was sure an annoying problem!