Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Peer's Certificate has an invalid signature > Can't connect to secured site

  • 5 replies
  • 23 have this problem
  • 5230 views
  • Last reply by cor-el

more options

I can't access secure sites with FF 23,01, when I try I get the following message:

"Secure connection failed---Peer's Certificate has an invalid signature .......

This just started today. I have been using FF forever and have never before seen this message.

I can access the same sites with IE10 .

This started mid-morning today 8/30/13

All Replies (5)

more options

Please refer to this thread.

more options

Hi ComputerWhiz  :-)


Thanks for taking the time to read and reply to my issue.

Unfortunately I am not a computer whiz and I have no idea how to do the suggested fix from the thread you referred me to.

more options

That is ok. Some people are more tech savvy than others.

Unfortunately, I have never attempted the solution from the other thread.

Since the solution from that thread is not mine, I will contact cor-el and get you some more support.

I will also look into how to do this solution.

Sorry I am not able to help you directly.

more options

Hi :-)

I just decided to do a fresh clean install. Luckily(lol) my pc crashed last week and my OEM recovery discs failed and my lousy 7 month old Iomega external hard drive failed a couple of weeks ago (stay away from Iomega-lots of complaints on their forum about failed external drives) so I had to buy a new edition of Windows-reformatted--lost my moz backups in the process so I really didn't lose that much and will only take a day to recreate what I lost in FF. So consider the matter resolved :-)

Thanks again for your time.

more options

Are you using a secure https connection in IE as well?

What are the connection settings?

Check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.