X
Tap here to go to the mobile version of the site.

Support Forum

How can I stop links opening if I merely hover the pointer over them, rather than clicking them?

Posted

If I inadvertently leave the mouse pointer hovering over a link, Firefox follows that link after a few seconds. This can cause major problems like sending incomplete emails, leaving pages on which one has entered data and losing that data, etc. The problem is particularly annoying when using the notebook's mousepad as one has to let go long enough to move one's finger across the pad. If the pointer is pointing at a link (as it often will be) Firefox opens the link, regardless of whether I want it.

I want Firefox to follow a link only if I click on it. I can't find a setting under Tools to achieve this. Is it in about:config? I don't want to play with that unless I know what I'm doing.

If I inadvertently leave the mouse pointer hovering over a link, Firefox follows that link after a few seconds. This can cause major problems like sending incomplete emails, leaving pages on which one has entered data and losing that data, etc. The problem is particularly annoying when using the notebook's mousepad as one has to let go long enough to move one's finger across the pad. If the pointer is pointing at a link (as it often will be) Firefox opens the link, regardless of whether I want it. I want Firefox to follow a link only if I click on it. I can't find a setting under Tools to achieve this. Is it in about:config? I don't want to play with that unless I know what I'm doing.

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Shockwave Flash 11.8 r800
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Unity Player 4.0.1f1
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Skype Click to Call 6.11.0.13348 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 9-26-2012
  • driverDate2:
  • driverVersion: 9.17.10.2867
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • accessibility.warn_on_browsewithcaret: False
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.suggest.enabled: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://mail.orcon.net.nz/portal/
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.bing.com/search?FORM=UP97DF&PC=UP97&q=
  • network.cookie.cookieBehavior: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376804677
  • places.history.expiration.transient_current_max_pages: 102532
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1375393134

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156717 answers

Did you check for problems with the moue driver or other software that is running in Windows?

In Firefox only an extension would be able to do this and your System Details List doesn't show extensions apart from the one of this forum.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Did you check for problems with the moue driver or other software that is running in Windows? In Firefox only an extension would be able to do this and your System Details List doesn't show extensions apart from the one of this forum. Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.