X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mixed Content Blocking preferences not remembered

Posted

I want to permanently disable Mixed content Blocking on certain websites. When I click "Disable protection on this page", Firefox seems to remember the choice till the end of the session. After restart I have to disable it again. Is there a way to remember these settings permanently, without turning the entire feature off?

Modified by maaxxify

Chosen solution

It's still a pain in the .... in version 26. I just want my decision to persist & not to have to keep telling it to unblock. But I also don't want to have to turn the feature off entirely. Pretty ridiculous situation.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).


In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords and other site settings.

Question owner

Thanks for your reply, cor-el. Unfortunately none of the two cases above applies to me. Firefox is set to remember all history and data, also I'm not using Private browsing.

Nate650 0 solutions 2 answers

Helpful Reply

To permanently disable:

1. In the address bar, type "about:config" and press Enter. 2. Click the "I'll be careful, I promise!" button. 3. In the search field, type "block_active". 4. Set the value for the one search result ("security.mixed_content.block_active_content") to "false".

Modified by Nate650

beniza 0 solutions 1 answers

Helpful Reply

In most cases that is not what the user needs. He/she should be able to disable this feature only on the selected websites. In my case, my intranet uses the filedepot plugin for the Drupal which was being blocked by the Firefox. It is annoying as we need to use it very often and to get it work, every time we need to click on the "Disable Protection on this page". However I'd need Firefox to block it on any other (especially 3rd party) websites. So as @maaxxify requests, a feature to disable this on certain website is more desirable.

Modified by beniza

notHappi 0 solutions 1 answers

Yes, this feature is terrible. If you insist on continuing down this path, you must put this feature in an area where normal humans can get to it, without having to type inscrutable messages. This completely breaks one of my asp.net sites and need to be able to tell regular people how to shut this maddening bug (yes, this is a bug not a feature) off. Where do I go to make suggestions like this? Thanks.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 7995 answers

You may find a developers forum or mailing list where this could be considered on topic or has already been discussed

You should certainly make your thoughts known by posting a short comment here


Update

Modified by John99

mjmoore 0 solutions 2 answers

To completely disable mixed content checking see screen snapshot here: http://plsqlnotes.blogspot.com/2013/09/firefox-disable-mixed-content-blocking.html

Nate650 0 solutions 2 answers

I agree the ability to disable MCB on a per-website basis is more desirable but since that solution doesn't currently exist, I posted the workaround to completely disable the feature.

jscher2000
  • Top 10 Contributor
2344 solutions 20788 answers

By the way, some refinements are in the works. For example:

Bug #902156: Firefox 24 will remember your decision to suspend protection on a particular site if you continue browsing the site in the same tab. (Possibly also in new tabs, but I haven't checked.) However, if you navigate away from the site, when you go back, you'll have to click the shield again.

Bug #860712: Possible enhancement to extend the suspension of protection for a site for the duration of your Firefox session (might or might not continue after exiting Firefox and restoring your previous session). Still in discussion.

There are many other open bugs relating to this feature for those interested in researching...

Question owner

Thanks jscher2000, this is helpful. Let's wait for Firefox 24 and hope the update will solve this tedious issue.

MattC 1 solutions 1 answers

Chosen Solution

It's still a pain in the .... in version 26. I just want my decision to persist & not to have to keep telling it to unblock. But I also don't want to have to turn the feature off entirely. Pretty ridiculous situation.