X
Tap here to go to the mobile version of the site.

Support Forum

how can i find ENCRYPTION tab in mozilla firefox 23 version? I really need to change its settings cause i contact from Iran n use proxy to access lots of sites

Posted

I contact from Iran, we've restrictions to access lots of sites such as facebook,twitter,.... even Google so we use proxy to access our profiles in these sites, since i've upgrade my mozilla firefox to newer version, i can't find ENCRYPTION tab to change the settings i need for running my proxy, I was wondering if you could help me to solve this problem, thanks

I contact from Iran, we've restrictions to access lots of sites such as facebook,twitter,.... even Google so we use proxy to access our profiles in these sites, since i've upgrade my mozilla firefox to newer version, i can't find ENCRYPTION tab to change the settings i need for running my proxy, I was wondering if you could help me to solve this problem, thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • 5.1.20125.0
  • VLC media player Web Plugin 2.0.2
  • Yahoo Application State Plugin version 1.0.0.7
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

kobe 441 solutions 5048 answers

Does entering this url in the url bar work?

  • chrome://pippki/content/certManager.xul
Does entering this url in the url bar work? * chrome://pippki/content/certManager.xul
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Helpful Reply

See this for proxy (connection) settings:

  • Firefox/Tools > Options > Advanced > Network > Connection

Current Firefox no longer have a user interface setting to disable TLS or SSL3, but you can make the change on the about:config page. SSL3 and TLS 1.0 are enabled by default in the current Firefox release.

You can set the security.tls.version.min and security.tls.version.max prefs to 0 to disable TLS (0 means SSL3)

Be cautious with activating TLS 1.1 because the fallback to lower protocols isn't implemented yet and Firefox will fail to connect if the server doesn't support it (i.e. Firefox will insist on using TLS 1.1).

security.tls.version.min
security.tls.version.max
S0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.
See this for proxy (connection) settings: *Firefox/Tools > Options > Advanced > Network > Connection *FoxyProxy Standard: https://addons.mozilla.org/firefox/addon/foxyproxy-standard/ ---- Current Firefox no longer have a user interface setting to disable TLS or SSL3, but you can make the change on the about:config page. SSL3 and TLS 1.0 are enabled by default in the current Firefox release. You can set the security.tls.version.min and security.tls.version.max prefs to 0 to disable TLS (0 means SSL3) Be cautious with activating TLS 1.1 because the fallback to lower protocols isn't implemented yet and Firefox will fail to connect if the server doesn't support it (i.e. Firefox will insist on using TLS 1.1). *http://kb.mozillazine.org/security.tls.version.* security.tls.version.min security.tls.version.max S0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.

Question owner

thanks for your attention i've to deactivate TLS 1.0 to run my proxy but i couldn't do it through this link address: http://kb.mozillazine.org/security.tls.version.*

thanks for your attention i've to deactivate TLS 1.0 to run my proxy but i couldn't do it through this link address: http://kb.mozillazine.org/security.tls.version.*

Question owner

thanks for your attention but unfortunately it couldn't help me

thanks for your attention but unfortunately it couldn't help me
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Helpful Reply

You can set these two prefs to 0 (zero) on the about:config page to disable TLS.

  • security.tls.version.min = 0
  • security.tls.version.max = 0

Use the search bar at the top to locate the prefs easily

You can set these two prefs to 0 (zero) on the <b>about:config</b> page to disable TLS. *security.tls.version.min = 0 *security.tls.version.max = 0 Use the search bar at the top to locate the prefs easily *http://kb.mozillazine.org/about:config

Question owner

i did it, i changed security.tls.version.max = 0 and security.tls.version.min = 0 but i couldn't run my proxy :-(

i did it, i changed security.tls.version.max = 0 and security.tls.version.min = 0 but i couldn't run my proxy :-(

Question owner

i restart my mozilla firefox and it worked, thanks a million :-))

i restart my mozilla firefox and it worked, thanks a million :-))

Question owner

thank you cor-el

thank you cor-el
eNorto 0 solutions 2 answers

HEY MOZILLA TEAM!

You guys must be outta your stupid minds! really! Upgrading means adding useful content and removing bugs and unuseful things. not removing things that might help some people to browse better! I've been thinkin for years that chrome is the real deal but I always told my self that I was wrong. with all the troubles I had with firefox I never stopped usin' it. well, chrome had won already... you just digged your own grave MOZILLA! cuz I'm no more a firefox user. YOU FIREFOX LOSERS!

And my compatriot, Atena! I suggest you to use chrome for surfing the web better, but if you still insist on using firefox, your only hope is to downgrade your firefox 23 to firefox 22 and never upgrade it AGAIN!

Good luck my friend!

I almost forgot this is the link for downgrading https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

HEY MOZILLA TEAM! You guys must be outta your stupid minds! really! Upgrading means adding useful content and removing bugs and unuseful things. not removing things that might help some people to browse better! I've been thinkin for years that chrome is the real deal but I always told my self that I was wrong. with all the troubles I had with firefox I never stopped usin' it. well, chrome had won already... you just digged your own grave MOZILLA! cuz I'm no more a firefox user. YOU FIREFOX LOSERS! And my compatriot, Atena! I suggest you to use chrome for surfing the web better, but if you still insist on using firefox, your only hope is to downgrade your firefox 23 to firefox 22 and never upgrade it AGAIN! Good luck my friend! I almost forgot this is the link for downgrading https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

Modified by eNorto

eNorto 0 solutions 2 answers
And this is the direct download link. https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/22.0/win32/en-US/Firefox%20Setup%2022.0.exe

Modified by eNorto

Question owner

Hi Arash thanks for your attention n i should say I'm in totally agreement with you in this case and again thank you very much indeed for firefox 22 download link I was wondering if u could do me a favor n send me the latest chrome download link too thanks a million

Hi Arash thanks for your attention n i should say I'm in totally agreement with you in this case and again thank you very much indeed for firefox 22 download link I was wondering if u could do me a favor n send me the latest chrome download link too thanks a million
ideato 893 solutions 6250 answers

Hello, Current Firefox no longer have a user interface setting to disable TLS or SSL3, as cor-el said above, because of that :

http://limi.net/checkboxes-that-kill/

Bug 851698 - (checkboxes-that-kill) Get rid of options that kill our product

brings me also problems sometimes but is not something that happened to chance, or without thinking,

thank you

Hello, Current Firefox no longer have a user interface setting to disable TLS or SSL3, as cor-el said above, because of that : http://limi.net/checkboxes-that-kill/ [https://bugzilla.mozilla.org/show_bug.cgi?id=851698 Bug 851698] - (checkboxes-that-kill) Get rid of options that kill our product brings me also problems sometimes but is not something that happened to chance, or without thinking, thank you

Modified by ideato