X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FIA website: pdf files not opening in new tab, open in new window instead

Posted

I'm a Formula 1 fan, & regularly visit the FIA website and download/view the pdf's that they put up on their site ( see http://www.fia.com/championship/fia-formula-1-world-championship/2013/2013-hungarian-grand-prix-event-information ) during a Grand Prix weekend,
but when clicking on any pdf in the link above, they always open in a new (not full screen) window, with no "file/edit/view/history... menus or search bar or home button etc...

Any way to get the pdf links to load in a new tab (as it should) and not a new window?

(note pdf's are set to "Use adobe acrobat (in Firefox)")
not had this problem on other websites, where pdf's load in a new tab, and this doesn't happen in IE

Modified by cor-el

Chosen solution

By default, Firefox will divert standard new windows to a tab, but if the link actually is a script that launches a window with special parameters, like a dialog, then Firefox will honor that. There is an obscure setting to disregard those parameters and force all scripted windows into a new tab as well.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered

(3) Double click these and set the value as desired:

(A) browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*)
2 = allow link to open a new window (unchecked*)
1 = force new window into same tab

* First checkbox in Options > Tabs

(B) browser.link.open_newwindow.restriction

0 = apply the setting under (A) to ALL new windows (even script windows)
2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
1 = override the setting under (A) and always use new windows

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • GEPlugin
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Unity Player 3.4.2f3
  • Garmin Communicator Plug-In 3.0.1.0
  • DivX VOD Helper Plug-in
  • getplusplusadobe162102
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

Try this:

  1. Go to the Firefox options
  2. Open the Tabs tab
  3. Make sure the Open new windows in a new tab instead is checked

Please report back if the issue is not solved.


I am also a Formula 1 fan!
Who is your favourite driver? (You can send me a PM if you want)
My favourite driver is Adrian Sutil from Force India.

Helpful Reply

ComputerWhiz

"Make sure the Open new windows in a new tab instead is checked" - it is.

issue still not solved,

ps if you click on a pdf on the above link do you get the same problem or is it just me..?


[Lewis Hamilton]

Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

When I click on the link, it opens in a new tab, but the page is no longer available.

Other PDF files that I have viewed open a new tab not a new window.


Do you open PDF files using the Adobe Reader plugin?

Try to update your Firefox to version 23.0 and see if the issue is resolved.

Wesley Branton
  • Top 25 Contributor
178 solutions 2063 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


Does this stop the problem?

jscher2000
  • Top 10 Contributor
2377 solutions 21041 answers

Chosen Solution

By default, Firefox will divert standard new windows to a tab, but if the link actually is a script that launches a window with special parameters, like a dialog, then Firefox will honor that. There is an obscure setting to disregard those parameters and force all scripted windows into a new tab as well.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered

(3) Double click these and set the value as desired:

(A) browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*)
2 = allow link to open a new window (unchecked*)
1 = force new window into same tab

* First checkbox in Options > Tabs

(B) browser.link.open_newwindow.restriction

0 = apply the setting under (A) to ALL new windows (even script windows)
2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
1 = override the setting under (A) and always use new windows

Question owner

The link in the opening post works if you remove the ')' at the end of the link.

pdf files load in Adobe Reader

problem occurs in safe mode.

Question owner

jscher2000

(A) browser.link.open_newwindow - set to 3 by default


(B) browser.link.open_newwindow.restriction - changed from 2 to 0 - problem solved.

0 = apply the setting under (A) to ALL new windows (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)

Thank you very much for solving this issue.