Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

GMAIL does not allow typing in text box

more options

This seems to have happend soon after upgrading to FF 22 ... but I do not think it is directly related to the upgrade

Is anyone else having a problem using the GMAIL interface and Firefox 22 when trying to type a new email ... forward or reply?

When I try to reply / forward .. or create a new email .. the box opens ... and if reply or forward .. I get the elipses (...) and when clicked ... I even can see the sent message ... but when I try to type in the message box ... I nothing happens ... the backspace works .. but it is like the rest of the keyboard is disabled

I tried

1) reloading the page

2) Logging out and back into GMAIL

3) Clear cache and cookies

4) Close and restart FF 22

5) Downgrading to FF 21

6) I have tried other browsers

Using IE - Succeeds Using Chrome - Succeeds Using Safari - Succeeds Using Opera - Succeeds

<< None allow me to type in GMAIL >>

I did notice one thing .. when Gmail loads .. it hangs (longer than usual) and then a FF bar popup comes up with the message

"Gmail has already been added as an application for mailto links."

I searched on this .. and it seems to be related to setting FF to use Gmail as the MAILTO client ... I use Thuderbird ... so I have no desire to use Gmail as my MAILTO client ...

Has anyone eles had this problem?

I am reluctant to reset to factory defaults as I have made some appearance changes for work ... and do not which to lose them

Chosen solution

Ideato - Will take a look at the bug and article ... tomorrow when I am using the profile again ... THanks

Qpixzy - 64bit Windows Pro ... Nightly? .. as in Firefox Nightly Builds?

Read this answer in context 👍 0

All Replies (18)

more options

Hello dicecollector, did you try to check it in safe mode ? if the problem is in an extension you have.

Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


in linux : Help menu > select Restart with Add-ons Disabled... or

with closed firefox in terminal : firefox -safe-mode

You may need to specify the Firefox installation path (e.g. /usr/lib/firefox)


Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Modified by ideato

more options

Hi Ideato

Thank you for the reply

I think so .. after posting this message I tried it using

HELP => Restart with Add-ons Disabled

Gmail still has the same problem .. and the same popup message occurs

I am very minimal with add-ons for this profile as I work for Oracle ... and nearly anything can effect our web apps

I am using the default theme for the same reason

more options

Do you create the user.js file in profile ?

more options

Not intentionally to my knowledge

I do see a user.js under

...\AppData\Roaming\Mozilla\Firefox\Profiles\ebfpd9gr.ORACLE

it has a file date of 15 Oct 2012

more options

It is possible that the text is invisible (e.g. text color is transparent or font-size = 0 or there is a problem with the used font).

If you press Ctrl+A to select all, do you get any text if you paste it elsewhere in a place where you see text?

You can do a font test to see if you can identify corrupted font(s).

more options

please check in about:config if the dom.storage.enabled is set to default, TRUE

dom.storage.enabled

more options

Thanks again

1) RE invisible text ... I dont think so .. as the cursor never moves

2) RE Ctrl-A - It doesnt even do anything (ie no highlight)

3) RE Corrupted fonts .. I kind of doubt it ... as all other browsers seem to work with the same page ... so a corrupted font on my machine would ... if it were the cause .. would cause the problem on other browsers ... would it not?

4) dom.storage.enabled is set to TRUE


Thanks again

more options

I just discovered another thing .. when I chose BASIC HTML view ... I have no problems

more options

Another thing I have discovered is .. if I change profiles ... the problem no longer occurs (I just ended my day at work ... logged out .. and changed FF profiles) ... so it really seems to be a problem with the settings for that profile ... any ideas?

"Gmail has already been added as an application for mailto links."

Does seem to be common to the problem ... is there a way to disable mailto links?

more options

If you don't have problem in a new profile then you are ok, see :

for the "Gmail has already been added as an application for mailto links." found the next bug :

Bug 668577 - registerProtocolHandler should not re-prompt if a protocol handler already exists and should provide a "don't bug me again" button


if you are ok with the new profile, you don't see the "Gmail has..........." ?

thank you

more options

Do you have a 64bit OS or 32bit...? If you have a 64bit... Nightly would be more stable (in sometimes) than Releases before for Last Supports in Selective OS'ses [Example: 11 to 12,for Windows 2000]

more options

Chosen Solution

Ideato - Will take a look at the bug and article ... tomorrow when I am using the profile again ... THanks

Qpixzy - 64bit Windows Pro ... Nightly? .. as in Firefox Nightly Builds?

more options

Why do you have a user agent override that identifies you as Google Chrome on 64 bit Linux when you are actually on Windows ?

general.useragent.override:

  • Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.21 (KHTML, like Gecko) Chrome/19.0.1042.0 Safari/535.21

See:

more options

That I do not know ... what should it be?

more options

You can reset all general.useragent prefs on the about:config page to the default via the right-click context menu.

more options

I am now available again to address this issue

I failed to start with Idealto's suggestion of 7/25/13 1:49 PM (I missed it) and started with Cor-el's suggestion to reset general.useragent.override ... I did so .. and and did a couple others that I didnt want ... like Dealio ... Cleared Cache ... but not browser history or cookies (as I need these for work) ... reset FF ... and retested GMAIL ... and at present ... So far ... it has solved the problem

I am glad that previous setting is recorded here (I was unable to highlight and copy it ) ... in case something goes wrong today .. as we primarily use Linux here at Oracle ... so who knows .. maybe he setting was correct for something here :)

I checked the setting for general.useragent.override for my non-work profile and there is not even an entry

I have put it on my TO DO list to come back to this thread in a week or so to report on the success of the solution ... If there are any problems ... I will also report so others can benefit from our experience

more options

"dicecollector - 64bit Windows Pro ... Nightly? .. as in Firefox Nightly Builds?" Yea. With Native Nightly Builds. :)

more options

It has been a week now and the problem has not returned ... Thank you to everyone ... I have marked Cor-el's suggestion as the solution