X
Tap here to go to the mobile version of the site.

Support Forum

Enabling SSL

Posted

i just have updated my firefox beta to version 23. the problem is i cant find the encryption tab to enable SSL so this error keeps coming "Secure Connection Failed!.

i just have updated my firefox beta to version 23. the problem is i cant find the encryption tab to enable SSL so this error keeps coming "Secure Connection Failed!.

Chosen solution

go to "about :config" search "security.tls.version.max" and set it "0" اون آدرسی که تو خط اول گفتم رو تو فایرفاکست بزن توش چیزی که خط دوم گفتم رو سرچ کن و به 0 تغییرش بده.حل میشه

Read this answer in context 48

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • GEPlugin
  • 5.1.20125.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Yahoo Application State Plugin version 1.0.0.7
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Waka_Flocka_Flame 441 solutions 5048 answers
refer to * [http://kb.mozillazine.org/SSL_is_disabled SSL Issues - Mozillazine KB] * [[Enable SSL to fix the Firefox cannot connect securely error message]]

Modified by Waka_Flocka_Flame

Helpful Reply

thanks. but as i said there is no encryption tab in advanced panel!

thanks. but as i said there is no encryption tab in advanced panel!
Waka_Flocka_Flame 441 solutions 5048 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Question owner

this shows that there is no encryption tab:

this shows that there is no encryption tab:
Waka_Flocka_Flame 441 solutions 5048 answers
  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. Use the page's Search bar for security.enable_ssl3 double click that if its bold, it should now unbold.
  4. Use the page's Search bar for security.enable_tls double click that if its bold, this should also unblod.

NOTE: If its not bold, dont double click it.

# In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. # Use the page's Search bar for '''security.enable_ssl3''' double click that if its bold, it should now unbold. # Use the page's Search bar for '''security.enable_tls''' double click that if its bold, this should also unblod. '''NOTE:''' If its not bold, dont double click it.
katmando 0 solutions 1 answers

i cant fine the line security.enable_ssl3 and its make no different when i double click security.enable_tls ( still remain bold )

i cant fine the line security.enable_ssl3 and its make no different when i double click security.enable_tls ( still remain bold )
cor-el
  • Top 10 Contributor
  • Moderator
12732 solutions 117066 answers

You can now only set a minimum TLS version and a maximum TLS version (0 means SSL3).

See http://kb.mozillazine.org/kb.mozillazine.org/Security.tls.version.*

  • security.tls.version.min
  • security.tls.version.max
  • 0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.
You can now only set a minimum TLS version and a maximum TLS version (0 means SSL3). See http://kb.mozillazine.org/kb.mozillazine.org/Security.tls.version.* *security.tls.version.min *security.tls.version.max *0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc.
zvandraz 0 solutions 2 answers

there is no encryption tab in advanced panel

there is no encryption tab in advanced panel
zvandraz 0 solutions 2 answers

i can't connect to facebook

i can't connect to facebook
cor-el
  • Top 10 Contributor
  • Moderator
12732 solutions 117066 answers

You need to open the certificates tab (Options > Advanced > Certificates), there you will find the settings.

You can also check the connection settings in "Options > Advanced > Network".

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You need to open the certificates tab (Options > Advanced > Certificates), there you will find the settings. You can also check the connection settings in "Options > Advanced > Network". *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can
Dangerissm 0 solutions 1 answers

Please help me i can't find ssl setting after update to firefox 23 please help me


سلام من بعد از آپدیت به فایرفاکس 23 نمیتونم تنظیمات اس اس ال رو پیدا کنم لطفا کمک کنید نمیتونم برم فیس بوک

Please help me i can't find ssl setting after update to firefox 23 please help me ----------------- سلام من بعد از آپدیت به فایرفاکس 23 نمیتونم تنظیمات اس اس ال رو پیدا کنم لطفا کمک کنید نمیتونم برم فیس بوک
farid87 1 solutions 5 answers

Chosen Solution

go to "about :config" search "security.tls.version.max" and set it "0" اون آدرسی که تو خط اول گفتم رو تو فایرفاکست بزن توش چیزی که خط دوم گفتم رو سرچ کن و به 0 تغییرش بده.حل میشه

go to "about :config" search "security.tls.version.max" and set it "0" اون آدرسی که تو خط اول گفتم رو تو فایرفاکست بزن توش چیزی که خط دوم گفتم رو سرچ کن و به 0 تغییرش بده.حل میشه

Modified by farid87

ali.abry 0 solutions 1 answers

Is there any way that we can bring back the "Encryption" tab ? because some websites does not work if we remove "Use TLS 1.0" check mark , so we have to mark it again to be able to access them and doing this repetitively using "about:config" way is a little hard .

Is there any way that we can bring back the "Encryption" tab ? because some websites does not work if we remove "Use TLS 1.0" check mark , so we have to mark it again to be able to access them and doing this repetitively using "about:config" way is a little hard .