Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make Firefox look the way it used to?

  • 7 replies
  • 13 have this problem
  • 3596 views
  • Last reply by jscher2000

more options

I just bought a new laptop with a 1920x1080 resolution and installed Firefox 21. Everything was compressed to a small portion of my screen and changing the font size did not help much, nor did changing layout.css.devPixelsPerPx. I tried updating to Firefox 22 and now the toolbars are extremely blurry, not to mention everything is still compressed. How can I get it so Firefox looks the way it's supposed to; crisp, clear, and utilizing my entire screen?

Chosen solution

Wow, everyone else is complaining their display is huge in Firefox 22.

Is your Windows DPI setting set to "100% text size" or 96 dpi? You can check the setting using the Display control panel.

When you maximize Firefox, does it not maximize fully? Apparently there were some changes in Firefox 22 related to window sizing (mentioned in another thread) but I'm not sure about what was involved.

By the way, for your screen shot, maybe you could fill half the screen with Firefox and half the screen with IE, both on the same page for comparison.


In case you mean that your entire Windows changes to more of a stretched out low-res display when you launch Firefox, check the program shortcut's Compatibility tab and make sure none of the boxes is checked there.

Read this answer in context 👍 0

All Replies (7)

more options

Could you attach a screenshot?

Try to use JPG or PNG image file format and make it public view.

more options

Could you try with the latest version of Firefox 22, its released today.

more options

You can see the clear Windows 8 buttons compared to the Firefox buttons. PS. This is in the latest Firefox

more options

Chosen Solution

Wow, everyone else is complaining their display is huge in Firefox 22.

Is your Windows DPI setting set to "100% text size" or 96 dpi? You can check the setting using the Display control panel.

When you maximize Firefox, does it not maximize fully? Apparently there were some changes in Firefox 22 related to window sizing (mentioned in another thread) but I'm not sure about what was involved.

By the way, for your screen shot, maybe you could fill half the screen with Firefox and half the screen with IE, both on the same page for comparison.


In case you mean that your entire Windows changes to more of a stretched out low-res display when you launch Firefox, check the program shortcut's Compatibility tab and make sure none of the boxes is checked there.

more options

Thank you for the comment. DPI is set to 125%; on 100% even the Windows Taskbar seems way too small (approx. half a centimeter). Firefox also maximizes fully.

more options

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Modified by cor-el

more options

Hi WHAASIANNN, thanks for the screen shot. I wonder why your Firefox didn't load this forum's custom font? Maybe there are some other issues involved that we'll need to tackle separately.