Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Shortcut for Web Console removed?

  • 4 replies
  • 6 have this problem
  • 18 views
  • Last reply by cor-el

more options

I can no longer bring up/down the Web Console with the Ctrl + Shift + K keyboard shortcut, nor is any shortcut listed next to it under Tools-->Web Developer.

The shortcut is still listed here:

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Not having a shortcut is such a hassle, what good reason is there to remove it?

If it was me who somehow removed it (haven't edited about:config any time recently), I appreciate tips on how to bring it back.

I can no longer bring up/down the Web Console with the Ctrl + Shift + K keyboard shortcut, nor is any shortcut listed next to it under Tools-->Web Developer. The shortcut is still listed here: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly Not having a shortcut is such a hassle, what good reason is there to remove it? If it was me who somehow removed it (haven't edited about:config any time recently), I appreciate tips on how to bring it back.

Chosen solution

It still works for me. Does the problem survive a Firefox exit/restart cycle?

Occasionally there are keyboard shortcut conflicts with add-ons. It's not obvious to me how best to resolve these, but there are add-ons that let you change shortcuts; that might be useful if the conflict persists. To see whether it's caused by an extension, try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Read this answer in context 👍 3

All Replies (4)

more options

Chosen Solution

It still works for me. Does the problem survive a Firefox exit/restart cycle?

Occasionally there are keyboard shortcut conflicts with add-ons. It's not obvious to me how best to resolve these, but there are add-ons that let you change shortcuts; that might be useful if the conflict persists. To see whether it's caused by an extension, try Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Can you access that toolbar via the Developer Toolbar (Shift+F2), click the wrench button on the right?

more options

@jscher2000 and @cor-el THANK YOU both for your kind help.

As suggested, I restarted the browser, and now it's back. I wasn't even able to use the Shift + F2 shortcut either, and the Tools-->Web Developer menu only had one entry beside "view source" and the option to get more tools. Now there's a huge list of tools all back again.

Is there anything I may have accidentally hit on the keyboard (or other) that could have disabled all those tools?

Thanks again

more options

I think that the Web Developer menu is generated by some JavaScript at a later time (a lot of items are in a special #devtoolsKeyset keyset including the Web Console) as it doesn't seem to be there when Extensions are initialized.
So in your cause something went wrong and this script didn't run properly and failed to initialize the Web Developer menu.

Note that various Web Developer tools each have their own pref on the about:config page to enable or disable them.
You can search for devtools.*.enabled via the Search bar at the top of the about:config page.
Some are under development in the current release and thus disabled by default and will be enabled in future Firefox versions.


Modified by cor-el