X
Tap here to go to the mobile version of the site.

Support Forum

Spinning beach ball FFv21, mac os 10.6.8, seizes control of my computer every 10 seconds - Im going mad!!

Posted

Im going insane with the spinning beachball on mac when using Firefox v21.

It happens several times per minute with something as simple as choosing the next field on a page or even scrolling down the page using the scroller on the right hand of the page.

Im on a laptop which has os 10.6.8 installed and the laptop has 8gig of ram and a 2.8ghz intel core 2 duo processor.

On previous versions of Firefox I used to get "unresponsive script" warnings with the option to stop it. These warnings would pop up and never give the option to "always stop an unresponsive script AND never take total control of my computer trying to get the script to respond" There is no option to block the script on the site its coming from.

I did have a block script plug in but no sites work properly if java script isnt enabled.

With Firefox21 I dont get these pop up warnings any more.

I have a lot of tabs open and when the spinning beach ball happens too often I quit firefox and open it again. It remembers my tabs but doesnt load till I click on the tab.

Despite this Firefox will start stalling and showing the beachball spinning only after a few new pages are opened.

It is enfuriating and I dont consider the software to be working properly.

Im wondering has something gottten corrupted in the System Library when firefox installs or if there is a compatability problem with versions of Firefox, my OS10.6.8, Java, Flash?

I can only look at one tab at a time - I WOULD LOVE IF THERE WAS AN OPTION TO

"NOT GIVE ANY RESOURCES TO OTHER TABS WHICH ARENT BEING VIEWED"

I used to use a plug in called Pause All Tabs which was brilliant and gave me back control of my computer. I cant get it for FF21

So what can I do? Use Chrome instead?

Im going insane with the spinning beachball on mac when using Firefox v21. It happens several times per minute with something as simple as choosing the next field on a page or even scrolling down the page using the scroller on the right hand of the page. Im on a laptop which has os 10.6.8 installed and the laptop has 8gig of ram and a 2.8ghz intel core 2 duo processor. On previous versions of Firefox I used to get "unresponsive script" warnings with the option to stop it. These warnings would pop up and never give the option to "always stop an unresponsive script AND never take total control of my computer trying to get the script to respond" There is no option to block the script on the site its coming from. I did have a block script plug in but no sites work properly if java script isnt enabled. With Firefox21 I dont get these pop up warnings any more. I have a lot of tabs open and when the spinning beach ball happens too often I quit firefox and open it again. It remembers my tabs but doesnt load till I click on the tab. Despite this Firefox will start stalling and showing the beachball spinning only after a few new pages are opened. It is enfuriating and I dont consider the software to be working properly. Im wondering has something gottten corrupted in the System Library when firefox installs or if there is a compatability problem with versions of Firefox, my OS10.6.8, Java, Flash? I can only look at one tab at a time - I WOULD LOVE IF THERE WAS AN OPTION TO "NOT GIVE ANY RESOURCES TO OTHER TABS WHICH ARENT BEING VIEWED" I used to use a plug in called Pause All Tabs which was brilliant and gave me back control of my computer. I cant get it for FF21 So what can I do? Use Chrome instead?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/Darwin/en-GB/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DownloadHelper 4.9.15 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Easy YouTube Video Downloader 6.8 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Flash Video Downloader - Youtube Downloader 3.8.7 (artur.dubovoy@gmail.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 647
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 8
  • numTotalWindows: 8
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 9600M GT OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 51200
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.warnOnClose: False
  • dom.disable_window_move_resize: True
  • dom.event.contextmenu.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • font.internaluseonly.changed: False
  • font.name.serif.x-western: Verdana
  • font.size.variable.x-western: 24
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1370027746
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No

Question owner

I cant be the only one out there with this problem on mac os 10.6.8? Is my OS just too old?

I cant be the only one out there with this problem on mac os 10.6.8? Is my OS just too old?

Modified by spinningbeachball

pruntrut 0 solutions 1 answers

I got the same problem since the upgrade to Firefox 21, It's really anoying. I'm on mac OS 10.8.3.

I got the same problem since the upgrade to Firefox 21, It's really anoying. I'm on mac OS 10.8.3.
FredMcD
  • Top 10 Contributor
4259 solutions 59636 answers

Not to answer your primary question but; If you want two sites side by side, open two browsers and put them side by side. You can reduce the pages display size a bit but not too much. If you close Firefox with multiple windows, tabs open at that time, and later restart, only the currently open window and or tab is loaded. The others are loaded when you open them. This option is to save CPU and internet bottle necking. However, this is an option that you can change.

Not to answer your primary question but; If you want two sites side by side, open two browsers and put them side by side. You can reduce the pages display size a bit but not too much. If you close Firefox with multiple windows, tabs open at that time, and later restart, only the currently open window and or tab is loaded. The others are loaded when you open them. This option is to save CPU and internet bottle necking. However, this is an option that you can change.