X
Tap here to go to the mobile version of the site.

Support Forum

Firefox prevents me from copying and pasting content from websites. How do I fix this problem?

Posted

When I enter this website, there are certain areas that FIrefox will allow me to copy and paste. However, if the content is located within frames, I get a message that indicates that Copy/Cut/Paste options are unavailable in Mozilla and Firefox. Then, the information box asks me if I want more information or to cancel the request. When I ask for more information, the system offers information about altering the preferences; however, those steps don't appear to work for me. Please help.

Thanks.

When I enter this website, there are certain areas that FIrefox will allow me to copy and paste. However, if the content is located within frames, I get a message that indicates that Copy/Cut/Paste options are unavailable in Mozilla and Firefox. Then, the information box asks me if I want more information or to cancel the request. When I ask for more information, the system offers information about altering the preferences; however, those steps don't appear to work for me. Please help. Thanks.

Chosen solution

What steps did you try -- editing prefs.js or user.js?

My recommendation would be to use the Windows shortcuts for cut, copy, and paste: Ctrl+x, Ctrl+c, and Ctrl+v. You might also use the right-click context menu for these actions. On most websites, you don't really need to use their buttons for these features.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Website Logon Plugin
  • Citrix Online App Detector Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Chosen Solution

What steps did you try -- editing prefs.js or user.js?

My recommendation would be to use the Windows shortcuts for cut, copy, and paste: Ctrl+x, Ctrl+c, and Ctrl+v. You might also use the right-click context menu for these actions. On most websites, you don't really need to use their buttons for these features.

What steps did you try -- editing prefs.js or user.js? My recommendation would be to use the Windows shortcuts for cut, copy, and paste: Ctrl+x, Ctrl+c, and Ctrl+v. You might also use the right-click context menu for these actions. On most websites, you don't really need to use their buttons for these features.

Question owner

I tried both of those options. Thanks so much for your help......The Windows shortcuts work......You are a lifesaver:).....

I tried both of those options. Thanks so much for your help......The Windows shortcuts work......You are a lifesaver:).....
happykt 0 solutions 1 answers

I've been visiting fanficiton.net for years and copying chapters to various stories to have the ability to read the completed story on my ebook reader. Last Saturday, the ability to copy and paste from fanfiction.net has stopped working using both Mozilla and Google Chrome but my drag, copy and paste ability still works on Internet Explorer.

fanfiction.net I believe uses frames. I have also emailed and Tweeted fanfiction.net several times but have not received a reply from them. I have no idea what happened last week to throw everything off.

I tried using ctl/C and it doesn't work. Only the top summary of the story is copied. The drag, copy and paste function is highlighting in Mozilla but nothing is being copied. I uninstalled Google Chrome and Mozilla, cleaned out my cache, uninstalled most of plugins I have but nothing is working. I can copy many other websites but not fanfiction.net. Any help would be appreciated :)

I've been visiting fanficiton.net for years and copying chapters to various stories to have the ability to read the completed story on my ebook reader. Last Saturday, the ability to copy and paste from fanfiction.net has stopped working using both Mozilla and Google Chrome but my drag, copy and paste ability still works on Internet Explorer. fanfiction.net I believe uses frames. I have also emailed and Tweeted fanfiction.net several times but have not received a reply from them. I have no idea what happened last week to throw everything off. I tried using ctl/C and it doesn't work. Only the top summary of the story is copied. The drag, copy and paste function is highlighting in Mozilla but nothing is being copied. I uninstalled Google Chrome and Mozilla, cleaned out my cache, uninstalled most of plugins I have but nothing is working. I can copy many other websites but not fanfiction.net. Any help would be appreciated :)

Modified by happykt

jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Helpful Reply

Hi happykt, I loaded a story and found that the mouse doesn't select anything in the main story area, although I can select in the header area near the author picture and I can select the entire page using Ctrl+a.

Right-clicking the story area and using Firefox's Inspect Element feature, I discovered the problem: the site is adding a style rule to block Firefox from selecting text:

<div role="main" class="storytextp" id="storytextp" style="padding: 0px 0.5em; -moz-user-select: none;" align="center">

Some elements within the main story have a .nocopy class name assigned, which applies a similar rule indirectly. Clearly the site doesn't want you to copy anything! Not sure why they didn't just come out and tell you this. Hmmm...


If you want to work around this "feature", you have three options:

(1) Turn off styles for the page temporarily. You can do this from the View menu.

Tap the Alt key if needed to display the classic menu bar

View menu > Page Style > No Style

Scroll down past all the menus and headings and copy at will.

(2) Use custom style rules to alter the page on each visit. Someone would need to develop this for you, and then you could add them to a file named userContent.css or use the Stylish extension.

(3) Use a script or add-on to alter the page on demand or automatically on each visit. Again, someone would need to create this and then describe how to implement it.

Hi happykt, I loaded a story and found that the mouse doesn't select anything in the main story area, although I can select in the header area near the author picture and I can select the entire page using Ctrl+a. Right-clicking the story area and using Firefox's Inspect Element feature, I discovered the problem: the site is adding a style rule to block Firefox from selecting text: &lt;div role="main" class="storytextp" id="storytextp" style="padding: 0px 0.5em; '''-moz-user-select: none;'''" align="center"> Some elements within the main story have a .nocopy class name assigned, which applies a similar rule indirectly. Clearly the site doesn't want you to copy anything! Not sure why they didn't just come out and tell you this. Hmmm... ---- If you want to work around this "feature", you have three options: (1) Turn off styles for the page temporarily. You can do this from the View menu. Tap the Alt key if needed to display the classic menu bar View menu > Page Style > No Style Scroll down past all the menus and headings and copy at will. (2) Use custom style rules to alter the page on each visit. Someone would need to develop this for you, and then you could add them to a file named userContent.css or use the Stylish extension. (3) Use a script or add-on to alter the page on demand or automatically on each visit. Again, someone would need to create this and then describe how to implement it.
codygotkilld 0 solutions 5 answers

@jscher2000 Is it possible that they can use the nocopy script on the no style view as well? I've come to be very wary of ff.net when it comes to things like this in the last two years. I have dyslexia and I'm unable to use my normal program since the implementation of the nocopy script and your first workaround is a big help to me. I would hate to know that my current fix to this problem is just a temporary solution.

@jscher2000 Is it possible that they can use the nocopy script on the no style view as well? I've come to be very wary of ff.net when it comes to things like this in the last two years. I have dyslexia and I'm unable to use my normal program since the implementation of the nocopy script and your first workaround is a big help to me. I would hate to know that my current fix to this problem is just a temporary solution.
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Helpful Reply

Hi codygotkilld, scripts can still operate when you turn off styles, so those will still be a concern for you. As you may recall, there was an Advanced JavaScript options dialog in earlier versions of Firefox where you could disable sites from replacing Firefox's right-click context menu with their own menu or an annoying copyright warning.

That setting still exists but it's a little harder to reach now because you need to use the about:config preferences editor. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste context and pause while the list is filtered

(3) Double-click the dom.event.contextmenu.enabled preference to switch it from the default value of true (sites can cancel Firefox's context menu) to false (always show Firefox's context menu).

On some sites, such as Google Maps, the site's menu will open behind Firefox's menu. To cancel Firefox's menu and use the site's menu, tap the Esc key once.

If you're interested, the following post has the details on the other two settings that were in that dialog: https://support.mozilla.org/en-US/questions/967108#answer-464407

Hi codygotkilld, scripts can still operate when you turn off styles, so those will still be a concern for you. As you may recall, there was an Advanced JavaScript options dialog in earlier versions of Firefox where you could disable sites from replacing Firefox's right-click context menu with their own menu or an annoying copyright warning. That setting still exists but it's a little harder to reach now because you need to use the about:config preferences editor. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''context''' and pause while the list is filtered (3) Double-click the '''dom.event.contextmenu.enabled''' preference to switch it from the default value of true (sites can cancel Firefox's context menu) to false (always show Firefox's context menu). On some sites, such as Google Maps, the site's menu will open ''behind'' Firefox's menu. To cancel Firefox's menu and use the site's menu, tap the Esc key once. If you're interested, the following post has the details on the other two settings that were in that dialog: https://support.mozilla.org/en-US/questions/967108#answer-464407
Ellen-Rose 0 solutions 1 answers

Happykt -

If you want FanFiction dot net stories on your e-book reader, go to FanFiction Downloader. It will not only collate stories for you, it will put them into e-book format. I'm using MOBI, but EPUB and a lot of other formats are available.You can even save stories in RTF. The program collects the whole thing, and doesn't get all the metadata FFnet puts at the beginning and end. (They came out with a rapid update to fix the 'can't copy' problem.)

This still doesn't let me bookmark author pages, but it's a start.

Happykt - If you want FanFiction dot net stories on your e-book reader, go to [http://www.FanFictionDownloader.net FanFiction Downloader]. It will not only collate stories for you, it will put them into e-book format. I'm using MOBI, but EPUB and a lot of other formats are available.You can even save stories in RTF. The program collects the whole thing, and doesn't get all the metadata FFnet puts at the beginning and end. (They came out with a rapid update to fix the 'can't copy' problem.) This still doesn't let me bookmark author pages, but it's a start.
sapho99 0 solutions 2 answers

I have the same problem, also under the EDIT tab is greyed out and right click doesn't work, using Mozila 25 on a vista machine. Any suggestions, if I keep having all these problems......really getting fed up!

I have the same problem, also under the EDIT tab is greyed out and right click doesn't work, using Mozila 25 on a vista machine. Any suggestions, if I keep having all these problems......really getting fed up!
sapho99 0 solutions 2 answers

On fanfiction site, i cannot copy/paste, on the menu under edit, it is greyed out, no features work. mouse right click copy/paste does not work. the Windows keys do not work. I have Vista OS I did try going the no style but it still wouldn't copy/paste ? I'm not copying stories, I copy out the Recommended works/stories that the authors give out. Now I cannot do that any more. Would Chrome work?

On fanfiction site, i cannot copy/paste, on the menu under edit, it is greyed out, no features work. mouse right click copy/paste does not work. the Windows keys do not work. I have Vista OS I did try going the no style but it still wouldn't copy/paste ? I'm not copying stories, I copy out the Recommended works/stories that the authors give out. Now I cannot do that any more. Would Chrome work?
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Hi sapho99, other browsers might work. As noted in my earlier post, there is a style rule specifically targeted at Firefox users to frustrate selection of text in part of the page: 960726#answer-489703. You can still copy the whole page (Ctrl+a, Ctrl+c), but for a partial selection you need to use one of the workarounds.

Hi sapho99, other browsers might work. As noted in my earlier post, there is a style rule specifically targeted at Firefox users to frustrate selection of text in part of the page: [https://support.mozilla.org/en-US/questions/960726#answer-489703 960726#answer-489703]. You can still copy the whole page (Ctrl+a, Ctrl+c), but for a partial selection you need to use one of the workarounds.
cor-el
  • Top 10 Contributor
  • Moderator
16653 solutions 150528 answers

You can copy and Paste the JavaScript code in the command line in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and press the Enter key.

document.querySelector("#storytextp").style.setProperty("-moz-user-select","auto","");

Bookmarklet:

javascript:void(document.querySelector("#storytextp").style.setProperty("-moz-user-select","auto",""));
You can copy and Paste the JavaScript code in the command line in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and press the Enter key. <pre><nowiki>document.querySelector("#storytextp").style.setProperty("-moz-user-select","auto","");</nowiki></pre> ------ Bookmarklet: <pre><nowiki>javascript:void(document.querySelector("#storytextp").style.setProperty("-moz-user-select","auto",""));</nowiki></pre>