X
Tap here to go to the mobile version of the site.

Support Forum

Firefox shows typed input backwards!

Posted

Sometimes when we type in text or numbers Firefox displays it backwards such that if I type in 12345 it is displayed as 54321. That can be critical if you are entering a username and/or password and especially for site that allow only a limited number of attempts (such as an on line banking account). We currently use FF 21.0, on Windows XP Pro Sp3, Windows Vista Business and Ubuntu 12.10 and it happens on all of these. To temporarily resolve the problem we usually have to close and restart Firefox but not the OS. This does not happen with any other software that we use.

Sometimes when we type in text or numbers Firefox displays it backwards such that if I type in 12345 it is displayed as 54321. That can be critical if you are entering a username and/or password and especially for site that allow only a limited number of attempts (such as an on line banking account). We currently use FF 21.0, on Windows XP Pro Sp3, Windows Vista Business and Ubuntu 12.10 and it happens on all of these. To temporarily resolve the problem we usually have to close and restart Firefox but not the OS. This does not happen with any other software that we use.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • VLC media player Web Plugin 2.0.6
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Npdsplay dll

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-GB/

Extensions

  • Advertising Cookie Opt-out 1.5 (optout@google.com)
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • Beef Taco (Targeted Advertising Cookie Opt-Out) 1.3.7 (john@velvetcache.org)
  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • Clear Cache Button 0.9f ({563e4790-7e70-11da-a72b-0800200c9a66})
  • DownThemAll! 2.0.13 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Edit Cookies 0.3.8.1 ({ea2b95c2-9be8-48ed-bdd1-5fcd2ad0ff99})
  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • Google Analytics Opt-out Browser Add-on 0.9.6 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • IE Tab 2 (FF 3.6+) 4.1.3.1 ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB})
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • My Homepage 1.2 (myhomepage_manishjain9@gmail.com)
  • Password Exporter 1.2.1 ({B17C1C5A-04B1-11DB-9804-B622A1EF5492})
  • Saved Password Editor 2.7 (savedpasswordeditor@daniel.dawson)
  • Show my Password 2.0 ({cd617372-6743-4ee4-bac4-fbf60f35719e})
  • Show Password 1.7 (showpassword@pratikpoddar)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Webmail Ad Blocker 3.9.1 (gmailnoads@mywebber.com)
  • Ghostery 2.9.5 (firefox@ghostery.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-13-2010
  • driverDate2:
  • driverVersion: 6.14.10.5218
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage: http://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.loadInBackground: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • general.autoScroll: False
  • keyword.URL: http://dts.search-results.com/sr?src=ffb&gct=ds&appid=362&systemid=406&apn_dtid=BND406&apn_ptnrs=AG6&apn_uid=3163095313054520&o=APN10645&q=
  • network.cookie.cookieBehavior: 1
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 96
  • network.http.max-connections-per-server: 32
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 8
  • network.http.proxy.pipelining: True
  • places.database.lastMaintenance: 1369317535
  • places.history.expiration.transient_current_max_pages: 53435
  • places.history.expiration.transient_optimal_database_size: 85494824
  • places.last_vacuum: 1303556493
  • plugin.disable_full_page_plugin_for_types: audio/aac,audio/x-aac,audio/ac3,audio/x-ac3,audio/aiff,audio/x-aiff,audio/AMR,application/x-mplayer2,video/x-ms-asf,video/x-ms-asf-plugin,audio/basic,audio/x-caf,audio/x-m4p,audio/mid,audio/midi,audio/x-midi,audio/vnd.qcelp,audio/x-ms-wma,video/x-ms-wmv,application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.extensions-dta: True
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.dialog_enable_delay: 100
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
Svetlana 76 solutions 915 answers

Helpful Reply

Hello,

In a text box, you can switch text direction using ctrl + shift + x keyboard shortcut. If you press this key combination accidentally you may see a wrong input mode like you described.

Please let me know whether this is the case. Thank you.

Hello, In a text box, you can switch text direction using '''ctrl + shift + x''' keyboard shortcut. If you press this key combination accidentally you may see a wrong input mode like you described. Please let me know whether this is the case. Thank you.

Question owner

This happens completely unexpectedly and we are very experienced computer users (since 1976 in my case!) so we know we do not make even accidental key presses of the combination mentioned. So it is not a matter of having pressed those keys at all. Example, I typed a letter this morning using LibreOffice Writer and all was well, then went to examine an account using FF and the username and password were entered backwards as I typed! The cursor was starting on the right and moving to the left and not as expected starting at the left and moving to the right! The only known way to escape that behaviour is to close FF and restart!

Any further ideas?

This happens completely unexpectedly and we are very experienced computer users (since 1976 in my case!) so we know we do not make even accidental key presses of the combination mentioned. So it is not a matter of having pressed those keys at all. Example, I typed a letter this morning using LibreOffice Writer and all was well, then went to examine an account using FF and the username and password were entered backwards as I typed! The cursor was starting on the right and moving to the left and not as expected starting at the left and moving to the right! The only known way to escape that behaviour is to close FF and restart! Any further ideas?
ideato 893 solutions 6250 answers

Hello MikeP_UK, the strange is that you have the same issue in Windows XP Vista and Ubuntu ! Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello MikeP_UK, the strange is that you have the same issue in Windows XP Vista and Ubuntu ! '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

This problem occurs in both modes and on XP Pro, Vista Business and Ubuntu 12.10, so to me it seems to be within the Firefox code somewhere. So I am looking to the Firefox team to resolve the issue.

(Note that I have used and built computers for over 30 years and worked in a technical role in the EDA software industry but not as a code developer.)

This problem occurs in both modes and on XP Pro, Vista Business and Ubuntu 12.10, so to me it seems to be within the Firefox code somewhere. So I am looking to the Firefox team to resolve the issue. (Note that I have used and built computers for over 30 years and worked in a technical role in the EDA software industry but not as a code developer.)
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Are there any Java applets running in other tabs when this happens, because that has been reported in the past to cause this issue?

Are there any Java applets running in other tabs when this happens, because that has been reported in the past to cause this issue?

Question owner

There are no other tabs open and no Java applets running. So that is irrelevant. Try again?

There are no other tabs open and no Java applets running. So that is irrelevant. Try again?
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

This happens when the cursor stays steady and isn't moved after the typed character, so all new characters that you type are entered at the current position and already typed characters are pushed one position to the right. causing the text to appear backwards.

It is weird that this happens with different Operating Systems (Linux and Windows).

This happens when the cursor stays steady and isn't moved after the typed character, so all new characters that you type are entered at the current position and already typed characters are pushed one position to the right. causing the text to appear backwards. It is weird that this happens with different Operating Systems (Linux and Windows).

Question owner

Nothing weird about it at all if the fault is within the Firefox code!

If I type something in a field in the normal UK English way, it shows the letters I typed in reverse order and they are entered at the left end instead of the right end, not always but often enough to be a problem - especially when logging in for internet banking. On some occasions only some of the letters are reversed! For example I logged into my modem router and it took the first letter and put it to the right of the cursor and then showed all the other characters in the correct order - but to the left of the first character! Try again, please?

Nothing weird about it at all if the fault is within the Firefox code! If I type something in a field in the normal UK English way, it shows the letters I typed in reverse order and they are entered at the left end instead of the right end, not always but often enough to be a problem - especially when logging in for internet banking. On some occasions only some of the letters are reversed! For example I logged into my modem router and it took the first letter and put it to the right of the cursor and then showed all the other characters in the correct order - but to the left of the first character! Try again, please?
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

If it would be a fault in Firefox then we would this reported a lot more times and I've only seen your report recently (i.e during the last few years).

Did you try a new keyboard?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

If it would be a fault in Firefox then we would this reported a lot more times and I've only seen your report recently (i.e during the last few years). Did you try a new keyboard? Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

Your ideas are flawed. This happens on 3 different PCs, different hardware and different software combinations. Only common factor is Firefox!

So It cannot be keyboard. If it were then it would affect all other software such as text entry applications - it doesn't. It only affects text being entered into a box in Firefox, such as when logging into an account, etc.

That it happens on 3 different PCs running different OSs, not all Microsoft, means that the boot mode is irrelevant - especially in Ubuntu 12.10!

Using my extensive experience in electronics fault finding, the common factor is always the cause - Firefox in this case.

Any better ideas that address the actual problem as stated?

Your ideas are flawed. This happens on 3 different PCs, different hardware and different software combinations. Only common factor is Firefox! So It cannot be keyboard. If it were then it would affect all other software such as text entry applications - it doesn't. It only affects text being entered into a box in Firefox, such as when logging into an account, etc. That it happens on 3 different PCs running different OSs, not all Microsoft, means that the boot mode is irrelevant - especially in Ubuntu 12.10! Using my extensive experience in electronics fault finding, the common factor is always the cause - Firefox in this case. Any better ideas that address the actual problem as stated?
Tonnes
  • Locale Leader
246 solutions 1454 answers

I still haven’t read your answer on if you disabled all add-ons (i.e. started in Firefox’s Safe Mode) like ideato suggested, which is vital. The only thing I could think of is a mutual but often overlooked or too much trusted add-on (or other mutual piece of software) on all your systems.

I still haven’t read your answer on if you disabled all add-ons (i.e. started in Firefox’s Safe Mode) like ideato suggested, which is vital. The only thing I could think of is a mutual but often overlooked or too much trusted add-on (or other mutual piece of software) on all your systems.

Question owner

Tonnes

It was answered way back!

The Ubuntu version does NOT have any add-ons installed, but still has the problem! Plus the same happens on 3 computers all running different operating systems and having different add-ons with the Windows versions.

Talking with my brother reveals he has the same problem on his 4 computers as well! He uses 2 with W7, one with Vista and one with XP Pro. That shows it's not my computers nor the way they are set up!

Tonnes It was answered way back! The Ubuntu version does NOT have any add-ons installed, but still has the problem! Plus the same happens on 3 computers all running different operating systems and having different add-ons with the Windows versions. Talking with my brother reveals he has the same problem on his 4 computers as well! He uses 2 with W7, one with Vista and one with XP Pro. That shows it's not my computers nor the way they are set up!
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Did you try to disable all plugins?

Did you try to disable all plugins?

Question owner

Yes, on all 3 of our PCs and it made no difference at all.

As stated before, the ONLY common factor is Firefox.

Yes, on all 3 of our PCs and it made no difference at all. As stated before, the ONLY common factor is Firefox.
MozillaVanilla 0 solutions 5 answers

To MikeP_UK:

You're right, this IS a Firefox issue and it apparently DOESN'T involve any KNOWN shortcut (key) combination. BUT, it DOES involve hitting a key combo of some kind (or some KINDS... I have noticed that SOMETIMES my input changes to the reverse, as in your case, and SOMETIMES to "reversed Romanized Cyrillic" or some such WEIRD, ALPHANUMERIC language!). I have tried everything to escape this "jinx" while INSIDE the browser, but TO NO AVAIL! There is a quicker way to solve the problem than having to close and reopen the browser (note that trying to write the text in a search field, on a word count/ character count site, on a TypeIt dot org page or even on the Google Translate page DOES NOT help!): Copy the last stretch of good text you have written (a word or two is sufficient) and paste it into a word processor (MS Word, Open Office, etc.) or a text editor -- even Notepad -- then continue writing there (again, a word or two will do), and leave a bit of untyped space at the end (press the spacebar a few times), just for safety's sake, then paste this new text + white space over the highlighted text that you left behind on your browser, and you're good to go! Of course, you can open Notepad (etc.) WHEN you open your browser, that way you can make the correction(s) much easier.

To MikeP_UK: You're right, this IS a Firefox issue and it apparently DOESN'T involve any KNOWN shortcut (key) combination. BUT, it DOES involve hitting a key combo of some kind (or some KINDS... I have noticed that SOMETIMES my input changes to the reverse, as in your case, and SOMETIMES to "reversed Romanized Cyrillic" or some such WEIRD, ALPHANUMERIC language!). I have tried everything to escape this "jinx" while INSIDE the browser, but TO NO AVAIL! There is a quicker way to solve the problem than having to close and reopen the browser (note that trying to write the text in a search field, on a word count/ character count site, on a TypeIt dot org page or even on the Google Translate page DOES NOT help!): Copy the last stretch of good text you have written (a word or two is sufficient) and paste it into a word processor (MS Word, Open Office, etc.) or a text editor -- even Notepad -- then continue writing there (again, a word or two will do), and leave a bit of untyped space at the end (press the spacebar a few times), just for safety's sake, then paste this new text + white space over the highlighted text that you left behind on your browser, and you're good to go! Of course, you can open Notepad (etc.) WHEN you open your browser, that way you can make the correction(s) much easier.

Modified by MozillaVanilla

Question owner

I'll give that a try but it's not really a fix, just a workaround. And it's an extra fiddle that should not be needed. It's especially annoying when trying to log in to our internet banking or web-based email programmes or trying to place and on-line order and entering a card number - all of which require absolute accuracy.

I'll give that a try but it's not really a fix, just a workaround. And it's an extra fiddle that should not be needed. It's especially annoying when trying to log in to our internet banking or web-based email programmes or trying to place and on-line order and entering a card number - all of which require absolute accuracy.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

You see the text backwards if the cursor position isn't updated after typing a letter causing already entered text to be pushed to the right instead of appending that letter at the end.
Firefox wouldn't do this by default, so it is either caused by an add-on (extension or plugin) or othwer software that runs on the computer.

Note that Firefox Safe Mode doesn't have effect on plugins.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

You see the text backwards if the cursor position isn't updated after typing a letter causing already entered text to be pushed to the right instead of appending that letter at the end.<br /> Firefox wouldn't do this by default, so it is either caused by an add-on (extension or plugin) or othwer software that runs on the computer. Note that Firefox Safe Mode doesn't have effect on plugins. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/Troubleshooting+plugins Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

Tried all that before posting!

Tried all that before posting!
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159013 answers

Can you at least move the cursor yourself if this happens or is the cursor entirely frozen?

Can you at least move the cursor yourself if this happens or is the cursor entirely frozen?

Question owner

Yes I can move it, if I notice the text is being entered backwards which doesn't happen every time. Plus it is not the normal behaviour when entering text to move the entry point manually. (I've had to do that twice while typing this response!)

The real problem is when entering a password/passphrase that is displayed as a series of asterisks so not clear text and you cannot tell until the password/passphrase is rejected. So you have to type it in again and hope it doesn't fail enough times to cause a 'lock out'.

Yes I can move it, if I notice the text is being entered backwards which doesn't happen every time. Plus it is not the normal behaviour when entering text to move the entry point manually. (I've had to do that twice while typing this response!) The real problem is when entering a password/passphrase that is displayed as a series of asterisks so not clear text and you cannot tell until the password/passphrase is rejected. So you have to type it in again and hope it doesn't fail enough times to cause a 'lock out'.