Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox shows typed input backwards!

  • 27 replies
  • 3 have this problem
  • 2520 views
  • Last reply by MikeP_UK

more options

Sometimes when we type in text or numbers Firefox displays it backwards such that if I type in 12345 it is displayed as 54321. That can be critical if you are entering a username and/or password and especially for site that allow only a limited number of attempts (such as an on line banking account). We currently use FF 21.0, on Windows XP Pro Sp3, Windows Vista Business and Ubuntu 12.10 and it happens on all of these. To temporarily resolve the problem we usually have to close and restart Firefox but not the OS. This does not happen with any other software that we use.

All Replies (7)

more options

A possibility is to type the password text temporarily in the user name field and select it and copy it to the clipboard and then immediately delete it from the user name field (press Delete to remove the selected text), so you can paste it from the clipboard if you do not want to use the Password Manager. The fact that it doesn't happen all the time could still indicate that a plugin that is running in another tab is involved.

You are using a standard keyboard and layout in Windows?

more options

RE cor-el's latest comment, I don't quite see the advantage in writing a string of gobbeldygook in the username/ password input field, then copying it to the clipboard, deleting the highlighted "dot-dot-dot" entry in the input field in question, then pasting it back in the input field, unless the idea is to check whether the "dot-dot-dot" entry truly IS the proper text (by pasting it somewhere else, for verification), for IF the "dot-dot-dot" entry IS gobbeldygook, then, then, then... what the dickens is gained?!

Here's what I do if I'm not sure whether my keyboard is entering gobbeldygook or "good gook": I write the password in a search field (NOT in the http field!) to see if it is okay; if okay, I copy everything from right to left, save the first letter, then I delete twice (killing the highlighted part AND the first, un-highlighted letter), then I write in the first letter, then paste from the clipboard. NOTE, however, that pasting from the clipboard is sometimes simply not allowed - the input field will remain blank!

IF the input text IS gobbeldygook, then I go outside the browser and follow the procedure immediately above, where pasting is allowed, but note that even where pasting from the clipboard is NOT allowed, just going outside the browser should clear up the "jinx" (one can try pasting into any non-http field in the browser and then continue writing a bit in the same field in order to check whether the "jinx" has been broken... a trip OUTSIDE the browser (to Word, etc.) has NEVER NOT WORKED for me!).

While waiting for Godot, fixes and workarounds aren't the worst bridging solutions!

more options

You can use it in case of problems to make sure to get the correct password in the password field. You can of course type that password anywhere and copy it to the clipboard to be able to paste it in one go in the password field.

more options

to Cor-el The copy/paste 'solution' does not work! Especially where there is a need to confirm the password and most web-based systems do not allow a copy/paste method as the field remains empty.

To all The only work-around I've found is to delete all the text and start again as you never know where in the text input process the error starts, it could be after the first character is entered or anywhere after that! As the error is intermittent, you have to keep trying and hope you manage to get accurate text input before and attempt limits kick in. (The problem occurred twice while composing this response!)

more options

Hmm. If you can't paste then it looks that some JavaScript is processing each key press and if that is the case then that script might be causing the problems. Pasting in a normal text or password field shouldn't be a problem (the Firefox Password Manager allows to right click and copy the password to the clipboard to facilitate this).

more options

To MikeP_UK's latest response (the "to all" part): You OBVIOUSLY aren't experiencing the bad Weird Input Text case that I suffer from, for there is simply NO WAY to exit the "jinx" with the WIT case that I suffer from (in Mozilla -- next time I find myself "jinxed", I'll open Chrome and see if I can write normally there, maybe even use Chrome where I have hitherto been using MS Word) save going OUTSIDE the browser.

And we're both right, MikeP_UK, there ARE situations where pasting is simply NOT accepted in some Username/ Password fields.

I seem to recall that at one point in this crazy saga, I could erase everything (hold the Backspace key down until it reached "Home"/ the left extreme, then hold it there a second or two) and that would seem to erase things, but eventually, even that quit working, which, when one thinks about it, is DOUBLE-WEIRD!

TO ALL: my alternative explanation for our WIT with Mozilla is owing to... Bullrun -- YIKES!

more options

To Cor-el: There are a great many websites that do not allow copy/paste of the password fields. They are deliberately written that way to prevent automated responses setting up accounts all over the place. It is not a matter that Firefox or any other web browser 'allows' copy/paste in these specific fields, the website itself determines whether it is allowed and those who have any interest in security would never allow copy/paste of any password.

Modified by MikeP_UK

  1. 1
  2. 2