X
Tap here to go to the mobile version of the site.

Support Forum

Clicking a .pdf link does not open .pdf file, it opens a SAVE DIALOG box

Posted

Recently when I click on a .pdf file link I am no longer able to open the file in a adobe reader either within a FIREFOX webpage or open it using the full adobe program. Instead it opens a SAVE dialog box requesting me to save to my harddrive. I am not sure what has happened and am trying to find someone who might know what is going on?

Recently when I click on a .pdf file link I am no longer able to open the file in a adobe reader either within a FIREFOX webpage or open it using the full adobe program. Instead it opens a SAVE dialog box requesting me to save to my harddrive. I am not sure what has happened and am trying to find someone who might know what is going on?

Chosen solution

I had the same problem, but I got it right by the following methods:

Go to Firefox > Options > Applications > Portable Document Format (PDF)

And for Portable Document Format (PDF) set the status as "Use Adobe Acrobat (in Firefox)"

Done

Now the PDF file opens within the Firefox browser without any need to download the file to open.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin
  • iTunes Detector Plug-in
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • LastPass 2.0.20 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce2 MX/MX 400 (Microsoft Corporation)
  • adapterDescription2:
  • adapterDeviceID: 0x0110
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'182.65']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-7-2004
  • driverDate2:
  • driverVersion: 5.6.7.3
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'182.65']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'182.65']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.update: False
  • browser.startup.homepage: www.yahoo.com
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.onTop: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1368784330
  • places.history.expiration.transient_current_max_pages: 98088
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0

Misc

  • User JS: No
  • Accessibility: No

Question owner

Here is a screen shot of the dialog box that opens after clicking a .pdf file URL on website "X" (This happens anytime I try to open a link that is a .pdf file). If I use Internet explorer I am able to open the .pdf file with no problem in either a new INTERNET EXPLORER TAB or sometimes they open up with the full ADOBE viewer. I therefor surmise that it is something with FIREFOX that prevent me from viewing a .pdf file.

If I save the file to my harddrive, I am able to open the .pdf file with no problem using ADOBE.

Here is a screen shot of the dialog box that opens after clicking a .pdf file URL on website "X" (This happens anytime I try to open a link that is a .pdf file). If I use Internet explorer I am able to open the .pdf file with no problem in either a new INTERNET EXPLORER TAB or sometimes they open up with the full ADOBE viewer. I therefor surmise that it is something with FIREFOX that prevent me from viewing a .pdf file. If I save the file to my harddrive, I am able to open the .pdf file with no problem using ADOBE.
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

Helpful Reply

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications". You can set the pdfjs.disabled pref to true on the <b>about:config</b> page to disable the build-in PDF viewer. You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/kb/view-pdf-files-firefox-without-downloading-them

Question owner

Cor-el,

  Your link to the https://support.mozilla.org/kb/view-pdf-files-firefox-without-downloading-them did the trick.  I had to scroll down about half way down to find the "Portable Document Format (pdf)" entry.  How mine got changed I don't know because I surely didn't do it.  I am not sure if this was set with the newest update to either version 21.0 or the earlier version of FIREFOX update?

I did not change anything in my ABOUT:CONFIG file. This is what I currently have and have left it like this;

plugin.disable_full_page_plugin_for_types;application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml

Thank you very much!!

Cor-el, Your link to the [http://example.com https://support.mozilla.org/kb/view-pdf-files-firefox-without-downloading-them] did the trick. I had to scroll down about half way down to find the "Portable Document Format (pdf)" entry. How mine got changed I don't know because I surely didn't do it. I am not sure if this was set with the newest update to either version 21.0 or the earlier version of FIREFOX update? I did not change anything in my ABOUT:CONFIG file. This is what I currently have and have left it like this; plugin.disable_full_page_plugin_for_types;application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml Thank you very much!!

Modified by marshallgrads

thusi 1 solutions 1 answers

Chosen Solution

I had the same problem, but I got it right by the following methods:

Go to Firefox > Options > Applications > Portable Document Format (PDF)

And for Portable Document Format (PDF) set the status as "Use Adobe Acrobat (in Firefox)"

Done

Now the PDF file opens within the Firefox browser without any need to download the file to open.

I had the same problem, but I got it right by the following methods: Go to Firefox > Options > Applications > Portable Document Format (PDF) And for Portable Document Format (PDF) set the status as "Use Adobe Acrobat (in Firefox)" Done Now the PDF file opens within the Firefox browser without any need to download the file to open.