X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I Can't import bookmarks from Safari. I've tried all the advice given but nothing works. Please help. Thanks.

Posted

My Imac is version 10.8 snow leopard. I tried to import bookmarks from Safari to Firefox but import data from another browser is greyed out, even though private browsing is turned off. I also created an .html file for my bookmarks no problem but when I import this file to firefox, no bookmarks appear. I checked the file in a plain text editor for any folded files but none existed. Can anyone help me solve this problem. It seems the easiest solution would be if the IMPORT DATA FROM ANOTHER BROWSER button was functional. thanks.

Chosen solution

I'm not familiar with TextEdit.app but I did a little searching...

I think you have 3 options:

(1) Switch how TextEdit opens .html files from showing them as web pages to showing the HTML source. This article describes how: Turn TextEdit Into an HTML Source Viewer with a Simple Settings Change.

(2) If you don't want to make the change in #1, open the file from inside TextEdit using File > Open and check the box to "Ignore rich text commands".

(3) Alternately, add .txt at the end of the file name. When you open the file, TextEdit should not try to display it as a webpage. After editing, you'll need to change the file extension back to .html for Firefox to be able to find it for importing.

Do any of those work for you?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Version 3.18.1.12731
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Shockwave Flash 11.6 r602
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Did you check the H3 tags in the HTML file?

  • <DT><H3 FOLDED>Bookmarks Bar</H3>

Helpful Reply

Yes, I couldn't see anything starting with H3, Only bookmark names.

I assume I am checking correctly? For example, Sydney Ferries - Home is one bookmark. When I open the .Html file and click this, the webpage opens on Sydney Ferries. 

Thanks for your reply.

Modified by Rusho

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

It's actually easier to open the exported file in a text editor to check for this. To see what cor-el is talking about check out the screen shots attached to this post: https://support.mozilla.org/en-US/questions/932927?page=2#answer-357415

Question owner

Thanks jscher2000, but when I open my Safari Bookmarks.html using TextEdit.app, it only appears as per the following screen shot: (no code, only plain english text)

Bookmarks Bookmarks Bar

Travel Insurance, Cheap Australian Travel Insurance Online

So don't really know what to do? Perhaps there is no answer to this?

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Sounds that you are in text render mode.

Did you switch to reading the HTML source code?

You can also try to open the HTML file in a Firefox tab and use inspect the page source via "View Page Source":

  • Tools > Web Developer > Page Source (Mac: Command + U)
  • right-click on a web page to open the context menu and select View Page Source
jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Chosen Solution

I'm not familiar with TextEdit.app but I did a little searching...

I think you have 3 options:

(1) Switch how TextEdit opens .html files from showing them as web pages to showing the HTML source. This article describes how: Turn TextEdit Into an HTML Source Viewer with a Simple Settings Change.

(2) If you don't want to make the change in #1, open the file from inside TextEdit using File > Open and check the box to "Ignore rich text commands".

(3) Alternately, add .txt at the end of the file name. When you open the file, TextEdit should not try to display it as a webpage. After editing, you'll need to change the file extension back to .html for Firefox to be able to find it for importing.

Do any of those work for you?

Question owner

A Huge Thanks to Cor-el and jscher2000. I opened the file as an html file in textedit and deleted the H3 folded lines. My bookmarks have now been successfully imported to Firefox. Now I just need to know how to sort them!!

You two are the best and Firefox should pay you to solve their probs.

Cheers.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

The built-in sorting option (just alphabetical, basically) is described in this article: Sort your bookmarks to quickly find the ones you want.

For more sophisticated sorting operations, there was an extension named SortPlaces. It is no longer available on the official download site or on the author's site, but can be found here and there on the web. There are some links in this post: https://support.mozilla.org/en-US/questions/933835#answer-357356

Question owner

Thanks again - you are supercool !!