X
Tap here to go to the mobile version of the site.

Support Forum

Adobe Reader XI PlugIn not working after reinstalling Firefox 20 and Reader. I have followed suggested answers in the support pages. What's next?

Posted

Opening PDF's outside of the browser is not an option for me. I specifically need the Adobe Reader plug-in to function, allowing me to open (and more importantly) edit PDF's in Firefox for a reason. Whenever I download/open in Reader, I am unable to save my changes or data entered into form fields. Typically I open the PDF on the website I use for work (Form Simplicity) and edit the form fields there, save it on the site, and then email it from the site for eSignatures. If I can't save the information put into the PDF then it defeats the whole purpose of trying to keep the process electronic, rather than on paper. Please help me find a solution. I have uninstalled ALL BROWSERS, Adobe Reader, Flash, run the Adobe Creative Suite Cleanup tool just in case I had left-overs from a CS5 trial, and reinstalled everything from scratch. Problem still remains. Is it simply the fact that I'm using a Mac?

Opening PDF's outside of the browser is not an option for me. I specifically need the Adobe Reader plug-in to function, allowing me to open (and more importantly) edit PDF's in Firefox for a reason. Whenever I download/open in Reader, I am unable to save my changes or data entered into form fields. Typically I open the PDF on the website I use for work (Form Simplicity) and edit the form fields there, save it on the site, and then email it from the site for eSignatures. If I can't save the information put into the PDF then it defeats the whole purpose of trying to keep the process electronic, rather than on paper. Please help me find a solution. I have uninstalled ALL BROWSERS, Adobe Reader, Flash, run the Adobe Creative Suite Cleanup tool just in case I had left-overs from a CS5 trial, and reinstalled everything from scratch. Problem still remains. Is it simply the fact that I'm using a Mac?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Picasa plugin.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.02
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Unity Web Player version 4.0.1f2. (c) 2012 Unity Technologies ApS. All rights reserved.
  • Garmin Communicator Plug-in Version 4.0.3.0
  • 5.1.10411.0
  • iPhoto6

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/Darwin/en-US/

Extensions

  • Google Shortcuts 2.1.7.1 ({5C46D283-ABDE-4dce-B83C-08881401921C})
  • Google Voice 5.2 (gvoice@elijahclark.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • NO Google Analytics 0.5 (jid1-JcGokIiQyjoBAQ@jetpack) (Inactive)
  • PDF Viewer 0.8.1 (uriloader@pdf.js) (Inactive)
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 863
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • browser.tabs.autoHide: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.external.aliph: True
  • network.protocol-handler.warn-external.aliph: False
  • places.database.lastMaintenance: 1366899136
  • places.history.expiration.transient_current_max_pages: 100664
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

Helpful Reply

hello, firefox 19 has introduced its own integrated pdf viewer - if you want to switch back to the plugin you've used before to view pdfs just go to firefox > options > applications & scroll down and define the default action for the portable document format (pdf).

How to disable the built-in PDF viewer and use another viewer

hello, firefox 19 has introduced its own integrated pdf viewer - if you want to switch back to the plugin you've used before to view pdfs just go to firefox > options > applications & scroll down and define the default action for the '''portable document format (pdf)'''. [[How to disable the built-in PDF viewer and use another viewer]]

Question owner

I have already done this and selected "Use Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox). When I attempt to open a PDF to edit inside of Firefox, I get this message: Adobe Reader cannot show documents in this browser. We are sorry, but Adobe Reader is unable to show documents in this browser configuration.

Please use your browser to download this file and open it in Adobe Reader or Adobe Acrobat.

To avoid this message in the future, many browsers provide a way to turn off certain add-ons, and some are able to show this document natively. Please contact your browser vendor for more details.

If I click “Ok” it then renders a blank page equal the total length of what the actual PDF would be. I have selected ever other plug-in without satisfactory results and am wondering why I can’t find the “Use Adobe Reader (in Firefox)” plug-in that I seem to remember being there before. Is it possible to just download/install that plug-in. I have also already tried:

https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them#w_if-pdf-files-are-downloaded-instead-of-displayed-try-these-solutions

http://www.schubert-it.com/pluginpdf/

https://support.mozilla.org/en-US/kb/use-adobe-reader-plugin-view-or-download-pdf-files

What's next?

I have already done this and selected "Use Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox). When I attempt to open a PDF to edit inside of Firefox, I get this message: Adobe Reader cannot show documents in this browser. We are sorry, but Adobe Reader is unable to show documents in this browser configuration. Please use your browser to download this file and open it in Adobe Reader or Adobe Acrobat. To avoid this message in the future, many browsers provide a way to turn off certain add-ons, and some are able to show this document natively. Please contact your browser vendor for more details. If I click “Ok” it then renders a blank page equal the total length of what the actual PDF would be. I have selected ever other plug-in without satisfactory results and am wondering why I can’t find the “Use Adobe Reader (in Firefox)” plug-in that I seem to remember being there before. Is it possible to just download/install that plug-in. I have also already tried: [https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them#w_if-pdf-files-are-downloaded-instead-of-displayed-try-these-solutions https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them#w_if-pdf-files-are-downloaded-instead-of-displayed-try-these-solutions] [http://www.schubert-it.com/pluginpdf/ http://www.schubert-it.com/pluginpdf/] [https://support.mozilla.org/en-US/kb/use-adobe-reader-plugin-view-or-download-pdf-files https://support.mozilla.org/en-US/kb/use-adobe-reader-plugin-view-or-download-pdf-files] What's next?

Modified by condition1ftw

philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

also see PDF files are blank or cause an error message on Mac - adobe's plugin a apparently doesn't work in 64bit browsers. other users have reported that it would work when you start it in 32-bit mode...

also see [[PDF files are blank and can't be downloaded on Mac]] - adobe's plugin a apparently doesn't work in 64bit browsers. other users [https://support.mozilla.org/en-US/questions/925055 have reported] that it would work when you start it in 32-bit mode...

Question owner

Thank you philipp, I think this is going in the right direction. The only issue now is that the "Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox)" Plug-in is no longer an option. Do you know which version of Adobe Reader is compatible with 32-bit Firefox? Hopefully I won't have to go back version by version using the trial and error method :(

Thank you philipp, I think this is going in the right direction. The only issue now is that the "Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox)" Plug-in is no longer an option. Do you know which version of Adobe Reader is compatible with 32-bit Firefox? Hopefully I won't have to go back version by version using the trial and error method :(

Modified by condition1ftw

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159076 answers

Helpful Reply

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default.

You can set the pdfjs.disabled pref to true on the <b>about:config</b> page to disable the build-in PDF viewer. You can check the value of the <b>plugin.disable_full_page_plugin_for_types</b> pref on the <b>about:config</b> page and remove the application/pdf part if present or reset the pref to the default. *http://kb.mozillazine.org/about:config
bononista 0 solutions 19 answers

for PDF files in Firefox -> Preferences I do not have the option under "Action" to select Adobe Acrobat NPAPI Plug-in, Version 11.0.02 and I don't know why because for other Adobe data and formats the option to use Adobe Acrobat NPAPI Plug-in, Version 11.0.02 is available. For "Portable Document Format (PDF) I only have the options to select are "Use PDF Browser Plugin 2.4.4" or "Use Adobe Acrobat Reader (default)". I don't know how to locate the NPAPI plugin to force it to appear on the list under "Action". Conversely, for the other three Adobe formats NPAPI is on the list and Plugin 2.4.4. is not. Bizarre! I'm new to the MAC OS so I don't know how to go deep into configuring anything complex especially since the UI hides the detailed file lists. So essentially, when I select a PDF within Firefox the 2.4.4. plug in opens in an new tab with "PDF Download by Nitro". I even tried to tell that plugin to use NPAPI but it isn't working (within it I set the preference and it isn't working).

Safari, of course, does exactly what it should with PDFs.

I also don't know how to uninstall all the apps or plugins or extensions, I only know how to disable or update them. So if I wanted to remove them all and start from scratch with just the Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox) I don't know how to do that.

Please don't make me go to the Mac Store, LOL :wink:

Christine Gilroy, CA

for PDF files in Firefox -> Preferences I do not have the option under "Action" to select Adobe Acrobat NPAPI Plug-in, Version 11.0.02 and I don't know why because for other Adobe data and formats the option to use Adobe Acrobat NPAPI Plug-in, Version 11.0.02 is available. For "Portable Document Format (PDF) I only have the options to select are "Use PDF Browser Plugin 2.4.4" or "Use Adobe Acrobat Reader (default)". I don't know how to locate the NPAPI plugin to force it to appear on the list under "Action". Conversely, for the other three Adobe formats NPAPI is on the list and Plugin 2.4.4. is not. Bizarre! I'm new to the MAC OS so I don't know how to go deep into configuring anything complex especially since the UI hides the detailed file lists. So essentially, when I select a PDF within Firefox the 2.4.4. plug in opens in an new tab with "PDF Download by Nitro". I even tried to tell that plugin to use NPAPI but it isn't working (within it I set the preference and it isn't working). Safari, of course, does exactly what it should with PDFs. I also don't know how to uninstall all the apps or plugins or extensions, I only know how to disable or update them. So if I wanted to remove them all and start from scratch with just the Adobe Acrobat NPAPI Plug-in, Version 11.0.02 (in Firefox) I don't know how to do that. Please don't make me go to the Mac Store, LOL :wink: Christine Gilroy, CA
bononista 0 solutions 19 answers

I did this: "You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default. "

I found it and I think it worked -- I'm so happy :D

I did this: "You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default. " I found it and I think it worked -- I'm so happy :D
bononista 0 solutions 19 answers

NoooOOOoooo, It shows the plug in but it's still launching the Nitro app!

How do get rid of pdfdownload powered by vuzit/NitroPDF?

NoooOOOoooo, It shows the plug in but it's still launching the Nitro app! How do get rid of pdfdownload powered by vuzit/NitroPDF?
bononista 0 solutions 19 answers

I tried this:

Manually uninstalling a plugin

If you can't use an uninstaller program to remove a plugin, you can remove it manually:

   In the Location bar, type about:config and press Return.
       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. 
   Search for the preference: plugin.expose_full_path.
   Double-click on the plugin.expose_full_path preference in the list to change the value to true.

'''''' Enter about:plugins into the Location bar to display the About Plugins page.

   Each entry in the About Plugins page will have "File name:" followed by a path. Navigate to the folder shown for the plugin you want to remove.
   Rename the file to something other than its normal name - e.g. npswf32 becomes Xnpswf32'''''''''''

   Double-click on the plugin.expose_full_path preference in the list on the about:config page to change the value back to false to avoid exposing the plugin path to websites. 

The plugin will be removed.


I can't select the file name to change it. It's just a list.

I tried this: Manually uninstalling a plugin If you can't use an uninstaller program to remove a plugin, you can remove it manually: In the Location bar, type about:config and press Return. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. Search for the preference: plugin.expose_full_path. Double-click on the plugin.expose_full_path preference in the list to change the value to true. ''''''''''' '''''Enter about:plugins into the Location bar to display the About Plugins page. Each entry in the About Plugins page will have "File name:" followed by a path. Navigate to the folder shown for the plugin you want to remove. Rename the file to something other than its normal name - e.g. npswf32 becomes Xnpswf32'''''''''''''''' Double-click on the plugin.expose_full_path preference in the list on the about:config page to change the value back to false to avoid exposing the plugin path to websites. The plugin will be removed. I can't select the file name to change it. It's just a list.
bononista 0 solutions 19 answers

Manually uninstalling fixed this problem. My apologies for not posting sooner.

Manually uninstalling fixed this problem. My apologies for not posting sooner.