X
Tap here to go to the mobile version of the site.

Support Forum

force download wmv

Posted

I use firefox, because I want to control the browser, not be controlled by it, but firefox falls short, in downloading media files. I want to be able to control how media files are downloaded or processed, I know there is an Option->Applications screen, but many media types do not show up here at all, for instance mp4, mkv, wmv, avi. I want all of these types automatically downloaded, never to be asked or to automatically playback, as that is useless. I've spent days on Google and looking for plugins that allow me to add or modify Applications so that I may control these types. For instance right now mkv, and mp4 download always. AVi always asks and wmv automatically plays in the default media player (useless), but none of them are on the Applications list so I can control them (not the do this always checkbox normally does nothing), as a result I have to use a VM just to down WMV files, since it asks every time. Simply put firefox is not putting me in control, since I can not add new types to the applications menu, or control types that are not in the Applications menu once an action is automatically selected.

Any suggestions?

Thanks, ERIC

I use firefox, because I want to control the browser, not be controlled by it, but firefox falls short, in downloading media files. I want to be able to control how media files are downloaded or processed, I know there is an Option->Applications screen, but many media types do not show up here at all, for instance mp4, mkv, wmv, avi. I want all of these types automatically downloaded, never to be asked or to automatically playback, as that is useless. I've spent days on Google and looking for plugins that allow me to add or modify Applications so that I may control these types. For instance right now mkv, and mp4 download always. AVi always asks and wmv automatically plays in the default media player (useless), but none of them are on the Applications list so I can control them (not the do this always checkbox normally does nothing), as a result I have to use a VM just to down WMV files, since it asks every time. Simply put firefox is not putting me in control, since I can not add new types to the applications menu, or control types that are not in the Applications menu once an action is automatically selected. Any suggestions? Thanks, ERIC

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • 5.1.20125.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • Plugin for Wacom tablets.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

Gingerbread Man 402 solutions 1537 answers

egandt wrote:

Option->Applications screen, but many media types do not show up here at all, for instance mp4, mkv, wmv, avi.

SHORT ANSWER
To add a new file type, see the following article:

Usually, in order for this to work, the server must send the correct MIME type. The following example links send the correct MIME type, and should therefore create a new entry under Applications after you click them, select a download action and check the "Do this automatically..." option.


LONG ANSWER
Adding a new file type may fail to work if the server is sending an incorrect or generic MIME type. For example, that's the case for the following link (the WMV file downloaded on the next page after clicking the Download button).

The above server is telling Firefox the MIME type is application/octet-stream. In order for Firefox to treat the file like a Windows Media Video file, the MIME type sent should be video/x-ms-wmv. For an explanation, see the following article:

To work around this issue, you can use the Force Content-Type add-on.

Force Content-Type is intended for advanced users, who are familiar with regular expressions and MIME types. If I'm not mistaken, the following rules would be appropriate for the file types you mentioned (I've only tested with the aforementioned problematic WMV link).

  • URL: (.avi)$ Old Content-Type: application/octet-stream New Content-Type: video/x-msvideo
  • URL: (.mp4)$ Old Content-Type: application/octet-stream New Content-Type: video/mp4
  • URL: (.mkv)$ Old Content-Type: application/octet-stream New Content-Type: video/x-matroska
  • URL: (.wmv)$ Old Content-Type: application/octet-stream New Content-Type: video/x-ms-wmv

Additionally, some servers force the display of the download window by sending the Content-Disposition: attachment header. In this case, the "Do this automatically for files like this from now on" option in the download window is grayed out (in older Firefox versions, it was available, but checking it had no effect).
To work around this issue, you can use the InlineDisposition add-on. Note that due to bug 835381, this add-on may cause Firefox to mistakingly attempt to play MKV files inside the browser window. The bug is supposedly fixed in the upcoming Firefox 22, which is slated for release around June 28th. At least one user has reported the same issue with MP4 files, but I haven't tested that scenario myself.

''egandt wrote:'' Option->Applications screen, but many media types do not show up here at all, for instance mp4, mkv, wmv, avi. '''SHORT ANSWER'''<br> To add a new file type, see the following article: * [[Change what Firefox does when you click on or download a file]] Usually, in order for this to work, the server must send the correct MIME type. The following example links send the correct MIME type, and should therefore create a new entry under Applications after you click them, select a download action and check the "Do this automatically..." option. * [http://www.engr.colostate.edu/me/facil/dynamics/files/drop.avi AVI] • [http://switch.dl.sourceforge.net/project/matroska/test_files/cover_art.mkv MKV] • [http://podcasts.london.edu/ioannis_heather_v6.mp4 MP4] • [http://robots.stanford.edu/talks/stanley/APGNov2004short_1.WMV WMV] '''LONG ANSWER'''<br> Adding a new file type may fail to work if the server is sending an incorrect or generic MIME type. For example, that's the case for the following link (the WMV file downloaded on the next page after clicking the Download button). * http://www.microsoft.com/en-us/download/details.aspx?id=7981 The above server is telling Firefox the MIME type is ''application/octet-stream''. In order for Firefox to treat the file like a Windows Media Video file, the MIME type sent should be ''video/x-ms-wmv''. For an explanation, see the following article: * [https://developer.mozilla.org/en-US/docs/Properly_Configuring_Server_MIME_Types#What_are_MIME_types.3F What are MIME types? | Mozilla Developer Network] To work around this issue, you can use the Force Content-Type add-on. * https://addons.mozilla.org/firefox/addon/force-content-type/ Force Content-Type is intended for advanced users, who are familiar with regular expressions and MIME types. If I'm not mistaken, the following rules would be appropriate for the file types you mentioned (I've only tested with the aforementioned problematic WMV link). * URL: '''(.avi)$''' Old Content-Type: '''application/octet-stream''' New Content-Type: '''video/x-msvideo''' * URL: '''(.mp4)$''' Old Content-Type: '''application/octet-stream''' New Content-Type: '''video/mp4''' * URL: '''(.mkv)$''' Old Content-Type: '''application/octet-stream''' New Content-Type: '''video/x-matroska''' * URL: '''(.wmv)$''' Old Content-Type: '''application/octet-stream''' New Content-Type: '''video/x-ms-wmv''' ---- Additionally, some servers force the display of the download window by sending the ''Content-Disposition: attachment'' header. In this case, the "Do this automatically for files like this from now on" option in the download window is grayed out (in older Firefox versions, it was available, but checking it had no effect).<br> To work around this issue, you can use the InlineDisposition add-on. Note that due to bug 835381, this add-on may cause Firefox to mistakingly attempt to play MKV files inside the browser window. The bug is supposedly fixed in the upcoming Firefox 22, which is slated for release around June 28th. At least one user has reported the same issue with MP4 files, but I haven't tested that scenario myself. * https://addons.mozilla.org/firefox/addon/inlinedisposition/