X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Black boxes

Posted

How do you disable the Default Theme on Firefox besides putting it in Safe Mode? It is actually causing the problem, as Hardware Acceleration, drivers, and Add-ons are not.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3)

More Information

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Could you describe the problem of "black boxes" in a little more details? are you saying that the icons are rendering as black boxes instead of normal icons?

Is this new after a recent version upgrade of Firefox?

You can switch your theme from the default to a different one by downloading something new from the Add-ons site. Firefox supports both full themes that have their own icons, and lightweight themes (also called personas) that simply change the background.

However, whatever is afflicting your Firefox might also affect a new theme, so it's probably worth chasing that a bit further... it really does sound like display artifacts associated with a graphics driver incompatibility. If the regular hardware acceleration checkbox --

orange Firefox button (or Tools menu) > Options > Advanced> "General" mini-tab > uncheck "Use hardware acceleration when available"

-- doesn't affect the toolbar area, hopefully another volunteer is familiar with a setting that does.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

personaboveisworthless 0 solutions 2 answers

It's like as much as I have a feeling you have no idea what the hell this is. I have to use this nick. Sorry, pal. It's sure as hell not hardware acceleration, Chrome displays pictures fine.

personaboveisworthless 0 solutions 2 answers

Sorry for my abrasive nature.

Another thread, no reply, of course. Post with bug second to last. I think we should refer to this as the "ugly rectangle" bug. It withstands multiple uninstallations/reinstallations so I assume it might be a hardware thing. No, it is not hardware acceleration.

It's one step above the no-stylesheet, since it gets rid of most gradient backgrounds I see

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

You may have switched on caret browsing.

You can press F7 (Mac: fn + F7) to toggle caret browsing on/off.

  • Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"
jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi personaboveisworthless, it's hard to distinguish between what you deliberately changed and what you don't like.

  • What kind of Windows theme are you using (e.g., Aero, Basic, High Contrast)?
  • In your first screen shot, the black mark appears to correspond not to an image but to a generated box with a narrow border that is used to make the post appear like a call-out (see attached screen shot). As far as I can tell, the associated CSS is:

    .answers .main-content:before {border-color:transparent #fff; border-style:solid; border-width:11px 11px 11px 0; height:0; content:''; left:-11px; position:absolute; top:20px; width:0}
  • Where is the problem in the Yahoo! screen shot?
cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

oracleyue 0 solutions 5 answers

I'd like to clarify more. Based on my testing, it might be caused by vimperator. Once disable vimperator, such small black boxes disappear. If enable vimperator, as long as not using mouse to scroll the page or scroll slowly, they do not appear. Using keyborad to scroll, like C-u,d,f,b or j,k, such small boxes do not appear. Maybe it is a problem related to vimperator. If disable the "using smooth scrolling", it turns to be better when using mouse.

FYI, my laptop: Archlinux + KDE + firefox 24.0

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

Hi oracleyue

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

oracleyue 0 solutions 5 answers

Don't mind the red boxes, which I used to cover sensitive infomation (like names). Please pay attentions to the small black boxes, which appear randomly. Moreover, they appear in the page with flash or pictures. If the webpage only contains texts, they never appear. I used phone to photo it. Once I use prtsc, the window will be redraw and these boxes will disappear.

They have been much less when I upgrade to 24.0. In the previous vision, there are many black boxes in certain pages.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi oracleyue, Vimperator can add a variety of little annotations on the screen. I don't know whether those small boxes represent broken annotations or random glitches. If the problem only occurs with the extension enabled, you might refer the problem to the developer for consideration.

oracleyue 0 solutions 5 answers

I found a more respesentative example to show this bug - google calendar. There are many black boxes appearing when scrolling fast using mouse, even though I have disabled "vimperator" (it shows that my previous guess is wrong), shown in the attached figure. However, they all automatically disappear in around 1~2 seconds.

FYI: Thinkpad X230 + Archlinux + kde + firefox 24.0.

oracleyue 0 solutions 5 answers

Nevermind, I don't think it's a big issue. I just help to clarify this bug. It might relate to graphics driver or something. Maybe it is due to oxygen-gtk software, which I have to use to make firefox to be kde-like. I guess so, since this bug relates to the frequency of window refreshment. I may test it later with oxygen-gtk uninstalled.

Modified by oracleyue

econ_arch 0 solutions 1 answers

Helpful Reply

I had the same black boxes oracleyue showed in his screenshot.

I'm using Arch Linux, and solved the issue by switching from SNA to UXA as described in the Arch wiki.

The source appears to be a bug in the intel video driver.

Modified by econ_arch

oracleyue 0 solutions 5 answers

econ_arch, thank you very much! Your answer is quite helpful!