X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop the notification pop-up that 'Only secure content is displayed' that comes up nearly every time when I move to a new web page?

Posted

This notification pop-up appears almost every time I navigate to a new page which is really annoying when I am trying to study my university subjects online.

This notification pop-up appears almost every time I navigate to a new page which is really annoying when I am trying to study my university subjects online.

Chosen solution

Thanks all I went to : orange Firefox button (or Tools menu) > Add-ons > Plug-in category

and found a warning that the Adobe Acrobat Plug-In 8.0.0.456 was known to be vulnerable and should be updated

after I disabled this plug in I haven't had the problem anymore.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • GEPlugin
  • Google Update
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • McAfee MSS+ NPAPI Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

iamjayakumars 493 solutions 5983 answers

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/faq/?qid=208283363 TDSSKiller - AntiRootkit Utility] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!
jscher2000
  • Top 10 Contributor
8959 solutions 73404 answers

Helpful Reply

Firefox used to have a warning somewhat like that, but now a mix of secure and insecure content is indicated by a "globe" icon instead of a padlock icon next to the URL. The insecure content is not actually blocked.

Edit: Apparently now you can block the insecure content by making a change in about:config. See cor-el's reply below.

It is possible you have an extension that blocks insecure content and displays that message? You could check the following tab, and use the Options button to see whether you can change the behavior:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Firefox used to have a warning somewhat like that, but now a mix of secure and insecure content is indicated by a "globe" icon instead of a padlock icon next to the URL. The insecure content is not actually blocked. ''Edit: Apparently now you can block the insecure content by making a change in about:config. See cor-el's reply below.'' It is possible you have an extension that blocks insecure content and displays that message? You could check the following tab, and use the Options button to see whether you can change the behavior: orange Firefox button (or Tools menu) > Add-ons > Extensions category

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17865 solutions 161655 answers

You can check the security.mixed_content.* prefs on the about:config page

  • security.mixed_content.block_active_content
  • security.mixed_content.block_display_content

You can check the security.mixed_content.* prefs on the <b>about:config</b> page *security.mixed_content.block_active_content *security.mixed_content.block_display_content *http://kb.mozillazine.org/about:config ---- *https://developer.mozilla.org/en/Security/MixedContent

Chosen Solution

Thanks all I went to : orange Firefox button (or Tools menu) > Add-ons > Plug-in category

and found a warning that the Adobe Acrobat Plug-In 8.0.0.456 was known to be vulnerable and should be updated

after I disabled this plug in I haven't had the problem anymore.

Thanks all I went to : orange Firefox button (or Tools menu) > Add-ons > Plug-in category and found a warning that the Adobe Acrobat Plug-In 8.0.0.456 was known to be vulnerable and should be updated after I disabled this plug in I haven't had the problem anymore.
crosetti 0 solutions 1 answers

Thanks a LOT, I installed "MalwareBytes' Anti-Malware" and it has LOADS of Malware IN IT!

I now have MORE of a malware problem then I did BEFORE I installed it!

Grrrrr!

Thanks a LOT, I installed "MalwareBytes' Anti-Malware" and it has LOADS of Malware IN IT! I now have MORE of a malware problem then I did BEFORE I installed it! Grrrrr!
jscher2000
  • Top 10 Contributor
8959 solutions 73404 answers

Hi crosetti, did you have a problem with the download from the above link posted by iamjayakumars? That site is the publisher and should be the cleanest available version of the software. Beware of imitators with similar names.

Hi crosetti, did you have a problem with the download from the above link posted by iamjayakumars? That site is the publisher and should be the cleanest available version of the software. Beware of imitators with similar names.