Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove the "Restore Session" page that comes up every time I open Firefox, Even by quitting it properly?

  • 15 replies
  • 19 have this problem
  • 5988 views
  • Last reply by Dyvik Chenna

more options

Ever since I upgraded to v20 of Firefox a problem has occurred where I will close Firefox properly (close browser and then quit application as I am on a Mac) but when I open it again I will get a message. This message is "Oh this is embarrassing..." and try to get me to reopen my tabs I had before. This will also happen if I have just one tab open and then close it. I was wondering if there is a way to fix it!

Chosen solution

hello epifight, this is currently a problem in firefox when you first close all open firefox windows and then close the application afterwards - the bug should be addressed in a later version of firefox.

as a workaround in the meanwhile you could close firefox (through firefox > quit) while the browser window is still running or try this: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

Read this answer in context 👍 9

All Replies (15)

more options

Chosen Solution

hello epifight, this is currently a problem in firefox when you first close all open firefox windows and then close the application afterwards - the bug should be addressed in a later version of firefox.

as a workaround in the meanwhile you could close firefox (through firefox > quit) while the browser window is still running or try this: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

more options

Awesome! I just thought it was me because I couldn't find any other questions along these lines. Thanks again for the help and quick response.

more options

You should quit Firefox properly. There may be occasions when Firefox freezes or crashes, and in that case you have no choice, but if you have a choice, exit properly.

Maybe the sessionstore file is corrupted? Move it somewhere else and set up a new session. See if that gets restored as it should.

Modified by finitarry

more options

No, this is a bug that is getting fixed for Firefox 23 on Mac and will likely be back ported to the Aurora and Beta version, so you will have to wait until Firefox 21 is released.

  • Bug 845681 - Closing all windows and quitting Firefox afterwards leads to about:sessionrestore to be shown on next startup

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

more options

Having MR Tech Toolkit installed and having it set to close child windows (and therefore the underlying process) when I close the main window means that I will not have that problem.

more options

In the workaround quoted below, I'm unclear as to where to find this "Firefox location bar". I'm not uninitiated into doing the kind of thing suggested, just don't know where to find the place to begin. I'm pretty sure it's not the URL address bar, or the Google search bar, or my Mac's spotlight bar, but then what/where is it. Thanks for your help..... Susiqw

as a workaround in the meanwhile you could close firefox (through firefox > quit) while the browser window is still running or try this: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named browser.sessionstore.resume_from_crash. double-click it and change its value to false.

more options

The location bar is the address bar in a normal browser window. In a popup window, there can be a location bar which is not an address bar because one cannot navigate a popup window, but one can still tell where it comes from.

more options

Your story is fun and it looks like an entertaining game, I really liked this and I want to learn more about it as a real lesson so I can send my loved ones so that they as I know, thanks for sharing this interesting and I will always follow and pay attention to the content you post in the future.

[link(s) removed by Moderator]

Modified by cor-el

more options

Ok that's what I thought, but unfortunately it comes up as a blank page which says: Firefox can't find the server at browser.sessionstore.resume_from_crash.

when this happened the first time that's why i wrote that I ws confused about which is the location bar.....

But now?

more options

Hi susiqw, it's hard to see when the text is all written as a single sentence, but the steps are:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click browser.sessionstore.resume_from_crash to toggle its value from true to false.

more options

You need to open the about:config if you want to inspect or modify prefs.

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean
more options

Thanks to you both, jscher2000 and cor-el, for your clear explanation. I was able to toggle it to the other position, that is, False. Then I closed that tab. I hope that was right...... now we shall see!

more options

I am facing this problem since I updated Firefox from version 21 to version 24. A similar issue is reported here: Firefox 24.0 and Integrated restore sessions of TMP

I don't see changing the value of browser.sessionstore.resume_from_crash as a real solution, since if Firefox does crash while I am browsing I would want to recover the session.

Modified by rossi9

more options

Hi rossi9, the recommendations in this thread were an emergency workaround for users of Firefox 20 on MacOS X, since it did not shut down properly under some circumstances. You probably do want to find a different solution.

The thread about Tab Mix Plus mentions a bug when you Exit Firefox with nothing but a blank tab open. Can you work around this by closing all the real pages as a temporary workaround? Edit: That wasn't clear, I meant exiting with at least one real page open.

Or could you be more specific about what you're seeing?

Note: The thread on TMP also mentioned getting a home page AND previous session windows and tab. This could happen if the home page URL redirects. For example, if you have a home page on Google with an http URL but Google automatically redirects to an https URL, Firefox will not automatically close that tab when restoring your session. The solution is to update your home page URL to the final destination. For example: I wonder if it is possible that you open the tab where it was during the closing session after restoring a session.

Modified by jscher2000

more options

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click browser.sessionstore.resume_from_crash to toggle its value from true to false. thank you.