Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Update to 20.0.1 Zoom problem

  • 11 replies
  • 12 have this problem
  • 1606 views
  • Last reply by ge32

more options

My Firefox just updated itself. Now Google search results are too small to read. Not possible to zoom in. The page flashes up correct size but then squeezes to a size a fraction of the screen and unreadable. Chrome ok so using that for the moment. How do I revert to previous version, which worked!?

Chosen solution

SOLUTION: install the "Always Zoom" add-on from https://addons.mozilla.org/en-US/android/addon/always-zoom/

Part of the problem is the search results page not allowing zooming. Why browsers prevent zooming is beyond me - on a small screen device zooming is a fundamental requirement, but for some reason they let page writers disable it. The person who came up with the idea of zoom-blocking is a right prat.

Anyhow, I installed the Always Zoom add-on thinking it would allow me to work around the zoomed-out results pages by zooming in, but with it installed the pages are never zoomed out anyway! It's probably the results page having a silly zoom level defined and the add-on prevents it from being obeyed.

Read this answer in context 👍 1

All Replies (11)

more options

I should add, this is on my Samsung Tab GT-P3100 running Android 4.0.4.

more options

Hi johnash:

Just tried google searches on my 10" Nexus 10 tablet running Android 4.2 with Firefox 20.0.1 and it works fine so it's not a general 10" tablet problem.

Could you please post a screenshot?

Thanks!

...Roland

more options

My Tablet is a 7". And you've made me learn how to take a screenshot. So here it is!

more options

hi johnash

i glad you learned something new :-)  !

My apologies for mis-reading the specs, your tablet is 7", you are right!

i tried google searching on my nexus 7 7" tablet running Android 4.2 and it works fine.

Hmmm. I will now search for a bug report on this.

Modified by Roland Tanglao

more options

When you go to the Google main page do you see the Tablet | Classic option?

Do you have the Phony extension installed? If you do make sure it is enabled in the extension window (about:addons in the address bar). Then make sure it is set to 'Default'.

more options

Hi!

No, I don't see Tablet | Classic Option

I don't have Phony. The only addons are searches for Amazon, Ebay and Wikipedia. If I disable these, I get the same result.

This was working perfectly before the latest Firefox update. It would be a shame if I had to switch permanently to Chrome.

Can I ask another question? Firefox Android keeps opening new tabs. I don't need new tabs all the time. Indeed, ever. Can I switch this off? I want it to perform like my PC Firefox and only open a new tab when I tell it to. I don't like my machines doing what THEY want to do instead of what I want them to do!!

more options

I too have this problem. I did have Phony installed, but have uninstalled it and the problem persists.

If I search from the address bar the Google results page is ok. If I search from Android's search on the homescreen and select Firefox to view the results then it is broken. The problem appears to be the URL used for the results.

From the Android search, which has the problem, the URL is: http://www.google.co.uk/search?hl=en-GB&redir_esc=&client=tablet-android-asus&source=android-launcher-search&v=141278776&qsubts=1365872082304&q=SEARCH_TEXT_HERE

From the address bar, to my custom configured search to Google's tablet interface, which does not have the problem, the URL is: https://www.google.com/search?q=SEARCH_TEXT_HERE&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official

I don't know if Firefox controls the URL or Android, but the update to 20.0.1 introduced this problem.

I'm running Android 4.0.3 on an Asus Transformer TF101 tablet.

more options

Chosen Solution

SOLUTION: install the "Always Zoom" add-on from https://addons.mozilla.org/en-US/android/addon/always-zoom/

Part of the problem is the search results page not allowing zooming. Why browsers prevent zooming is beyond me - on a small screen device zooming is a fundamental requirement, but for some reason they let page writers disable it. The person who came up with the idea of zoom-blocking is a right prat.

Anyhow, I installed the Always Zoom add-on thinking it would allow me to work around the zoomed-out results pages by zooming in, but with it installed the pages are never zoomed out anyway! It's probably the results page having a silly zoom level defined and the add-on prevents it from being obeyed.

more options

I have opened a bug for this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=861534

more options

Yes, installing Always Zoom has fixed this. Thank you.

more options

More info I found while investigating stuff for the bug I opened... I'm in the UK so my searches were going to google.co.uk, but google.com works ok. Other country-specific sites like google.de and google.fr also have the problem. I suspect this is Google's bug affecting their localised sites.

So an alternative fix is to change Android's search to use .com by opening the search box, selecting the "three dots" menu on the top right, then Settings > Google Search > Search on google.com