X
Tap here to go to the mobile version of the site.

Support Forum

Unable to connect to proxy due to automatic https

Posted

Hi there,

I am the network administrator for an Australian K-12 school. We are cross platform, and support both Mac & Windows environments, based of an Active Directory Infrastructure.

We have local proxy server based on ISA 2006, using McAfee SmartFilter as the local filtering solution.

The issue I am having has been occuring since Firefox 12 was released. A number of websites retrieved through firefox started using the HTTPS connection by default, for example google.com, youtube.com, twitter.com, or carrying out a search using the search bar.

For example - If i search cat in the search bar, Firefox will automatically refer the search through this url - https://www.google.com.au/search?q=cat&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-GB:official&client=firefox-a&channel=fflb.

With the majority of our Mac computers running Firefox 14 or later, this search is hampered and returns the message Proxy is refusing connection. To overcome this, I have trained staff and students to remove the 's' from http:// and to reattempt the connection. If it isn't a blocked term, ie porn, the proxy will ask for login details, and connect through.

In the case of a blocked website, such as YouTube, the same fix is applied to bring up the block page, which can allow the override. Further more, once the filtering is turn off. The issue doesn't rear again, until the filter cuts back in.

This also occurs, but less often with our Windows based computers running Firefox, as they support NTLM authentication straight through.

What makes it most curious, is that Safari versions 5 & 6, the current and many releases of Google Chrome, and Internet Explorer 7, 8 & 9 work flawlessly.

I'm looking for an option or a fix that will allow us to set a preference the HTTP over HTTPS for these website so that Firefox can at least work straight out, prior to the release of this feature, or adjust so that if the connection is refused/unable to connect by the proxy at, it will try by HTTP before failing to connect.

If there is anything else I can try, please let me know.

Hi there, I am the network administrator for an Australian K-12 school. We are cross platform, and support both Mac & Windows environments, based of an Active Directory Infrastructure. We have local proxy server based on ISA 2006, using McAfee SmartFilter as the local filtering solution. The issue I am having has been occuring since Firefox 12 was released. A number of websites retrieved through firefox started using the HTTPS connection by default, for example google.com, youtube.com, twitter.com, or carrying out a search using the search bar. For example - If i search cat in the search bar, Firefox will automatically refer the search through this url - https://www.google.com.au/search?q=cat&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-GB:official&client=firefox-a&channel=fflb. With the majority of our Mac computers running Firefox 14 or later, this search is hampered and returns the message Proxy is refusing connection. To overcome this, I have trained staff and students to remove the 's' from http:// and to reattempt the connection. If it isn't a blocked term, ie porn, the proxy will ask for login details, and connect through. In the case of a blocked website, such as YouTube, the same fix is applied to bring up the block page, which can allow the override. Further more, once the filtering is turn off. The issue doesn't rear again, until the filter cuts back in. This also occurs, but less often with our Windows based computers running Firefox, as they support NTLM authentication straight through. What makes it most curious, is that Safari versions 5 & 6, the current and many releases of Google Chrome, and Internet Explorer 7, 8 & 9 work flawlessly. I'm looking for an option or a fix that will allow us to set a preference the HTTP over HTTPS for these website so that Firefox can at least work straight out, prior to the release of this feature, or adjust so that if the connection is refused/unable to connect by the proxy at, it will try by HTTP before failing to connect. If there is anything else I can try, please let me know.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20125.0
  • Shockwave Flash 11.4 r402
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/WINNT/en-GB/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) Q35 Express Chipset Family (Microsoft Corporation - WDDM 1.0)
  • adapterDescription2:
  • adapterDeviceID: 0x29b2
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 3-22-2012
  • driverDate2:
  • driverVersion: 8.15.10.2697
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) Q35 Express Chipset Family (Microsoft Corporation - WDDM 1.0))
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • font.internaluseonly.changed: True
  • network.automatic-ntlm-auth.allow-non-fqdn: True
  • network.automatic-ntlm-auth.trusted-uris: http://daymap/daymap
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364431346
  • places.history.expiration.transient_current_max_pages: 93515
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
7797 solutions 63475 answers

I can't speak for YouTube or Twitter, but for your search engines, you can edit some of those settings.

(1) Address bar search

You can edit the keyword.URL setting to use an http:// URL. This article describes how to access that setting, and the following thread has an alternate URL you can use for the searches:

(2) Search box

You can add a new search engine plugin that uses http instead of https. You can choose one from the Mycroft site, or I have posted one that I created last July by deleting the "s" from the URLs in the standard search plugin.

Does that work?

I can't speak for YouTube or Twitter, but for your search engines, you can edit some of those settings. (1) Address bar search You can edit the keyword.URL setting to use an http:// URL. This article describes how to access that setting, and the following thread has an alternate URL you can use for the searches: * [[Search the web from the Address Bar]] * [https://support.mozilla.org/en-US/questions/932804 How do I turn off the safe search feature new in Firefox 14?] (2) Search box You can add a new search engine plugin that uses http instead of https. You can choose one from the Mycroft site, or I have posted one that I created last July by deleting the "s" from the URLs in the standard search plugin. * Mycroft: http://mycroftproject.com/google-search-plugins.html * My site: http://dev.jeffersonscher.com/search/getplug.html Does that work?