X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How do I stop firefox from showing mobile content on my desktop

Posted

I was wondering if anyone could assist me with this problem. Firefox shows mobile content on my desktop (such as going to Yahoo Sports page) instead of desktop content on my desktop. I have tried clearing cookies and c ache, and that has not solved my problem. Thanks in advance!

I was wondering if anyone could assist me with this problem. Firefox shows mobile content on my desktop (such as going to Yahoo Sports page) instead of desktop content on my desktop. I have tried clearing cookies and c ache, and that has not solved my problem. Thanks in advance!

Chosen solution

You might need to manually reset a setting as described in this article: Websites say that Firefox is outdated or incompatible even though it's the latest version. Could you try that and test again?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20125.0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Amazon MP3 Downloader Plugin 1.0.17
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Skype Web Plugin
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Yahoo Application State Plugin version 1.0.0.7
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (masking-agent; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

jscher2000
  • Top 10 Contributor
8950 solutions 73359 answers

It's interesting: your browser reported itself to this board as follows:

User Agent: Mozilla/5.0 (masking-agent; rv:18.0) Gecko/20100101 Firefox/18.0

Where I usually see something like "Windows" instead I see "masking-agent." I suspect that websites do not know what to do with this information and you may get mixed results.

This is a feature of the Masking Agent extension. Unfortunately, it doesn't have the option to make exceptions for individual sites. But you could change the text from masking-agent to Windows and see whether that fixes it. To do that, go to

orange Firefox button (or Tools menu) > Add-ons > Extensions category

When you find Masking Agent, click the Options button and edit the text there. There's no save button, I think it saves as soon as you tab away from the textbox.

Any luck?

It's interesting: your browser reported itself to this board as follows: User Agent: Mozilla/5.0 (masking-agent; rv:18.0) Gecko/20100101 Firefox/18.0 Where I usually see something like "Windows" instead I see "masking-agent." I suspect that websites do not know what to do with this information and you may get mixed results. This is a feature of the [https://addons.mozilla.org/en-us/firefox/addon/masking-agent/ Masking Agent] extension. Unfortunately, it doesn't have the option to make exceptions for individual sites. But you could change the text from masking-agent to Windows and see whether that fixes it. To do that, go to orange Firefox button (or Tools menu) > Add-ons > Extensions category When you find Masking Agent, click the Options button and edit the text there. There's no save button, I think it saves as soon as you tab away from the textbox. Any luck?

Question owner

I tried changing the text from masking agent to just Windows. No change. I then completely removed the masking agent extension alltogether. Still, no change.

I tried changing the text from masking agent to just Windows. No change. I then completely removed the masking agent extension alltogether. Still, no change.
jscher2000
  • Top 10 Contributor
8950 solutions 73359 answers

Helpful Reply

Oh, Yahoo! might have stored its decision in a cookie, or in a cached file. You probably need to clear those again. You've done it before, but just for reference:

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

Oh, Yahoo! might have stored its decision in a cookie, or in a cached file. You probably need to clear those again. You've done it before, but just for reference: (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" Then try reloading the page. Does that help?

Question owner

Unfortunately not...

Unfortunately not...
jscher2000
  • Top 10 Contributor
8950 solutions 73359 answers

Could you view your browser description on the following page and let me know if you see anything unexpected?

http://dev.jeffersonscher.com/jstest.html

Could you view your browser description on the following page and let me know if you see anything unexpected? http://dev.jeffersonscher.com/jstest.html

Question owner

It still says there's a masking agent involved. I completely removed that.

It still says there's a masking agent involved. I completely removed that.
jscher2000
  • Top 10 Contributor
8950 solutions 73359 answers

Chosen Solution

You might need to manually reset a setting as described in this article: Websites say that Firefox is outdated or incompatible even though it's the latest version. Could you try that and test again?

You might need to manually reset a setting as described in this article: [[Websites say that Firefox is outdated or incompatible even though it's the latest version]]. Could you try that and test again?

Question owner

That did the trick! Thank you so much!

That did the trick! Thank you so much!