Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Linux Firefox used to automatically connect to my wifi router (192.168.1.1) ; now it tries to reach my homepage and I must manually connect to the router ?

  • 3 replies
  • 7 have this problem
  • 570 views
  • Last reply by volpial3

more options

I always relied on the automatic connection to the wifi router landing page. This is in practice not an issue when I am using my own portable router (MIFI 3352), since I can easily connect to the router just typing the IP address in the Firefox address bar. Nevertheless that might be a problem if I try to connect to a public wifi router, whose address might be different from the standard 192.168.1.1 .

I do not remember whether the behaviour of Firefox has changed after I have updated to the last version via "yum update", but I am almost sure that I did so recently ...

Very best regards.

Alessandro Volpi

P.S. I have installed the troubleshooter, but this is not relevant, since I am now working on my Desktop workstation with optical fibre Internet connection and not of my wifi connected portable. Also the portable has got version 19.0.2

All Replies (3)

more options

Hi volpial3,

this is not related to Firefox. I don't know which linux distribution you are using but you should be able to add, edit or remove network connections (and view their properties) using Network Settings (or Network Connections, or something like that depending on your distribution) from System Settings menu.
Hope that helped you!

more options

Thanks for your help, alco .

I was also suspecting that the issue might be related to the network connections, since, after the last kernel update I had to add a line with the name of the workstation in file /etc/hosts . The startx script did not work properly when wlan0 was active, since it looks for the workstation name on the network, in case it does not find it in /etc/hosts .

After adding the line in the mentioned file startx is working perfectly and without unneeded delays.

I nevertheless point out that nothing has been changed in the network configuration since a long time ...

If the issue is not related to Firefox it has therefore to be related to the latest kernel updates.

I will try to check the Firefox behaviour with the old kernel.

Best regards.

Alessandro Volpi

more options

I have now checked the Firefox behavior with the old kernel; nothing has changed. Nothing changes also with the newly installed 3.8.4-102.fc17.i686.