X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I set a website to the "permanantly add to exception" when the checkbox is greyed out?

Posted

I have to use a site called "Blackboard" for my college courses. Whenever I go to it, it gives me a security certificate pop up window. The site is secure but I keep having to add as an exception multiple times daily. The "permanently add to exceptions" box is greyed out so I can't check it. On the PC's at school, they are using the same version of Firefox that I am but the box is not greyed out, so it will let you check it. I am using the latest release.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20125.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

You can also check if that page is opened in an (i)frame.
In that case you should have a "This Frame" item in the right-click context menu and you can try to open that frame in a new tab.


Check out why the site is untrusted (see the Technical details) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

pieroland 0 solutions 2 answers

Same problem for me. I created a self-signed certificate on my personal home server (https://pieroland.linuxd.org/). When I try to add an exception to Firefox (I understand the Risks -> Add Exception...) the browser says (in the pop-up used to add the exception):

   Valid Certificate
   
   This site provides valid, verified identification. There is no need add an exception.

The "Confirm Security Exception" is greyed-out and I can't access my pages

I can reproduce the problem when running in safe mode, and I'm not using private browsing. It works fine in Chrome :-(

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Did you try to remove an existing installed certificate?

pieroland 0 solutions 2 answers

Yes I removed them, but didn't work.

By the way, it's Firefox 22.0 on OSX 10.6.8.