X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why can't the FireFox engineering team produce fixes for the problems for users who have Outlook.com as their email service?

Posted

If you work on an Apple Mac and use web access for Outlook.com as your email service, you cannot delete, move or rename an email folder in the new Outlook.com using the Firefox browser (FFv19). You should be able to right-click on an email folder to delete, rename and move a folder. However, in Firefox the pop-up box does not come up to be able to do these functions. In Internet Explorer you can right-click on a folder to delete, etc., but right-clicking on email Outlook folders using the Firefox (FFv19) browser does not work. Firefox and Microsoft's new Outlook.com are not playing nicely.

Does the software engineering team at Firefox give a damn? Apparently, this has been a problem for months and Firefox still has not come up with a fix.

Those of us who user Firefox and work on Apple MACs need fixes for the new Outlook.com. AND please DON'T ask me to change my email service provider because I have been using MSN (now Outlook.com) for 14 years. I'm NOT going to change my email service.

To the Firefox engineering team: Please produce/create a fix for the problem I've outlined for Outlook.com. I need to be able to delete, move and rename my email folders in Outlook using the Firefox browser.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.02
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

hello, please make sure that the disable or replace context menu setting is checked in firefox > preferences > content > enable javascript - advanced...

Settings for fonts, languages, pop-ups, images and JavaScript

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Have you done any troubleshooting to see if that issue is caused by an Add-on?

Try the Firefox SafeMode
http://support.mozilla.com/en-US/kb/Safe+Mode
Don't select anything right now, just use "Continue in SafeMode."

When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.

If not, see this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...


Beyond that, have you checked with Outlook support to see if or when they plan to fix that issue?

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8022 answers

Just a simple longshot, but there was a recent spike in problems of using Firefox with MSN and a Firefox User Advocacy, staff member, attributed that problem to a change in how cookies were handled by MSN.

 Apparently, this has been a problem for months and Firefox still has not come up with a fix. 

Not sure I have seen much evidence of that. It is possibly more likely to be a local problem with your machine. Investigating that is probably your best first course of action.

Question owner

Yes, I have deleted cookies and cleared my Firefox cache and the problem remains. Also, I have made sure that "Disable or replace context menus" is checked and that also did not help. I use FireFox version 19.0.2 maybe I need to downgrade my version of FireFox.

Question owner

I have made sure that "Disable or replace context menus" is checked and that did not help. Deleted cookies and cache and that also did not fix the problem. I use FireFox version 19.0.2. Perhaps I need to downgrade my version of FireFox. Could it be the version of FireFox that I am using?

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

please also try it in safemode once, as the-edmeister has explained above to rule out the influence of any addons.

Question owner

Thank you everyone for trying to help resolve the issue I am having with Outlook.com using Firefox. I've now tried all of the above including starting FireFox (FFv19.0.2) in safe mode which also did not resolve the problem. The folks in the Microsoft Community forums don't seem to have any answers either. If you use a browser other Internet Explorer, discussion on the Microsoft Community forums usually directs people to getting support from their various browser communities. In any case, perhaps, with time, this will all work itself out. I do sincerely appreciate the time you all took to reply.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

Helpful Reply

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Question owner

Hi everyone,

I have now tried all of the following below to resolve the problem I initially described. Just to reiterate: I use Outlook.com (web access) for my email. When a user right-clicks on an email folders that they created (not the default folders), a pop-up box with a drop-down menu is suppose to appear enabling a person to delete, rename or move a folder. That function does not seem to work if you are using FireFox browser version 19.0.2 That is, the pop-up box does not appear.

Here is what I have already tried (and thank you to those who have offered these solutions to try and help me resolve the issue.)

- I have optimized my FireFox (FireFox v 19.0.2) browser. (did not resolve the problem) - Ran FireFox in safe mode (did not resolve problem) - Made sure the "disable or replace context menu" was checked (did not resolve the problem) - Cleared cache and history (did not work) - Created a new profile as a test to check if my profile was causing the problem (did not work) - Completely removed all FireFox applications and folders, etc. on my hard drive and started all over again by reinstalling Firefox version 19.0.2 anew ( did not work)

I guess I still need assistance. Can anyone offer any other recommendations? I just don't have a clue now, given the possible solutions I tried, why I cannot seem to resolve this issue.

I have posted questions in Microsoft forums to tried and get help and no one there seems to have any solutions either. They keep pointed me to get help from Firefox support.

Any more help that someone can offer would be most appreciated.

xumix 0 solutions 1 answers

I use Firefox (15+) with outlook.com daily and have zero problems with right click on the folders. Do you use HTTPS address scheme? Try it if you don't. This may be some proxy/adblocker issue.

asserbo 0 solutions 1 answers

I have this problem too using my laptop. The Outlook folders are all dead except the Inbox. Trying to enter the Junk-folder or Sent-folder just returns to the same Inbox. I have tried to delete cookies, deleting and re-installing Firefox, but nothing helps. On other computers the same Firefox version works fine with my outlook account.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Hi asserbo, your problem is not that you are a missing right-click menu, but the folder doesn't open at all, or redirects to the Inbox? I think that probably has a different cause.

Did you try clearing your Firefox cache in case Firefox is applying a corrupted or obsolete script?

If that doesn't help, could you start a new question showing your OS, Firefox version, and add-ons? You can do that starting with this link:

https://support.mozilla.org/questions/new/desktop/websites

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96793 answers

See:

  • Tools > Options > Content : JavaScript > Advanced > Allow Scripts to:
  • "Disable or replace context menus"

You can also check the dom.event.contextmenu.enabled on the about:config page and make sure that it is true (i.e. has the default value and is not user set).