X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Snap.do search has hijacked my browsers startppage

Posted

I downloaded some program from cnet, which used to be a reputable source, but now seems to be riddled with malware. The item I downloaded was not what I thought it was and I promptly removed it from my computer. I also managed to remove snap.do toolbar from all my browsers and my computer with little effort. HOWEVER, I cannot seem to get rid of snap.do. It seems as though it has hijacked the startpage of all my browsers, IE, Chrome,Safari, and Firefox all show snap.do whenever I open them. Of course I can click past this and go to a different page with no trouble. I can reset the homepage in tools-internet options and every time I hit the little house button, I can go back to that homepage. BUT if I turn my browser OFF, when I turn it back on, snap.do is the homepage once more. I have run anti-malware from Kaspersky and Webroot, neither finding anything. I have reset Firefox. I have done a flushDNS through config. I have checked all the settings for the LAN, Internet protocol, and HOSTS folder. I have even reset the router to factory settings. I am at a complete loss. All I want is for my homepage to come up when I open my browser, any browser. Since Firefox is my preferred browser, I am asking you. Please help Running: Windows XP SP3 with latest available Firefox

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • iTunes Detector Plug-in
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Pando Web Plugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

It sounds like you have a third party program that has taken over your search engine, home page, and/or the default new tab page. Fortunately, this can be remedied easily:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP), and then click Add-ons. The Add-ons Manager tab will open.
  2. In the Add-ons Manager tab, select the Extensions panel.
  3. Select the toolbar you wish to remove.
  4. Click the remove button.
  5. Click "Restart now" if it pops up. Your tabs will be saved and restored after the restart.

After Firefox restarts, install the Search Reset Tool. This will remove the rest of the traces of this program from your Firefox.

For further information, please read Remove a toolbar that has taken over your Firefox search or home page.

Does this help your question? Let us know!

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Helpful Reply

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.

Question owner

I have already removed the toolbar and this snap.do does not show up in extensions, plug-ins or anywhere in the tools menu. In fact the only place I see snap.do is as the startpage when I first start up Firefox. Otherwise, it does not exist.

glennpenne 0 solutions 2 answers

I also couldn’t figure out how to uninstall Snapdo and the instructions in their Support section didn’t help. I emailed their customer support and they got back to me pretty quickly: contact@snap.do

Question owner

DId contacting them solve your problem? If so, how?

tech.shadow01 0 solutions 1 answers

I am please to announce the fix for snap.do . I couldn't believe how simple it was .

step 1 . Right click on firefox icon and go to propertie

step 2. In the Target bar it should only say "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

step 3. Erase anything that comes after "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Step 4. Once erased just simply apply changes then click OK .

step 5. Restart firefox an enjoy !!!!

let me know if this worked for you !

Modified by tech.shadow01

sillymoy 2 solutions 19 answers

It's happening again. Cnet is pushing this software. So, pay close attention to its "offers". In case you already installed it, a step by step Snap.do removal guide is located here:

http://deletemalware.blogspot.com/2013/01/remove-snap-do.html

Please note that in some cases, this app is not listed as a stand alone application, I mean it's a part of the app you installed. If you want to remove it completely you will have to re-install recently installed software. If none of these suggestions work, scan your computer with AdwCleaner.

manishmohan85 0 solutions 1 answers

Helpful Reply

Same problem I have also faced.

Just follow the below steps:

Type about:config in your url filed.

Now search for snap you will see search result related to snap. Right click on every result and set it to default.

Your problem will be solve.

Cheers!!!

anki3111 0 solutions 1 answers

Thanks a lot!!!

Ceit60 0 solutions 1 answers

Thank you thank you thank you - I have been trying for so long to get rid of this interloper - your advice worked :)

leomartintsa 0 solutions 4 answers

Yes.....I have solved it




I have solved this snap.do redirection issue using this article link http://www.techsupportall.com/how-to-remove-snap-do-search-from-chrome-firefox-ie/

WiKKiD 0 solutions 1 answers

To remove Snap.do, go to Control Panel on Windows -> Uninstall a Program -> find Snap.do and click Uninstall. Make sure to select "Custom" and NOT the "Next" button. Deselect the top option and the very bottom option, leaving only "remove snap.on" selected. This will remove the Snap.do software from your pc. This should allow you to reset your homepage and new tabs search page. To reset your tabs page, open a new tab, type in the location bar "about:config". This will open a file with your browsers configuration settings (after you select "I'll be careful, I promise!"). Type "browser.newtab.url" in the search bar of the page. Select the setting by double-clicking it. Normally this will be reset back to "about:blank", but you can set it back to "about:newtab" so that you get the page suggestions when opening a new tab. Enjoy!