X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Warn me when closing multiple tabs is not checked, but I still receive the warning when closing multiple tabs

Posted

So, I see there are prior threads on the topic dating back to Firefox 16. I'm at 19 now and the check box for "Warn me when closing multiple tabs" is still non-functional, that is, it's always on, even if unchecked. Why has this not been fixed? For those looking for a solution, this works (copied from https://support.mozilla.org/en-US/kb/tab-preferences-and-settings?esab=a&as=aaq)

Warn me when closing multiple tabs: When you close a window with multiple tabs, Firefox will ask you to confirm your choice. This prevents you from accidentally closing the whole window when you intended to only close the current tab. Uncheck this option to disable this warning and have Firefox automatically close the window.

Note: This setting has no effect on the warning when closing other tabs in a window. If you want to disable the warning when closing other tabs, set a preference to false:

In the Location bar, type about:config and press Enter.

The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page.

In the Search field box at the top, type browser.tabs.warnOnCloseOtherTabs. Double-click the browser.tabs.warnOnCloseOtherTabs preference to set its value to false.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.14.17.11865
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 4.1.10329.0
  • Picasa plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • CouponNetwork Coupon Activator
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Citrix ICA Client Plugin (Win32)
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • np-mswmp

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Easy YouTube Video Downloader 6.7 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}) (Inactive)
  • HP Smart Web Printing 4.51 (smartwebprinting@hp.com) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Skype Click to Call 5.6.0.8442 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9800 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0614
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 10-2-2012
  • driverDate2:
  • driverVersion: 9.18.13.697
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&type=827316
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnCloseOtherTabs: False
  • dom.max_script_run_time: 1800
  • extensions.lastAppVersion: 19.0
  • general.useragent.extra.microsoftdotnet: (.NET CLR 3.5.30729)
  • gfx.direct3d.checkDX10: False
  • keyword.URL: http://search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&type=827316&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1361835966
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1299029236
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

The checkbox in Options>Tabs relates to clicking the red "X" button at the top of the window when the window has more than one tab. But the language is general enough that you would think it covers your scenario as well. I guess someone either should change the language (e.g., Warn me when closing all tabs) or tie the two preferences together or add another checkbox.

Helpful Reply

Ahh, yes, I remember that warning as well. Apparently the check box has worked as I have forgotten about that additional warning. Anyhow, I agree - the wording does not distinguish well between the two scenarios. Supplying an option for both would be great.

Thanks for your reply.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

I don't know whether anyone here will take up the cause, so you might also submit the suggestion using Help > Submit Feedback.

Sue/Susan/Susie 0 solutions 2 answers

I was confused about this, as well. This was great info = very helpful. I've changed the configuration and now all other tabs close without warning. I agree that there should be another checkbox option in the settings tab. Not sure that tying the two together would be good because a user may want one without the other, or the option to manage them at any given time, separately, at least. I also recommend adding the instructions to change the configuration, for those of us who are comfortable using Boolean but may (did) not think to do this. I definitely did not think about it; I sometimes find it a challenge to change gears from artist to geek ;)

Again, this information was very helpful. I would like to use it in my training. If I do, may I link to your post to give you credit for showing me the way, as well as Mozilla's support page?

Question owner

Of course. Glad it helped!

Sue/Susan/Susie 0 solutions 2 answers

Thanks, Bob :) I will let you know when I use this and credit you.

pmohanta 0 solutions 1 answers

Helpful Reply

Long story short. 1) go to about:config 2) find browser.tabs.warnOnCloseOtherTabs 3) set the value (Hint: dbl click to to toggle value)

PouderedWater 0 solutions 2 answers

I still have this problem. I had it since FF 16. I had to downgrade to get around it. I run a lot of iMacro scripts and I use the close all tab command. iMacros can't close the FF pop-up window so all my macros stopped working.

I've check the problem is still there in safe mode. And I've checked the setting in about:config. And the options menu,

When will this get fixed? I'm stuck in FF 15 until there is a way to turn off that annoying pop-up. There is no reason not to be able to turn off that window. It's like being stuck with training wheels.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi PouderedWater, which dialog are you getting?

Did you set both of these preferences to false in about:config?

browser.tabs.warnOnClose
browser.tabs.warnOnCloseOtherTabs
PouderedWater 0 solutions 2 answers

That's it! Thanks so much.