X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why isn't download helper working?

Posted

I have been successfully using download helper for weeks. All of a sudden it just stopped working. The icon will animate for an advertisement but not for a video. I have been downloading from project free tv and have successfully downloaded over 100 videos in the last month. I have completely uninstalled and re-installed both firefox and download helper. Nothing seems to help.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • McAfee MSC FF plugin DLL
  • 5.1.10411.0
  • DivX VOD Helper Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • DivX Web Player version 2.1.2.265
  • npmnqmp 989898989877
  • Unity Player 2.6.1f3
  • npdnupdater2
  • npdnu
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • Office Plugin for Netscape Navigator

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • DivX Plus Web Player HTML5 <video> 2.1.2.126 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)
  • RealDownloader 1.3.0 ({34712C68-7391-4c47-94F3-8F88D49AD632}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) G33/G31 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x29c2
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.18592
  • driverDate: 1-2-2008
  • driverDate2:
  • driverVersion: 7.14.10.1409
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'7.1500.1000.1666']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'7.1500.1000.1666']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 53385
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No

Question owner

I am wondering if anyone has suggestions for me. Could I have too many plug ins? I am somewhat illiterate and when I was looking for a downloader and converter I did install several products before I decided that download helper worked best. It did. I would appreciate any help or suggestions from anyone. I am really missing my daily downloading and burning.  :-(

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Does it work if you do not use the converter and reset all dwhelper prefs on the about:config before reinstalling the extension?

Question owner

Um ok not sure  :-) I can't even get the icon to animate other than if it is an advertisement but not for any of the shows I have tried. I have clicked on shows from multiple sites (on project free tv) and the same thing. I am wondering if it could be their website issue?

In any case I am not sure how to reset all download helper prefs - could you explain?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Download helper works for me.

You can try to check for problems with the RealPlayer that offers a similar feature to download and save file.


Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean

See also:

Question owner

There are a number of dwhelper prefs - I should reset each one of them separately?

Question owner

Oh I just tried several and the reset button is not lighlighted - not giving me that option.

Helpful Reply

Still looking for help or suggestions. I have tried again today to uninstall and reinstall. I even did a search for all random mozilla files and deleted them. I was able to create a new profile - I did not import anything - fresh profile and still the download helper does not work at all. If I click on a show that run an advertisement - the icon will animate for the advertisement but not for any of the actual shows. I am not a skilled computer user but am trying to follow any and all suggestions.

I just don't get it. Does anyone know if there could be something else in my system that could be conflicting with this program? I have spent hours on this and am getting so frustrated!!!

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Only prefs that show as bold user set can be reset.
Prefs that have the default value can't be reset, but should disappear if you uninstall the extension that added them.

Did you try to disable all other extensions?

Question owner

Ok so for the ones that are user set I should change each one to a new one of whatever it is? This is a little above my scope of knowledge but willing to try anything at this point. I think I have made more of a mess. Now I have 2 profiles - download helper doesn't work on either one. I have all of the extensions disabled except download helper and even went in and disabled half the plug ins. No clue there were so many on there so I disabled any that were installed several years ago. Not sure if that was the best. There is a plug in for flash that keeps telling me I need to update - it is in red - and I update but it still shows as not being updated. I am wondering if that could be the problem. Still says it is vulnerable. Not sure where to start at this point.

Question owner

Ok so far I have uninstalled and reinstalled - created a new profile - gone into about:config and reset the user set browser files according to the help article. I still have no downloading - can anyone help me at all? What am I missing or not doing thoroughly or right?