X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

msn.com does not work with Firefox. The tab has the address and Bing logo, but the page is all white. Worked fine earlier but doesn’t work now.

Posted

msn.com does not work with Firefox.

The tab has the address and Bing logo, but the page is all white. Worked fine earlier but doesn’t work now.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • DivX Plus Web Player version 2.2.2.14
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • 5.1.10411.0
  • GEPlugin
  • DivX VOD Helper Plug-in
  • NPWLPG
  • Office Live Update v1.5
  • npmnqmp 989898989877
  • getplusplusadobe16260
  • npdivxplayerplugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

jscher2000
  • Top 10 Contributor
2380 solutions 21066 answers

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?

Note that if you log in to msn.com through live.com or another Microsoft site, you might need to clear cookies for that site as well.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97005 answers

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

BuckeyeBooster 0 solutions 1 answers

There appears to be a new MSN for Firefox 1.0 extension that has been enabled by default. I removed the site's cookies and disabled this extension and it is finally working again.