X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Wrong rendering by Firefox' built-in PDF viewer

Posted

There seems to be a render issue when opening this PDF: http://www.gp.org/real-difference/the-real-difference.pdf

At the bottom it shows: WWW.GP.o RG While in other PDF viewers it simply shows: WWW.GP.ORG

Modified by sicco

Chosen solution

It looks like this to me: http://i.imgur.com/E8phigb.png

It might be that this is an issue that was fixed recently. Please try it again in a nightly build: http://nightly.mozilla.org

If it displays fine, it will display fine in Firefox ~22 or so as well.

--Tobbi

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233
  • Version 2.0.3 Twoflower, copyright 1996-2011 VideoLAN and Authorshttp://www.videolan.org/vlc/
  • 4.0.51204.0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

{
"application": {
"name": "Firefox",
"version": "19.0.2",
"userAgent": "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0",
"supportURL": "http://support.mozilla.org/1/firefox/19.0.2/Linux/en-US/"
}

iamjayakumars
  • Top 10 Contributor
415 solutions 4909 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Tobbi
  • Moderator
67 solutions 450 answers

Chosen Solution

It looks like this to me: http://i.imgur.com/E8phigb.png

It might be that this is an issue that was fixed recently. Please try it again in a nightly build: http://nightly.mozilla.org

If it displays fine, it will display fine in Firefox ~22 or so as well.

--Tobbi

Question owner

It is indeed fixed in the nightly build. Thanks!

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Try the latest version of the PDF Viewer (pdfjs) extension.

madelharri 0 solutions 1 answers

I had a similar problem were links within a pdf document were being corrupted, so that the linked to document was not found when the link was clicked on. The problem only occurred in Firefox and not in any other browser. The nightly build didn't help me, and neither did downloading the latest version of the PDF viewer. But the problem was solved by going to options and changing the pdf viewer to "Use Adobe Acrobat (in firefox)" from "Use Adobe Acrobat (default)".