Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[SOLVED] [Firefox 19] How do I get Firefox to display local PDF files?

  • 5 replies
  • 5 have this problem
  • 120 views
  • Last reply by cor-el

more options

When I first installed Firefox 19, the PDF viewer worked so well that I uninstalled Adobe Reader. Today, after a system update, Firefox stopped displaying local PDFs. If I open a PDF directly from a website, the internal PDF viewer activates and the PDF is displayed properly. However, if I open a PDF from my hard drive, Firefox just displays a mass of jumbled characters and the internal PDF viewer does not activate.

Here is a screenshot of the behavior: http://i.imgur.com/5Of0kUH.png

I tried running in safe mode and the behavior persisted. I really hope there is a fix for this because using Firefox for viewing PDFs really makes my workflow much better.

EDIT -- SOLUTION IN REPLY

Modified by y9yjRQcg7F

Chosen solution

SOLUTION

  1. In terminal, type: # firefox -ProfileManager
  2. Create new profile.
  3. Start with said profile.
  4. Fixed. Internal PDF viewer will now work in either profile.
Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

SOLUTION

  1. In terminal, type: # firefox -ProfileManager
  2. Create new profile.
  3. Start with said profile.
  4. Fixed. Internal PDF viewer will now work in either profile.

Modified by y9yjRQcg7F

more options

This is relatively new. There will be issues, and I believe some bugs are scheduled to be fixed in later Firefox versions.

Problems of this type may conceivably only show on certain files. I have checked and I may open and view local pdfs in Firefox. (Using fx21.0a2 canonical on Ubuntu 12.04 )

Try a selection of files from different sources. If you use pdf s a lot the Firefox viewer alone may not suffice.

more options

Not sure I understand that.

A new profile may fix a problem, but how/why does that fix the original profile.

Never mind, glad it works, & thanks for posting back.

more options

@John99:

This problem was very specific. I have hundreds of PDFs on my local hard drive. Firefox was behaving that way every single time I tried to open any and all PDFs from my hard drive. However, it never failed to open correctly when I was opening a PDF from a website.

Anyway, it seems bizarre to me that creating a new profile would fix the problem since I had tried safe mode, and it didn't work. Even more bizarre is the fact that going back to the old profile proves the problem is fixed there as well. I have no idea why this worked, I just know that it did.

Modified by y9yjRQcg7F

more options

This can probably be fixed by deleting the mimeTypes.rdf file in the Firefox profile folder.