X
Tap here to go to the mobile version of the site.

Support Forum

How do I turn off the prompt to launch in safe mode?

Posted

I noticed that since Firefox 18 on Windows 8 I have observed the safe mode window here: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode?esab=a&as=aaq#w_safe-mode-window_2 pop up when Firefox crashes asking me to launch in Safe Mode.

This window is useful, but I would like to turn it off. The circumstances under which I'm using Firefox require that it just loads into the browser window immediately (I'm doing automated browser testing. The reason my browser stopped is that I killed it with my script sending the command 'taskkill /f /im firefox.exe' or 'killall -9 firefox')

The safe mode window doesn't always load for me. I've only noticed it on Windows 8, not on any other platforms, but it does force intervention from me to proceed, which I want to avoid.

Any assistance in turning it off would be appreciated.

I noticed that since Firefox 18 on Windows 8 I have observed the safe mode window here: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode?esab=a&as=aaq#w_safe-mode-window_2 pop up when Firefox crashes asking me to launch in Safe Mode. This window is useful, but I would like to turn it off. The circumstances under which I'm using Firefox require that it just loads into the browser window immediately (I'm doing automated browser testing. The reason my browser stopped is that I killed it with my script sending the command 'taskkill /f /im firefox.exe' or 'killall -9 firefox') The safe mode window doesn't always load for me. I've only noticed it on Windows 8, not on any other platforms, but it does force intervention from me to proceed, which I want to avoid. Any assistance in turning it off would be appreciated.

Chosen solution

hello, you could try this - enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named toolkit.startup.max_resumed_crashes. double-click it and change its value to something very high like 999999 (maybe setting it to 0 or -1 will also work, however i haven't tried that myself).

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The IcedTea-Web Plugin executes Java applets.
  • The Totem 3.4.3 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2820 solutions 13110 answers

Chosen Solution

hello, you could try this - enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preference named toolkit.startup.max_resumed_crashes. double-click it and change its value to something very high like 999999 (maybe setting it to 0 or -1 will also work, however i haven't tried that myself).

hello, you could try this - enter '''about:config''' into the firefox location bar (confirm the info message in case it shows up) & search for the preference named '''toolkit.startup.max_resumed_crashes'''. double-click it and change its value to something very high like '''999999''' (maybe setting it to <s>0 or</s> -1 will also work, however i haven't tried that myself).

Modified by philipp

cor-el
  • Top 10 Contributor
  • Moderator
12001 solutions 111508 answers

The -1 value for toolkit.startup.max_resumed_crashes should work to disable Safe mode.

The -1 value for toolkit.startup.max_resumed_crashes should work to disable Safe mode. *http://mxr.mozilla.org/mozilla-release/source/toolkit/components/startup/nsAppStartup.cpp#975
philipp
  • Top 10 Contributor
  • Moderator
2820 solutions 13110 answers

thanks for pointing that out!

thanks for pointing that out!

Question owner

thanks!

thanks!