X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Starting today, Firefox will not open Adobe Acrobat files in Adobe Reader, despite my putting Reader as default in Applications tab.

Posted

Until today, I had no trouble opening Adobe Acrobat files with Adobe Reader 9.5. (I need to use an old version of Adobe Reader, because I use a program called Macro Express that does not recognize later versions.) Starting this morning, when I click on an Acrobat file, I am asked which program I want to open it with. Even when I click "Do this automatically...", it doesn't do so. It asks me every time. I went into Tools, Applications, and changed all of the pdf related issues to open with Adobe Reader 9.5. This also doesn't work.

Chosen solution

go to firefox options > applications & define the default action for the portable document format (pdf).

View PDF files in Firefox without downloading them

Read this answer in context 29

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.3"
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Motive Plugin for Mozilla Browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

alco 18 solutions 141 answers

Hi KevinBrau,
you could try the Adobe Reader plugin for Firefox. Details on how to use it can be found in this article:

Use the Adobe Reader plugin to view or download PDF files

Also, have a look at this article:
View PDF files in Firefox without downloading them
Hope that helped you! Please report back!

pheP 0 solutions 2 answers

Firefox 19 will not open Abode Acrobat in an external Acrobat window. The document is opened within the browser but not as an Acrobat document as far as I can tell - I can't save it and the text is fuzzy (screen shot enclosed). This just started with version 19. I don't have any acrobat plugins, my Acrobat internet preference is unchecked for open in browser, and Acrobat 9.5 is set as the default program to open pdfs in applications. Internet Explorer opens identical pages directly into Acrobat, and not within the browser. This seems to be a FF19 issue. The only other issue is that I had a failed Javascript update installation earlier today (FF19 was installed automatically today as well). Any help would be welcomed. thanks

hohoking 0 solutions 2 answers

This is a new build-in feature together with Firefox 19.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Chosen Solution

go to firefox options > applications & define the default action for the portable document format (pdf).

View PDF files in Firefox without downloading them

pheP 0 solutions 2 answers

Thank you for letting me know about the built-in pdf reader in FF19.

However it takes some doing to be able to use Acrobat to view the files externally. Simply setting the options for pdfs to open in Acrobat does not work - I already had checked this setting to make certain that it pointed to Acrobat for pdfs. What I had to do was two things:

1) In the config file I had to set pdfjs to true, as detailed in the above kb link 2) I had to enable an Acrobat plug-in

With this I can now click on a pdf link in the browser and have it open externally in Acrobat.

At least this worked for the one PC that I got to work, which has Acrobat 10 and an Acrobat 10 plugin. Firefox does not like the Acrobat 9.4 plugin, so I'm not sure that I will be able to get this to work on my machine with Acrobat 9.4.

It would certainly be nice if FF fixed the built-in viewer so that it obeyed the options settings, or included some other easy fix. This was apparently a bug in the past but supposedly had been fixed.

If all else fails then I discovered that the built-in pdf reader has an action button that will allow download of the document.

hohoking 0 solutions 2 answers

Helpful Reply

What I did was to reinstall/upgrade Adobe Reader, then there is an new option showing up in Firefox > options > applications > Portable Document Format(PDF), which is "use adobe acrobat in Firefox". Choose this one, then I managed again to open PDF files with Adobe Reader internally in Firefox.

Modified by hohoking

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to delete the mimeTypes.rdf file in the Firefox Profile Folder to reset all file actions.

rtroper 0 solutions 1 answers

Starting today, Firefox will not open Adobe Acrobat files in Adobe Reader, despite my putting Reader as default in Applications tab. I have the same problem. I have performed most of the above suggestions except the last one which is too complicated. Can't Mozilla fix this problem. I am only able to print pdf files if I first download them. Please help.

uoptions 0 solutions 6 answers

Thank you! I thought that I was losing my mind. C'mon developers, this is kind of a biggie. I went back to ver 18.x until this is fixed.

I got ver 19 to work thanks to the suggestions above from the 'Tools, Options, Applications' menu and re-set all instances of 'Content Type' to use the Reader directly. I'll try it with the later suggestion of re-configuring the 'Portable Document Format' to Adobe Acrobat in Firefox. I have a Professional version of Adobe and have to admit that I rather like opening these documents directly in Adobe Pro with access to the full range of menu functions.

I was reminded of the usefulness of manually configuring how Firefox handles applications from this 'ladybug'. But hey, my preferences still don't help the unsuspecting users who suddenly discover that the Reader won't work at all.  :-).

Thanks, again, for the totally excellent help.

Modified by uoptions

Question owner

Yes, it's them, not us. I used a Macro Express utility to toggle between "Save" and "View". (It's time consuming to do open Tools Options Applications etc manually each time.) This is unwieldy, but workable. Of course, not a practical solution for other people. Thanks for your suggestion to return to version 18.

uoptions 0 solutions 6 answers

Thanks, Kevin! I reconfigured Adobe as per the suggestion above for the Reader. It now works in ver 19 the way that I want the application to work by opening my version of Adobe Pro directly. So, I was reminded of the beauty of manually controlling how Firefox handles applications.

Nevertheless, this 'opportunity' reminded me that Mozilla was aware of the problem and still released ver 19 on its unsuspecting user base. A more proactive release might have included an alert for all users on how to fix the Adobe Reader problem temporarily by reacquainting their users with the manual configuration settings for the handling of applications in Firefox. Just a thought from a humble and lowly user.

Mozilla is the true humanitarian here with its free and fantastic browser (using it since the very beginning all those vers ago...:-), that somehow the sides might find a way to come together and fix this essential element of the web browsing experience. I'm hoping that it's not about intellectual property or anything litigious. Enough already from the bad precedent of the entertainment industry that harms everyone.

Good luck & be well!

Modified by uoptions

uoptions 0 solutions 6 answers

Thank you! That worked!

Raven23 0 solutions 2 answers

My Adobe Reader 10.1.4 is the latest version for Windows Vista. As of today (5-4-13). It keeps prompting me to update to 10.1.6, and everytime I try... Adobe will not give the option because of Windows Vista.

Even my Antivirus program: It runs scans, to keep all my software up-to-date. It will not install the latest version either.

I had contacted Adobe; and of course they asked: "what browser do you use?" .... "well, you have to contact the browser developer..." blah blah blah. I could put my first through the screen!

Funny thing, my Adobe Reader works fine! It is set to default here in FF Version: 20.0.1 and opens my documents no problem. I just have this thing: when I check my plugin updates, it says Vulnerable! I will attach a screen shot (scanned and safe). The screen shot will be of the FF plugin page, and my antivirus program's software updateer screen.

Also: my antivirus program is working overtime, because it keeps trying to install the latest version of Adobe Reader which, I already have!

Thanks everyone Just wanted to report this

harrietvane 0 solutions 2 answers

I had a variation on this same problem--both Acrobat 9 and Reader 10.7 installed, along with the latest Acrobat plugin, but Firefox was downloading all PDF files instead of viewing them in the browser. I was really stumped by this, because it previously worked just fine. I spent the entire day and much of last night trying to fix this problem. I followed the instructions given here about disabling the Firefox pdf viewer and deleting the mimetypes.rdf file, but realized that this is a mistake: If you disable pdfs.js in about:config, that will cause the PDF file type to disappear from the Tools/Options dialog, so you can't assign it to another program (whether Adobe or anything else).

I was ultimately able to fix the problem, but had to figure out how through trial and error. This is what I learned:

1. Acrobat and Reader conflict with each other in Firefox, but this isn't totally Firefox's fault. It's mostly Adobe's fault, and they pretty much admit it. Specifically, they say that Acrobat and Reader can't coexist on the same machine unless both are version 10 or higher. They tell you to upgrade to solve the problem--but I can't afford to pay for a new version of Acrobat. If you have to keep Acrobat 9.x, the lowest version of Reader that will work with it is Reader 11. I couldn't upgrade to this because I have Vista, and Adobe hasn't issued Reader 11 for Vista, and doesn't plan to. I did cheat and download the Win 7 version of Reader 11, but it didn't help.

2. If you have both Acrobat and Reader, you can choose a setting in Reader to make it the default PDF handler--but Firefox ignores this information and defaults to Acrobat no matter what. (This is the part we can blame Firefox for.) If you have a version of Acrobat which is below 9.5.5, Firefox actually blocks it as a security risk, so the plugin won't work at all, regardless of version number. That's why PDFs are being downloaded through your standalone program instead of being displayed in the browser. If you want to view PDFs in Firefox and keep Acrobat on your computer, you MUST upgrade Acrobat to version 9.5.5 or above.

3. If you can't upgrade Acrobat all the way to 11.x, GET RID OF READER. As long as you can access Acrobat 9.5.5, it will work fine in Firefox and there's no need for Reader. I never used to have Reader myself, only Acrobat, but it must have been downloaded automatically when Acrobat was blocked by Firefox (which I didn't even realize).

4. IF YOU NEED TO UPGRADE ACROBAT 9.X TO 9.5.5, YOUR LAST CHANCE IS TODAY--6/26/13. Adobe has announced that today is the "end of life" for the Acrobat 9.x platform, and all support and upgrades will cease after today.

5. Once you have Acrobat 9.5.5, this is how to enable it in Firefox:

a. INSIDE ACROBAT, set your preference for "Internet" to "view PDF files in browser." Close Acrobat. Close Firefox if it's already open.

b. Reopen Firefox. Check Tools/Add-Ons/Plugins to make sure the Acrobat plugin is there. Enable it if disabled. Close Firefox.

If the plugin isn't there at all, repair your Acrobat installation through Control Panel. Then return to Firefox and enable it. Close Firefox.

c. Reopen Firefox again. Go to Tools/Options and check the list of file types. For the names that contain "Adobe" and "Acrobat," Acrobat should be set as the default program to open them. Select it from the drop-down list if it's not. Continue to scroll through the alphabetical list--you should see another entry called Portable Document Format. If it's there, the default will be "preview in Firefox." You should be able to change this to "Acrobat (in Firefox)" using the drop-down menu. Do NOT pick the option that says "Acrobat"--this is the standalone program and will cause your PDFs to be downloaded.

If you don't see "Acrobat (in Firefox)" as an option, this means your plugin is not working. Go back and fix it using the instructions above (including repair of Acrobat if necessary).

d. If you don't see a file type for "Portable Document Format" at all, that means the Firefox PDF viewer is disabled. You must enable it by editing the about:config file. To see it, type about:config in the Firefox address bar. You will get a warning message--just click OK and keep going.

This file is a long list of statements in alphabetical order. LOOK FOR A STATEMENT THAT SAYS "pdfjs.disabled" with a Boolean value of "true." Select this statement and right-click. A context menu will offer you choices including "Toggle." Select that one, which will change the Boolean value to "false." Exit about:config. Close Firefox.

e. Now return to Tools/Options, scroll through the list of file types, and you should see "Portable Document Format." Select "Acrobat (in Firefox)" as in the instructions above. Close Firefox.

f. The first time you try to open a PDF file in Firefox, you may get a dialog box which offers you choices of how to open the file. The first will be Acrobat, but DON'T CHOOSE THAT--it will cause your PDF to download. Instead, go to the choice that says "Open as application/pdf." You don't need to change the program that opens this file type, because your settings are already correct. Your PDF should open in the browser, with the full-featured Acrobat menu (including the option of editing or saving the file).

I hope other users can benefit from the truly painful experience I had figuring all of this out. Good luck.