X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

services.addons.mozilla.org uses an invalid security certificate.

Posted

I try to get a addon and I only get this:

This Connection is Untrusted

         You have asked Firefox to connect

securely to services.addons.mozilla.org, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

         What Should I Do?
         
           If you usually connect to

this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

       services.addons.mozilla.org uses an invalid security certificate.

The certificate is not trusted because no issuer chain was provided.

(Error code: sec_error_unknown_issuer)


I try your automatic trouble shooter and it says this:

Connection failure

Additional System Details

Application

  • User Agent:

More Information

Application Basics
Name
Firefox
Version
18.0.2
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Skip Cert Error
0.3.3
true
skipcerterror@foudil.fr
Troubleshooter
1.0a
true
troubleshooter@mozilla.org
AVG Security Toolbar
14.2.0.1
false
avg@toolbar
DivX Plus Web Player HTML5 <video>
2.1.2.145
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
Skype Click to Call
5.10.0.9560
false
{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
4
browser.search.update
false
browser.startup.homepage
www.dogile.com
browser.startup.homepage_override.buildID
20130201065344
browser.startup.homepage_override.mstone
18.0.2
extensions.lastAppVersion
18.0.2
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.default_personal_cert
Select Automatically
security.enable_tls
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 9500 GT
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM
512
Device ID
0x0640
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
Driver Date
10-15-2011
Driver Version
8.17.12.8562
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x10de
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 9500 GT)
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3019 answers

Helpful Reply

This is an odd issue. Please try clearing cache and cookies as I don't have this issue. Please also make sure that you date and time of your pc is correct as this may be the cause as well.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Check out why the site is untrusted (see the Technical details) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

Tattoo 0 solutions 2 answers

Helpful Reply

i also have this problem with firefox 22 can't install add on's because of security certificate...but also...i can't use google at all, as says the same untrusted...also facebook..(untrusted) ebay sign in (untrusted) using windows 7 fresh install.(fully updated)..no problems with clock!! but ff 22 is literally unusable...and when i did manage to get to add on page it looked like safe mode(all blue text)...it does the same when first going to ebay...i used ff as default browser..but now its intolerable.

Tattoo 0 solutions 2 answers

i checked the details of the untrusted certificate....it was issued by kaspersky (my anti virus) is this the reason i can'y use ff but can use ie or chrome?

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Hi Tattoo, it sounds like your Kaspersky software is intercepting secure connection so it can filter them.

You probably can turn off this feature and make your secure connections directly.

However, I do see a solution on the Kaspersky forums that could try if you want to keep this feature turned on: