X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot edit email messages before sending

Posted

When composing a message in email (it happened while composing this message the first time also); if I have to move the cursor for any reason, I get an alert sound from the computer and can do nothing else without cancelling the message and starting over. This does not happen in safari which I switched to, but I don't like as well.

I removed Firefox from my computer and reloaded it, but the problem persists.

Mac 10.6.8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Garmin Communicator Plug-in Version 4.0.4.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6
  • Facebook Video Calling by Skype
  • Coupons Inc., Coupon Printing FireFox Plugin
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Garmin Communicator Plug-in Version 2.9.1.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.2
  • RealPlayer Plugin
  • Simplifies the uploading of photo files.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4931 answers

Helpful Reply

Update to latest version of Firefox 18.0.2 and give a try in safe mode...

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

Safe mode worked. I'll try the troubleshooting site next.

Question owner

Following the instructions, I found a few extensions that I didn't want anymore and removed them. Everything is back to normal now, and the machine is running faster too. Thanks for the help!

iamjayakumars
  • Top 10 Contributor
416 solutions 4931 answers

Cool, make sure your extensions are updated!