X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Sometimes I just want to close ONLY one window, but Firefox is closing ALL TABS, and I don't want this!

Posted

I sometimes will open several windows, especially from my Comcast mailbox. When I am through with that window, I will close it, but leave the other ones open. FIrefox won't do this any more, When I close 1 window, Firefox send me a message stating that it is CLOSING ALL TABS. I DONT WANT TO CLOSE all of them, I just want to close the window I am closing!. This is very annoying, because I have to re-log back into everything, because FIrefox is "CLOSING ALL TABS", and all I want to to close ONE window...I am about ready to chuck this browser....I tried to find an answer to this in tools, but was unable to do so. Please help me with this

Chosen solution

Make sure that you do not click the close X on the title bar as that closes the current window with all tabs.

If you have the tab bar visible then click the close X on that tab or middle click the tab or use the Ctrl+W shortcut key to close the tab.

If the tab bar got hidden then see:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Acrobat Plug-In Version 7.00 for Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Use CTRL+W - to close the surrent tab.

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

Make sure that you do not click the close X on the title bar as that closes the current window with all tabs.

If you have the tab bar visible then click the close X on that tab or middle click the tab or use the Ctrl+W shortcut key to close the tab.

If the tab bar got hidden then see:

Question owner

CONTROL-W -----THAT WORKS!!!!!!! ....YAY! I'm all set and fixed..problem resolved. THANK YOU all so very much.

Karl1950