X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to Change background on address and search bar- It ruins my personas

Posted

I am hooked on personas however the address bar and search bar are glaringly white instead of transparent like the rest of the upper page. This totally destroys the continuity of the photo. I would like to make those bars, as well as everything above the reading pane transparent like the upper tool bar so that the only thing that shows is the icons and text. I have tried dozens of search terms, none address this issue. Firefox 18.01. Can anyone help resolve this? Screen shot available.

Thanks

Chosen solution

You need the @namespace line at the start of the userChrome.css to avoid namespace conflicts.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • DRM Netscape Network Object
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.

________________________________________________________________________________


In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

In order to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.

Question owner

iamjayakumars Thank you for responding. I followed your instructions and found the keyword url reset greyed out and not accessible. My issue is not with the contents of the bar or how to change the search engine, it is with the background shading of the bar itself. It is white and I wish to make it clear like the area around the menu bar area (File edit view etc.) I don't want to see anything except the icons and associated text including the tabs. Make it all disappear...? Is this even possible? Screenshot included. Thanks wolfman7h <^|^>

iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Add code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.

You can experiment with code like this:


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar {opacity: 0.5!important}
#urlbar:hover {opacity: 0.8!important}
#urlbar[focused="true"] {opacity: 1!important}

#searchbar .searchbar-textbox {opacity: 0.5 !important}
#searchbar .searchbar-textbox:hover {opacity: 0.8!important}
#searchbar .searchbar-textbox[focused="true"] {opacity:1 !important}

Question owner

cor-el - Bingo! Your fix was exactly what I was looking for. - Thank you - I searched all files for the chrome folder, of course there was none. I located the profile folder by - Help> troubleshooting information> (press "show folder" button) which resulted in a tab called "about:support" and brought me to the profile page which was well hidden. No chrome folder existed so I created it and then created the "userchrome.css" file. I did a copy/paste of your code, tweaked it a little and there it was... I set the opacity to 0.3, 0.5 and 0.7 respectively. Now I can see more of the photo and less of the junk. (I call anything that obscured the persona as junk). Now I will try to do the same for the other bars, although I am not sure what to call them - browser.tabs, tabbar, I am not sure but so far you have helped me fix an annoying problem. - Thanks for your help and thanks to all who took the time to respond. - wolfman7h - <^|^>

jastro_ 0 solutions 3 answers

Hey wolfman i was wondering if you can do a copy and paste of your code you have in the userchrome.css file

Question owner

My userchrome.css file looks like this with no other entries. Do not use the @namespace.url entry. This will only display well in the screenshot. If not, email me and I will send you the code.

jastro_ 0 solutions 3 answers

Helpful Reply

yea i cant view it

Question owner

check your email & try this one.

jastro_ 0 solutions 3 answers

that one works thanks :)

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97065 answers

Chosen Solution

You need the @namespace line at the start of the userChrome.css to avoid namespace conflicts.

Question owner

As for COR-EL's @namespace.url, When I first created the file I did a copy/paste as given and it did not work, without it it did work. I just retried it again and it worked where it did not before. If it works for you that's good. In any case the code should work now