X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mouse cursor flickers from arrow to hand as I drag it across the screen, especially over links

Posted

When I move the mouse over anything on the screen it flickers. When I move it across a hyperlink it flickers from an arrow to a hand. This flickering is so quick and constant that it has become an annoyance and is enough to drive me back to using Safari full time. I cant figure out how to stop this. I have deleted and reinstalled a fresh copy of Firefox, but that didnt help. I tried restarting with plug ins off and that didnt stop it.

Chosen solution

Problem resolved. I upgraded this afternoon to the latest version of Java and this issue no longer happens. Thanks for the suggestions.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Office Live Update v1.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
411 solutions 4868 answers

Helpful Reply

Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Question owner

This is an iMac. There is no Tools>Options. Hardware acceleration is not something I can control on an iMac as far as I know.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You can disable hardware acceleration in Firefox on a Mac here:

Question owner

I want to avoid making significant changes to my environment. I do not have these problems with any other application, nor is this a problem in Safari. It just started and I cant tell if it was due a firefox upgrade or something else. Any other thoughts?

Chosen Solution

Problem resolved. I upgraded this afternoon to the latest version of Java and this issue no longer happens. Thanks for the suggestions.

pablox_cl 1 solutions 5 answers

I started to have this problem too after upgrading to Firefox 21.0. It stopped after I disabled hw acceleration. I hope this get solved in the future.