X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox 18.0.1 try to see the .m4b I'm trying to download as an .mp4?

Posted

I'm trying to download an .m4b (Apple Audiobook format) file on my Macbook Pro (OS 10.8.2) with Firefox 18.0.1. When I do, Firefox opens a new tab like it's going to download the file, but then loads the m4b into what I assume is the Quicktime plugin for Firefox and starts playing it. When I mouse over the tab, the tip that pops up says:

"filename.m4b (video/mp4 Object)"

I tried it on my iMac (OS 10.8.2) running Firefox 17.0.1 and the file downloaded correctly as an m4b. What gives?

I'm trying to download an .m4b (Apple Audiobook format) file on my Macbook Pro (OS 10.8.2) with Firefox 18.0.1. When I do, Firefox opens a new tab like it's going to download the file, but then loads the m4b into what I assume is the Quicktime plugin for Firefox and starts playing it. When I mouse over the tab, the tip that pops up says: "filename.m4b (video/mp4 Object)" I tried it on my iMac (OS 10.8.2) running Firefox 17.0.1 and the file downloaded correctly as an m4b. What gives?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • iPhoto6
  • Amazon MP3 Downloader Plugin 1.0.17
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The iLok Client Helper Plug-in v3.5 allows you to use iLok.com to manage your iLok hardware keys. For more information, visit the iLok.com Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Gingerbread Man 403 solutions 1537 answers

In the Applications category of the Preferences window, check if you have an entry for video/mp4. If it's there, make sure it's not set to “Use QuickTime Plug-in (in Firefox)”.

In the Applications category of the Preferences window, check if you have an entry for ''video/mp4''. If it's there, make sure it's not set to “Use QuickTime Plug-in (in Firefox)”. * [[Change what Firefox does when you click on or download a file]]

Question owner

I tried that (just now). I have a Video-MPEG4 entry that I set to Always ask, and a QuickTime Player.app Document (video/mpeg), but none at all that have video/mp4.

I tried that (just now). I have a Video-MPEG4 entry that I set to Always ask, and a QuickTime Player.app Document (video/mpeg), but none at all that have video/mp4.