X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to make address and awesome bar not auto-expand?

Posted

I'm looking to customize firefox's appearance. I want two rows: one with the menu button, tabs, and awesome bar (in that order), and another with the forward/back buttons, address bar, home button, and bookmarks toolbar items (also in that order).

In both cases, the address bar and the awesome bar expand to fill all of the empty space (ei. my awesome bar starts spanning almost the entire row) and shrink as more items are added (ei. as I open more tabs). I would like to make it so they have a set size.

Chosen solution

Add code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-container { max-width:400px!important; }
#search-container { max-width:200px!important; }
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The IcedTea-Web Plugin executes Java applets.
  • 4.0.51204.0

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Application Basics
Name
Firefox
Version
18.0
User Agent
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Ghostery
2.8.4
true
firefox@ghostery.com
HTTPS-Everywhere
3.1.3
true
https-everywhere@eff.org
Novell Moonlight
3.99.0.3
true
moonlight@novell.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size_cached_value
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.places.smartBookmarksVersion
4
browser.search.useDBForOrder
true
browser.startup.homepage
http://duckduckgo.com/
browser.startup.homepage_override.buildID
20130109143032
browser.startup.homepage_override.mstone
18.0
dom.mozApps.used
true
extensions.lastAppVersion
18.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358371934
places.history.expiration.transient_current_max_pages
39555
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
GLXtest process failed (exited with status 1): X error occurred in GLX probe, error_code=11, request_code=152, minor_code=3
GPU Accelerated Windows
0/3 Basic Blocked for your graphics driver version. Try updating your graphics driver to version <Anything with EXT_texture_from_pixmap support> or newer.
WebGL Renderer
Blocked for your graphics card because of unresolved driver issues.
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0
3.14.1.0 Extended ECC
NSSSMIME
3.14.1.0
3.14.1.0 Extended ECC
NSSSSL
3.14.1.0
3.14.1.0 Extended ECC
NSSUTIL
3.14.1.0
3.14.1.0

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97003 answers

Chosen Solution

Add code to the userChrome.css file below the default @namespace line.

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the user profile folder.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#urlbar-container { max-width:400px!important; }
#search-container { max-width:200px!important; }

Question owner

Thank you! It took me a while to get around to doing this, hence the late response, but it works like a charm!

Cheers, Steavio99

lapsangleaf 0 solutions 4 answers

Well, either this doesn't work for me (using ff 22 on OS X 10.8.4) or I'm getting something wrong. Could you, perhaps, simplify this workaround even more? Thanks.

Question owner

These directions are found within the articles cor-el linked to. Here they are simply:

Go to help->troubleshooting. Click the button 'show folder', next to 'profile folder'.

Create a new folder named 'chrome'.

Open up TextEdit (for non-mac OS: use notepad or your favorite text editor). Copy in the lines at the end of cor-el's message (from "@namespace" onward).

Save the file in the folder you just created (chrome) and name it 'userChrome.css'. I don't use mac, but there's probably some option of what format to save it in. Choose 'plain text' or 'all formats' or something like that.

Restart Firefox. Your panels should now be a fixed width. You can experiment with changing the values 400 and 200 to make the panels longer or shorter to your needs.

lapsangleaf 0 solutions 4 answers

Helpful Reply

That's exactly what I did. I created a chrome folder here: (home)/Library/Application Support/Firefox/Profiles/(....default)/chrome Within which I created a userChrome.css file that reads:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. urlbar-container { max-width:400px!important; }
  2. search-container { max-width:200px!important; }

It hasn't worked.