X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to Stop Firefox 18 From Restoring the Previous Session After a Crash

Posted

Firefox 18.0.1 running on Windows 7

When Firefox crashes, the next time it opens it tries to restore the previous session. I do not want Firefox to restore the previous session after a crash. How do I prevent Firefox from restoring the previous session after a crash?

Please note: 1- My home page is set to "blank page" 2- I have configured Firefox to NOT remember my browsing history, download history, form fields and passwords. 3- Even in Safe Mode (i.e., with all add-ons disabled), Firefox STILL restores the previous session after a crash.

Chosen solution

Thanks very much for your help. I hope my vote pushes you into the 'TOP 9' category.

Read this answer in context 4

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

Application Basics
Name
Firefox
Version
18.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Adblock Plus Pop-up Addon
0.5
true
adblockpopups@jessehakanen.net
BetterPrivacy
1.68
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Comment Snob
4
true
youtube-comment-snob@efinke.com
Customizations for Adblock Plus
1.0.3
true
customization@adblockplus.org
DoNotTrackMe
2.2.5.1205
true
donottrackplus@abine.com
Element Hiding Helper for Adblock Plus
1.2.3
true
elemhidehelper@adblockplus.org
LastPass
2.0.0
true
support@lastpass.com
Print pages to PDF
0.1.8.0
true
printPages2Pdf@reinhold.ripper
Xmarks
4.1.3
true
foxmarks@kei.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
0
browser.cache.disk.smart_size.first_run
false
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
4
browser.search.suggest.enabled
false
browser.search.useDBForOrder
true
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20130116073211
browser.startup.homepage_override.mstone
18.0.1
browser.tabs.warnOnClose
false
browser.urlbar.autocomplete.enabled
false
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
dom.mozApps.used
true
extensions.lastAppVersion
18.0.1
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1358543218
places.history.enabled
false
places.history.expiration.transient_current_max_pages
52252
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.offlineApps
true
privacy.clearOnShutdown.passwords
true
privacy.clearOnShutdown.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Q45/Q43 Express Chipset
Adapter Drivers
igdumdx32 igd10umd32 igd10umd32
Adapter RAM
Unknown
Device ID
0x2e12
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 8.1500.1000.2202 or newer.
DirectWrite Enabled
false (6.1.7601.17789)
Driver Date
7-28-2009
Driver Version
8.15.10.1855
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 9
Vendor ID
0x8086
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset)
AzureCanvasBackend
cairo
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

philipp
  • Top 10 Contributor
  • Moderator
2054 solutions 8922 answers

Helpful Reply

hello Bulldogger, please try the following in order to switch off sessionrestore completely: enter about:config into the firefox location bar (confirm the info message in case it shows up) & search for the preferences named browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo. double-click on those entries and change both of their values to 0.

http://kb.mozillazine.org/Browser.sessionstore.max_tabs_undo http://kb.mozillazine.org/Browser.sessionstore.max_windows_undo

Chosen Solution

Thanks very much for your help. I hope my vote pushes you into the 'TOP 9' category.